Forum Xamarin.Forms

Build error when deploying to physical iOS device

TylerKellyTylerKelly USMember ✭✭
edited June 2016 in Xamarin.Forms

I have a Xamarin.Forms project that work great on the iOS simulator. I have attempted to deploy to a correctly partitioned iOS device (iPhone 6s on 9.3) and I am getting the following strange error:

 /Library/Frameworks/Mono.framework/External/xbuild/Xamarin/iOS/Xamarin.iOS.Common.targets: Error: System.IO.FileNotFoundException: /Users/tkelly/Projects/Attendance/iOS/obj/iPhone/Debug/build-iphone8.1-9.3.2/ibtool/LaunchScreen.storyboardc/01J-lp-oVM-view-Ze5-6b-2t3.nib does not exist
File name: '/Users/tkelly/Projects/Attendance/iOS/obj/iPhone/Debug/build-iphone8.1-9.3.2/ibtool/LaunchScreen.storyboardc/01J-lp-oVM-view-Ze5-6b-2t3.nib'
  at System.IO.File.Copy (System.String sourceFileName, System.String destFileName, Boolean overwrite) <0x1a24c50 + 0x00333> in <filename unknown>:0 
  at Xamarin.MacDev.Tasks.SmartCopyTaskBase.CopyFile (System.String source, System.String target, System.String targetItemSpec) <0x48c2fa8 + 0x000c7> in <filename unknown>:0 
  at Xamarin.MacDev.Tasks.SmartCopyTaskBase.Execute () <0x48c2770 + 0x002bf> in <filename unknown>:0  (Attendance.iOS)

Does anyone know about this error? I cannot find anything on google about this.

Thanks for any help



  • TomasWinstonTomasWinston IEMember ✭✭

    Hi Tyler,

    Sorry to drag this up if you have moved on from the issue already ... but can I ask - did you get this resolved? I am encountering the same issue. Works OK on simulator but giving problems building to physical device....

    Any advice?



  • MattPerryMattPerry USMember

    I've hit exactly the same issue today...

  • TylerKellyTylerKelly USMember ✭✭

    I had a couple similar errors at start up so I'm not exactly what fixed this for me but I think I just created a new Xamarin.Forms project in xamarin studios and restarted the whole project (copying over the previous files) and then it seemed to work fine...

  • NeelamNeelam USMember

    Any one get the solution? I am facing the same issue. Works fine on simulator but not on device. Same errors. Please help....

  • Jesse_JiangJesse_Jiang USMember ✭✭✭

    Delete the Bin and Obj folders, sometimes it will work

  • MikaYMikaY USMember

    @JesseJiang.8365 said:
    Delete the Bin and Obj folders, sometimes it will work

    Worked for me, thanks! I'm new to Xamarin.Forms, and the sheer number of these weird errors is, to me, startling.

  • AmruthaTamanam.iosAmruthaTamanam.ios USMember ✭✭
    edited January 2017

    ""Delete the Bin and Obj folders, sometimes it will work""

    Worked for me... Thanks...

Sign In or Register to comment.