Unable to use Xamarin from VS after update

Hi!
Since last update I have an error when trying to open\create Xamarin.IOS projects from VS 2015.2.
I tried to reinstall Xamarin or switch channels 5-7 times.

1. Message box

Microsoft Visual Studio

The project file 'C:\Users\Bonda\AppData\Local\Temp\pymg34jq.fxw\Temp\App6.csproj' cannot be opened.

There is a missing project subtype.

Subtype: '{FEACFBD2-3405-455C-9665-78FE426C6842}' is unsupported by this installation.

OK Help

  1. VS Error window
    There was an error attempting to initialize the Xamarin.iOS extension.
    System.NullReferenceException: Object reference not set to an instance of an object.
    at Xamarin.VisualStudio.IOS.XamarinIOSPackage.Initialize() in C:\Users\builder\data\lanes\3345\2e397405\source\XamarinVS\src\Core\VisualStudio.IOS\XamarinIOSPackage.cs:line 277

What I have to do to solve this problem?

Best Answer

Answers

  • DmytroBondarenkoDmytroBondarenko USMember ✭✭
    edited June 2016

    --deleted

  • PodsterPodster USMember ✭✭

    How did you fix it?

  • DmytroBondarenkoDmytroBondarenko USMember ✭✭

    @MarcoNapoli said:
    How did you fix it?

    I haven't fixed it yet.

  • Thanks for the update. This is my second time that this has happened after a visual studio update. Last time in-installing and re-installing visual studio did not work. The only way was to completely re-format Windows and re-install. :(

  • DmytroBondarenkoDmytroBondarenko USMember ✭✭

    I don't want to reinstall OS. But I have tablet PC where Xamarin is working after update properly and I can do some Xamarin tasks on.

  • VictorGarciaAprea.9996VictorGarciaAprea.9996 USXamarin Team Xamurai

    Hi @DmytroBondarenko ,

    Can you please let me know which version of XamarinVS are you currently running?

    At first this looks like the initialization of the iOSPackage is throwing an error, which will cause the project factory for iOS to not be registered at all, which will ultimately error out with VS saying that it cannot open the project GUID for iOS, which is the error you are seeing.

    If you let me know the exact XamarinVS build you are using I'll try to map that stack trace with line 277 to actual code and see if that helps the guessing game.

    One thing I'll try is to do a repair from the XamarinVS MSI. Do you have the matching XamarinVS MSI for the build you are running?

    thanks,
    -VGA.

  • DmytroBondarenkoDmytroBondarenko USMember ✭✭
    edited June 2016

    VS full info
    https://dl.dropboxusercontent.com/u/22639368/ShareX/2016/06/2016-06-14_00-53-41.txt
    Xamarin section:

    Xamarin 4.1.0.530 (2e39740)
    Xamarin.Android 6.1.0.71 (4e27558)
    Xamarin.iOS 9.8.0.323 (39ebb77)

    Do you have the matching XamarinVS MSI for the build you are running?

    I think no. I tried to install Xamarin only from VS installer and from VS Options menu.

    Today I tried to remove almost all connected with Xamarin from OS. Clean caches, remove some folders from APP_DATA and other. And install from VS installer latest awailable version for me. The result is same. The same error.

  • JoaoSilva.7604JoaoSilva.7604 GBUniversity ✭✭

    Had to reinstall my windows machine 2 days ago and now getting all this weird errors. Tried to install everything manually also without success. If I try to install the Visual Studio version with mobile support I also run into this problems. There's some serious issues with the latest install versions of Xamarin. Just lost 2 days of work for nothing, had to quit and I'm working on my MAC for now.

  • DmytroBondarenkoDmytroBondarenko USMember ✭✭

    Ooo! Thank you! It works again.

  • CharlesDonnisonCharlesDonnison GBMember

    I am still getting this error with the latest stable build

  • DmytroBondarenkoDmytroBondarenko USMember ✭✭

    @CharlesDonnison said:
    I am still getting this error with the latest stable build

    did you try this solution https://forums.xamarin.com/discussion/comment/204225/#Comment_204225?

  • hypermoghypermog USMember

    @leramirez55 said:
    I have been struggling with this issue also. I have found a fix.

    I encountered this problem when upgrading the extension. I went from stable to alpha, back to stable. Then I was unable to open iOS projects.

    You will need to reset visual studio. Unfortunately doing a repair install does not work. You have to make visual studio wipe all settings, and options.

    To do this do the following: (Back up the registry before you do this)

    Close Visual Studio.
    Run regedit.exe
    Delete the key: HKEY_CURRENT_USER\Software\Microsoft\VisualStudio\14.0
    Delete the key: HKEY_CURRENT_USER\Software\Microsoft\VisualStudio\14.0_Config
    Delete the directory: %USERNAME%\AppData\Local\Microsoft\VisualStudio\14.0 (Replace username with your username)

    Once visual studio restarts Xamarin Works Again!
    If you are on visual studio 2013 just replace the version number.

    Good Luck!

    This fixed my problem. Thank you, leramirez55.

  • SweeHengCheahSweeHengCheah USMember ✭✭

    Xamarin for Visual Studio Update Available (for Visual Studio 2015 Update 3) but unable to install and unable to use the Mac Agent to connect to my Mac, Visual Studio 2015 crashes everytime!

  • LeoReadingLeoReading USMember

    This problem still exists. Did anyone file an official bug yet?

  • TaylorTaylor USMember ✭✭

    There was a KB update for Update 3 that apparently fixed it for me (But I also did a repair on xamarin and visual studio 2015 so I am not so sure it wasn't that that fixed the problem

  • wvd_vegtwvd_vegt NLMember ✭✭
    edited August 2016

    This link suggests a less damaging solution (deleting the 14.0 directory means losing all add-ons and more).

    https://bugzilla.xamarin.com/show_bug.cgi?id=40781#c9

    Just tried it and can confirm you can re-load the iOS project. VS just recreates these files.

  • EllenKEllenK USMember ✭✭

    Thank you @leramirez55

  • chukachuka NGMember

    @leramirez55 said:
    I have been struggling with this issue also. I have found a fix.

    I encountered this problem when upgrading the extension. I went from stable to alpha, back to stable. Then I was unable to open iOS projects.

    You will need to reset visual studio. Unfortunately doing a repair install does not work. You have to make visual studio wipe all settings, and options.

    To do this do the following: (Back up the registry before you do this)

    Close Visual Studio.
    Run regedit.exe
    Delete the key: HKEY_CURRENT_USER\Software\Microsoft\VisualStudio\14.0
    Delete the key: HKEY_CURRENT_USER\Software\Microsoft\VisualStudio\14.0_Config
    Delete the directory: %USERNAME%\AppData\Local\Microsoft\VisualStudio\14.0 (Replace username with your username)

    Once visual studio restarts Xamarin Works Again!
    If you are on visual studio 2013 just replace the version number.

    Good Luck!

    Thanks a lot. This worked for me. I have been battling this issue for weeks.

Sign In or Register to comment.