Forum Xamarin.iOS

AOT Error with Xamarin Studio 6.0 (Undefined Symbols from what appears to be Core Graphics)

ByteMasterByteMaster USDeveloper Group Leader
edited May 2016 in Xamarin.iOS

Our application works just fine on the emulator. We can also deploy to the device with Xamarin Studio 5.X. After we upgrade to Xamarin 6.0 (build 5104) we are no longer able to deploy to a device.

We get the following error:

Which is after the following output log:
MTOUCH: error MT3001: Could not AOT the assembly '/Users/kevindwolf/FishAngler/FishAngler.iOS/obj/iPhone/Debug/build-iphone8.2-9.3.1/mtouch-cache/Build/Facebook.dll'

Undefined symbols for architecture arm64: [NOTE tried different processor types, same error]
1> "_CGAffineTransformIdentity", referenced from:
1> -[FBSDKWebDialog _transformForOrientation] in FBSDKCoreKit.a(FBSDKWebDialog.o)
1> -[FBSDKWebDialog _updateViewsWithScale:alpha:animationDuration:completion:] in FBSDKCoreKit.a(FBSDKWebDialog.o)
1> "_CGAffineTransformMakeRotation", referenced from:
1> -[FBSDKWebDialog _transformForOrientation] in FBSDKCoreKit.a(FBSDKWebDialog.o)
1> "_CGAffineTransformMakeScale", referenced from:
1> -[FBSDKLogo pathWithSize:] in FBSDKCoreKit.a(FBSDKLogo.o)
1> -[FBSDKMaleSilhouetteIcon pathWithSize:] in FBSDKCoreKit.a(FBSDKMaleSilhouetteIcon.o)
1> -[FBSDKMessengerIcon pathWithSize:] in FBSDKShareK


Kevin D. Wolf
Microsoft MVP
Tampa, FL


  • HalilDoganBolakHalilDoganBolak USMember ✭✭

    I have exactly the same problem. Getting the following error:

    /Users/hdb/Projects/OOVAtInvstr/OOVAtInvstr/MTOUCH: Error MT3001: Could not AOT the assembly '/Users/hdb/Projects/OOVAtInvstr/OOVAtInvstr/obj/iPhone/Debug/build-ipad6.7-9.3.2/mtouch-cache/Build/Facebook.dll' (MT3001) (OOVAtInvstr)

    I receive this error whether I link everything or do not link anything under project settings.

    Works fine on the simulator. Running Xamarin 6.1 (Build 817) with Xamarin.iOS Version: Did not have this problem until I integrated Facebook login using the Xamarin.Facebook.iOS package version 4.10. Also note that version 4.11 is available but does not install and fails with the following message:

    Could not install package 'Xamarin.Facebook.iOS 4.11.0'. You are trying to install this package into a project that targets 'Xamarin.iOS,Version=v1.0', but the package does not contain any assembly references or content files that are compatible with that framework. For more information, contact the package author.

    Any rapid response is greatly appreaciated since the app is now complete but cannot deploy to devices.

  • HalilDoganBolakHalilDoganBolak USMember ✭✭

    @KevinWolf Did you find a solution to this problem ?

  • ByteMasterByteMaster USDeveloper Group Leader


    Looks like rolling back to the stable branch would fix it, we have devs that didn't upgrade to 6.0 yet, with 5.X it works.

  • HalilDoganBolakHalilDoganBolak USMember ✭✭

    @KevinWolf Which version of the Xamarin.Facebook.iOS package is causing this problem for you ? Is it 4.10 like mine ?

  • @HalilDoganBolak I have just hit the very same problem with Facebook.dll, v. 4.10.. Did you manage to sort it out?? :/

  • HalilDoganBolakHalilDoganBolak USMember ✭✭

    @MarcoStrillozzi.4745 Here is the situation:

    • I am running the latest "Alpha channel" of Xamarin Studio on Mac.
    • I still cannot "update" the Xamarin.Facebook.iOS to 4.11.0 - the update process fails as described above.
    • I can get a 'release' build if I set Link Framework SDK's Only for Linker behaviour bypassing the AOT error.

    The reason for this is the sloppy work done on the Xamarin.Facebook.iOS package.

  • Hey @HalilDoganBolak somehow I managed to fix it although not quite sure how, seems to be an issue with Universal apps.
    Here's more or less what I did (I'm on the Stable channel):

    • uninstalled the FB SDK Component
    • changed target devices in info.plist from Universal to iPhone/iPod only (not sure if this can work for you)
    • set Linker to"don't link"
    • physically deleted all FB related content from both Components and Packages folders
    • reinstalled the FB SDK component

    I still get a warning that v.4.11.0 of the Xamarin.Facebook.iOS package is available, but update still fails.

  • I'll take it back.. still getting the same error when deploying to a device.
    Anyone knows how to escalate @JamesMontemagno?

  • DavidOrtinauDavidOrtinau USForum Administrator, Xamarin Team, Insider, University Xamurai

    I'm having this issue as well. Didn't see a bug report, so here's a new one filed:

  • DavidOrtinauDavidOrtinau USForum Administrator, Xamarin Team, Insider, University Xamurai

    For anyone else still experiencing this issue, today's Stable channel release seems to have fixed it for me.

  • BrendanZagaeskiBrendanZagaeski USForum Administrator, Xamarin Team Xamurai
    edited April 2017

    Many thanks DavidOrtinau for the bug report!

    (Bug reports are indeed the best place to post information any time you're thinking "I've got an error, and I'm pretty sure it's a bug in Xamarin.")

    today's Stable channel release seems to have fixed it for me.

    In my tests of this issue, the update to "Cycle 7 – Service Release 0" did not influence the behavior, so there's a chance that the update will not solve the problem for all users.

    In contrast, disabling Project Options > Build > iOS Build > Enable incremental builds has successfully stopped problem in all the reports so far. (Note that the "incremental builds" setting will also automatically be disabled if "debugging" is disabled, so this problem will by default not affect Release builds.)

    I expanded on some of the information from David's bug report on June 20 to aim to provide a relatively clean and complete starting point on a new bug: Bug 42139.

    One new bit information on the new bug report that might be interesting to note is that in theory it is possible to correct the problem locally by downloading the open source Xamarin.Facebook.iOS component, making a change to a .linkwith.cs file, and re-building the library.

    I will now close this thread to consolidate any further discussion and updates onto the public bug report: Bug 42139.

    (As always, I'm also happy to reopen the thread upon request within the next month or two. Just send a quick email to [email protected] with a link to this thread. For follow-up after the next couple of months, if the remaining related open bug reports or forum threads do not cover the desired scenario, please follow the recommendations to file a new bug report or create a new forum thread. Thanks!)

This discussion has been closed.