Xamarin Studio 6.0.0 hangs upon build/clean

TomasNemecTomasNemec Tomas NemecCZMember

After upgrading from 5.5 to 6.0 XS on MacOSX hangs whenever I try to build/rebuild/clean my solution. UI is responsive, but the operations never finish and cannot be cancelled. Please help!

Answers

  • JohannesRudolph.0922JohannesRudolph.0922 Johannes Rudolph DEMember

    Same here. Seriously guys, do you even test/dogfood stable releases?

  • JohannesRudolph.0922JohannesRudolph.0922 Johannes Rudolph DEMember

    Okay, apparently XS didn't like updating. I tried xbuild clean on my solution, got a couple of errors:

    ERROR [2016-06-13 17:15:27Z]: Error running resgen
    System.NullReferenceException: Object reference not set to an instance of an object
    at MonoDevelop.MonoDroid.MonoDroidProjectFlavor+c__AnonStorey1A+c__async19.MoveNext () [0x0004e] in /Users/builder/data/lanes/3342/694a75f0/source/md-addins/MonoDevelop.MonoDroid/MonoDevelop.MonoDroid/MonoDroidProject.cs:1004

    Then decided to clean my repository using source control (hg purge --all) and that worked. Now XS builds fine. Not a good upgrade experience though, if xbuild requires obliterating workdirs it should do so as part of the update.

  • TomasNemecTomasNemec Tomas Nemec CZMember
    edited June 2016

    I tried deleting and re-cloning my repo but the build phase got stuck right after it finished building the 1st project of the solution. I got marginally further then, but in the end I am still unable to build my solution. I am left with having to compile from command line via mdtool. But that way I cannot use a debugger - this is sooo annoying. Is anyone even testing these so called stable releases?

  • DavidPerssonDavidPersson David Persson USMember

    I've run into this as well. Operations like Build, Save, Clean all cause XS to hang with no output messages. I've left it trying to clean a solution for a couple hours to no avail. Any solutions?

  • DannyCampbellDannyCampbell Danny Campbell USUniversity

    I am having these same issues yesterday and today. Build, clean and also 'find in files - whole solution' gets stuck forever while the rest of the UI remains responsive.

  • DenisSugakovDenisSugakov Denis Sugakov RUMember ✭✭

    I can't build a project too

  • TomasNemecTomasNemec Tomas Nemec CZMember

    I have filed a bug for this https://bugzilla.xamarin.com/show_bug.cgi?id=41807
    If you want to support the case open the terminal and run:

    ps -ef | grep XamarinStudio
    kill -QUIT {pid}
    

    where {pid} is the actual process id taken in the 1st command. This will not kill the app but rather generate a dump in the log files.
    The log directory can be accessed from XS via Help > Open Log Directory - open IdeXXX.log by double clicking it. You will most likely find an exception similar to this one:

    "Threadpool worker"ERROR [2016-06-16 01:52:12Z]: Current check for updates task error.
    System.AggregateException: One or more errors occurred. .
    ---> System.InvalidOperationException: Could not connect to the feed specified at 'https://www.nuget.org/api/v2/'. 
    Please verify that the package source (located in the Package Manager Settings) is valid and ensure your network connectivity.
    ---> System.Net.WebException: The request timed out
    
  • mattwardmattward Matt Ward GBMember Xamurai

    @TomasNemec - You can disable check for updates in Preferences - NuGet - General to see if that makes any difference. However I suspect this will not solve the build problems you are seeing.

  • LluisSanchezLluisSanchez Lluis Sanchez ESXamarin Team Xamurai

    We are having a really hard time trying to reproduce this issue. If you have problems with XS getting stuck when saving or building a project, it would be very useful if you could send me this information:

    • A copy of the detailed version information from the about dialog.
    • The IDE log file with a thread dump. While XS is stuck, find out what's the process ID of XamarinStudio (using the activity monitor or ps for example), and on a terminal run "kill -QUIT ". This will not kill XS, it will signal the IDE to dump thread information into the IDE.log file. You can find it using the Help -> Open Log Directory command.

    Please send the information to lluis@xamarin.com.

    Thanks!

  • DannyCampbellDannyCampbell Danny Campbell USUniversity

    I can clean and build after updating to OSX El Capitan (10.11) and XCode 7.3.1. The system requirements say OSX 10.11 is required but it is really easy to miss that. I figured it out because if I waited long enough, eventually the build failed and gave a console error message about needing iOS 9.3 support provided by XCode 7.3.1.

  • TomasNemecTomasNemec Tomas Nemec CZMember

    Not me. Already on 10.11 and XCode 7.3.1

  • mmxmmx Yuri Ostrovsky USMember

    I'm having the same problem. Running Yosemite, which cannot upgrade to xcode 7.3. Can I downgrade back to the version I had just before this upgrade? How do we do that? I don't have the bandwidth to switch to El Capitan right now.

  • BrightLeeBrightLee Bright Lee KRMember ✭✭✭

    same here....

    I'm doing reinstall now.
    Please it would work...

  • BrightLeeBrightLee Bright Lee KRMember ✭✭✭

    Reinstall didn't help.
    I'm screwed.

  • BrightLeeBrightLee Bright Lee KRMember ✭✭✭

    XS 6.0 (build 5174)

  • BrightLeeBrightLee Bright Lee KRMember ✭✭✭

    Building project works now somehow...
    I don't even now why.
    very confused.

  • WilliamJockuschWilliamJockusch William Jockusch USMember ✭✭

    I tried to email you some logs Lluis, but the email bounced. Here they are. This is for a Xamarin.Mac project, with a
    shared mac/iOS project beneath it, and lots of PCL code and nuget beneath that, using XS 6.0.1 build 9.

  • LluisSanchezLluisSanchez Lluis Sanchez ESXamarin Team Xamurai

    If you are still hitting this issue, please try deleting the .userprefs file you'll find in the directory of the solution. Please make a copy of the file before deleting it, since it may help diagnosing the issue. If that solves the problem for you, please let me know.

  • NguyenNhuHieuNguyenNhuHieu Nguyen Nhu Hieu VNUniversity, Developer Group Leader ✭✭
    edited August 2016

    @LluisSanchez said:
    If you are still hitting this issue, please try deleting the .userprefs file you'll find in the directory of the solution. Please make a copy of the file before deleting it, since it may help diagnosing the issue. If that solves the problem for you, please let me know.

    Deleting userpref does solve the problem for some reason. Build fine now

    https://gist.github.com/anonymous/74fd4fc0415875d3362835154d8afd03

  • fatsofatso Tim Wayper NZMember

    Deleting the .userprefs file resolved the issue for me too. If you need a copy of the file, Lluis, I'm happy to provide it.

  • RobertJohanssonRobertJohansson Robert Johansson SEMember

    +1 for deleting .userprefs , now building works fine!
    You can find my old userprefs file here for debugging: https://dl.dropboxusercontent.com/u/7035424/MainApp.userprefs.old

  • cezardcezard Cezar D. PLMember

    Excellent solution, exactly working, btw, I do not think I have to save this file in other local position.

Sign In or Register to comment.