Forum Xamarin.Android
We are excited to announce that the Xamarin Forums are moving to the new Microsoft Q&A experience. Q&A is the home for technical questions and answers at across all products at Microsoft now including Xamarin!

We encourage you to head over to Microsoft Q&A for .NET for posting new questions and get involved today.

Generate Resource.designer.cs with problem for GooglePlayServices

RosalbaMiccoRosalbaMicco ITMember
edited September 2015 in Xamarin.Android

Hello to all,
I have a problem after updating all Android SDK and packages contained in the project in Xamarin Studio.
I tell me I have 33 errors in the files Resource.designer.cs; I also opened the file and saw that are caused by resources generated by GooglePlayService.
Below are some examples:
Application\Resources\Resource.designer.cs(102,102): Error CS0117: 'W3SalesAndroid.Resource.Attribute' non contiene una definizione per 'barSize'. (CS0117)
Application\Resources\Resource.designer.cs(122,122): Error CS0117: 'W3SalesAndroid.Resource.Attribute' non contiene una definizione per 'disableChildrenWhenDisabled'. (CS0117)
Application\Resources\Resource.designer.cs(113,113): Error CS0117: 'W3SalesAndroid.Resource.Attribute' non contiene una definizione per 'middleBarArrowSize'. (CS0117)

Commenting on these lines the project works fine but every time I clean and recompile the file is regenerated from scratch and the problem reoccurs.
Can you help me?
Sorry for my English.

Versions of my tools:
_Xamarin Studio
Version 5.9.6 (build 23)
Microsoft .NET 4.0.30319.34209
GTK+ 2.24.22 (MS-Windows theme)
GTK# 2.12.26

Version: 5.1.6 (Business Edition)
Android SDK: C:\Users\Giovanni\AppData\Local\Android\android-sdk
Supported Android versions:
2.3 (API level 10)
4.0.3 (API level 15)
4.4 (API level 19)
4.4.87 (API level 20)
5.0 (API level 21)
5.1 (API level 22)
Java SDK: C:\Program Files (x86)\Java\jdk1.8.0_31
java version "1.8.0_31"
Java(TM) SE Runtime Environment (build 1.8.0_31-b13)
Java HotSpot(TM) Client VM (build 25.31-b07, mixed mode)

Operating System
Windows 6.2.9200.0 (64-bit)_


  • Jason.0753Jason.0753 USMember

    I am having the same problem after updating google play services, please let me know if you have found a solution

  • RosalbaMiccoRosalbaMicco ITMember
    edited October 2015

    Sorry if I insist but I consider it a mistake bad enough. I repeat, with the latest update to Google Play services in the Android SDK project it gives me 33 errors.You need a update component of Google Play Services Xamarin, switch from ver.25 to vers. 27.

    Thanks for the attention

  • RosalbaMiccoRosalbaMicco ITMember
    edited October 2015

    The problem is solved!
    With the latest update (Google Play Service ver. 26 for Xamarin Studio) compiles without problems. =)

    Thank you all.

  • Andrey.8366Andrey.8366 USMember

    I have exactly the same problem. Google Play Service ver.26 not helping, I even installed 27.0.0-rc1 hoping that it will fix the issue and because I already updated to 27 in Android SDK. Have no idea how to fix this. I guess that downgrade is needed, but what exactly: SDK Tools, Google Play Service or something else?

  • wootwoot USMember

    I am also having this same error after updating Google Play Services to V.26.0.0 and SDK tools etc to the latest.

    Anyone found a solution yet? Really don't want to have to downgrade again.

  • Mirko.9600Mirko.9600 USMember

    Anyone ?

  • wootwoot USMember

    @Mirko.9600 - I've been in touch with Xamarin support, and it looks like the culprit might be mixed versions of the Support Libraries. It looks like some of Google Play Services has dependencies on the Support v4 lib, so updating may have introduced conflicting support versions.

    I'm going through all my 3rd party dependencies now and checking to see what support version they rely on, I'll update here if I find a related fix.

  • wootwoot USMember

    After going through all my dependencies, I found some libraries that were built with Support Library v4 22.0.0 - I rebuilt the libraries with the newest version, and it solved the issue for me! Hope this can help some folks.

  • JonDouglasJonDouglas USXamarin Team, University, Developer Group Leader Xamurai
    edited October 2015

    Hi all!

    As mentioned by Thomas, you will need to ensure that all of your Xamarin.Support.v* libraries are up to date with each other as Google is known to add/remove certain resources from the Support Libraries. This causes issues when mixing your Support Libraries as there will be missing/added resources that older versions of the libraries are looking for!

    You can find all the revisions here:

    To be more specific about certain resource changes and such, you can go to a specific version diff of the library:

    Example: Version 23

    You can then categorize this list using the "Changes" link within the "Filter the Index" box on the left hand side

    On the left hand side Alphabetical bar, you can then click on the R.* folder that respects to your missing resource to see if it was removed/added to.

    I hope this helps!

  • skylessskyless USMember ✭✭

    I have 31 errors with my dependency (from Xamarin.Android.Support.AppCompat v23) ... How can I fix it exactly ?

  • skylessskyless USMember ✭✭

    Found. It was the fault of the AppCompat v22 dependency from his other library (

  • JonHuntJonHunt USMember ✭✭

    "As mentioned by Thomas, you will need to ensure that all of your Xamarin.Support.v* libraries are up to date with each other as Google is known to add/remove certain resources from the Support Libraries. "

    I've updated all the Xamarin.Support.v* Nuget packages to the latest version and have the latest version of Xamarin Forms ( installed and I still get 500+ errors with the Resource.Designer.cs file. What is the solution to get my project to build?

Sign In or Register to comment.