Stable Release: XamarinVS 4.1.0, Cycle 7 Feature Release

BrendanZagaeskiBrendanZagaeski USForum Administrator, Xamarin Team Xamurai

Please direct any discussion about this release to the main release announcement in the General forum:

Stable Release: Cycle 7 Feature Release

Posts

  • DanSiegelDanSiegel USUniversity ✭✭

    From what I understand the iOS remoting should now work. I've followed the Preview Instructions, but I'm not able to see an iOS device connected directly to my Windows Machine. When I try to deploy to the Simulator it shows that it's deployed and running but there is no simulator coming up on the Windows Machine, and the simulator isn't up on the Mac.

  • BrendanZagaeskiBrendanZagaeski USForum Administrator, Xamarin Team Xamurai

    Yes, the Preview iOS Simulator Remoting feature does work successfully with these new Stable versions in at least some environments (I tested quickly on my local setup).

    I noticed we don't yet have a forum announcement dedicated to the Preview iOS Simulator Remoting feature, so I have requested that one be created in the Prerelease & Betas forum. In the mean time, it looks like there has been some troubleshooting discussion about that preview feature in another thread starting around April 27: https://forums.xamarin.com/discussion/39044/ios-simulator-display-on-windows/p1.

  • NMackayNMackay GBInsider, University mod

    @BrendanZagaeski

    Hi Brendan, does this stable have the following issue as the notes suggest?

    Does it affect both iOS and Android? would seem a pretty compelling reason not to install (for myself anyway)

  • SpencerThompsonSpencerThompson CNMember

    Today I downloaded and installed the latest 4.1 update. On my first attempt install the update I was told I need to has MS Build Tool 2015 to continue. So I installed MS Build Tools and completed the update. The problem is, now when I build, the compilation never completes. It just seems to hang at certain point.

    The project I'm trying to compile a Xamarin Forms Android project. I'm running Visual Studio Ultimate 2013 on Windows 10.

    Any ideas on how to fix this? I need some help with this fairly urgently as obviously I can't get any work done until this fixed. Thanks in advance for any assistance.

  • JeremyKolbJeremyKolb USMember ✭✭✭

    @SpencerThompson: It's probably downloading the android support zip files. They're HUGE and there is no indication in the output window that these files are being downloaded.

    1. Go in and delete the files from %USER%\AppData\Local\Xamarin\zips.
    2. Rebuild.
    3. Let the build go for 15 - 45 minutes.

    Watch that directory and you should see the zip files download. It takes a long time but once they're downloaded and unzipped your build should succeed.

  • JohnWilson.4976JohnWilson.4976 AUMember ✭✭

    @NMackay I've been holding off on installing the update as well for precisely that reason. I can't risk it.

    There was a release some time ago where breakpoints in PCLs stopped working, and it ended up being a project killer (they elected to ditch Xamarin because something so fundamental had stopped working).

    If this has happened again, I'm a bit annoyed that it seems to have regressed, given I shelled out for the Business subscription back then (and now).

    @BrendanZagaeski is it still a problem? Is there a hotfix coming? Because I'm also stuck unable to debug a Lollipop deployment because of that runtime/art/sigsev breakpoint bug (I've tried all the workarounds, none work).

    I can't upgrade, nor downgrade (for other reasons). It's getting a bit silly.

  • JohnWilson.4976JohnWilson.4976 AUMember ✭✭

    @SpencerThompson it may also help if you fire up your windows task manager, go to the "performance" tab and click on the Ethernet entry which corresponds to your internet connection. If you see a massive spike, where it gobbles up all your available bandwidth, and can track that ethernet usage back to the Processes screen (sorted by network usage), you'll be able to see if it's Xamarin/Visual Studio/MSBuild that's doing it. If it is, leave it alone (as @JeremyKolb described), and just be patient with it. Some of those files are 90MB a pop.

    Does the Output window 'Xamarin Diagnostics' perhaps show this happening?

  • ShantimohanElchuriShantimohanElchuri USMember ✭✭✭✭✭

    The docs say that I may be asked for Mac's credentials once after this Cycle-7 update to connect to Mac. But it is asking for credentials every time I start VS, not once, not twice, but every time.

    After update to XVS 4.1, I had to start VS several times before successfully connecting to my Mac. That was yesterday night at home where my Mac is. Now at work, where I don't have any Mac and when I start VS it is asking for credentials every time. Previously it just silently tries to connect and not complain if couldn't connect.

    How do I avoid this?

  • ericleigh007ericleigh007 USMember

    For me, this is happening if I turn on the remoting feature (which I cannot get to work with the latest as of the date of this post). If I turn that option off in options->Xamarin:IOS->Show remote simulator in Windows, things work as they used to.

    I did have no trouble using my "no-spaces" username to work on the mac, and I used an IP instead of a name, but still have to avoid the remoting options if I want to do anything.

    For me, the remoting is a total fail. I'll test upcoming versions for better ops.

    -thanks
    -e

  • ericleigh007ericleigh007 USMember
    edited June 2016

    BTW, if anybody wants to remote connect to my machine and see what's up, I'm willing to help move the Xamarin community forward that way.

    If I can include any logs, let me know. The logs collected in the other thread don't seem to be very verbose or helpful in finding the errors that many users are seeing.

  • ShantimohanElchuriShantimohanElchuri USMember ✭✭✭✭✭

    @BrendanZagaeski I am not seeing the "Show Simulator in Windows" option at all after the Cycle-7 updates. I have updated in both Mac El Capitan and Windows 10 machines.

    I have tried running the project in the iOS Simulator on Mac once, closed VS and restarted it, but no option.

    What is missing?

  • BrendanZagaeskiBrendanZagaeski USForum Administrator, Xamarin Team Xamurai
    edited June 2016

    Keep in mind that the iOS Simulator Remoting feature is still in preview, so it's possible there are environments where it simply doesn't work at the moment. If you have followed the setup instructions, I would recommend browsing existing bugs, filing a new bug, or dropping in to the forum thread I mentioned earlier for any additional follow-up: https://forums.xamarin.com/discussion/39044/ios-simulator-display-on-windows/p1.

  • SpencerThompsonSpencerThompson CNMember

    @JeremyKolb and @JohnWilson.4976. Thanks for the replies. I followed your instructions and ran a rebuild. Only one zip file was downloaded - 139MG. That happened fairly quickly. After about 2 hours the build finally finished with the error message "The directory is not empty". The message references the Droid project.

    Here is the output of the build just before it failed -

    4>C:\Program Files (x86)\MSBuild\12.0\bin\Microsoft.Common.CurrentVersion.targets(1697,5): warning MSB3247: Found conflicts between different versions of the same dependent assembly. In Visual Studio, double-click this warning (or select it and press Enter) to fix the conflicts; otherwise, add the following binding redirects to the "runtime" node in the application configuration file:
    4>C:\Program Files (x86)\MSBuild\Xamarin\Android\Xamarin.Android.Common.targets(387,2): error : The directory is not empty.
    4>C:\Program Files (x86)\MSBuild\Xamarin\Android\Xamarin.Android.Common.targets(387,2): error :

    Any ideas? Or should I just back out of this release? My only worry is where that leaves me for future updates.

  • NMackayNMackay GBInsider, University mod

    @JohnWilson.4976

    Same as yourself, debugging in PCL's was a major problem. A little frustrated that a regression bug once again appears if that's the case.

  • RaymondKellyRaymondKelly USMember ✭✭✭

    I am having an issue after updating to 4.1.0, builds for Android now take 3 times longer. This is even on every code change. It takes about 2 minutes to start a debug session where on 4.0 it took maybe 20 seconds (using the emulator). Any ideas what this is?

  • RaymondKellyRaymondKelly USMember ✭✭✭

    I should add, the big hang is after these 2 lines when deploying the app:
    1>C:\Users\x\AppData\Local\Android\android-sdk\platform-tools\adb.exe -s 169.254.220.177:5555 shell getprop ro.build.version.sdk
    1>C:\Users\x\AppData\Local\Android\android-sdk\platform-tools\adb.exe -s 169.254.220.177:5555 shell getprop ro.product.cpu.abi

  • BjornBBjornB USMember ✭✭✭

    Now my apps are extremely laggy! Nothing changed in my code, WHAT DID YOU DO?

  • BrendanZagaeskiBrendanZagaeski USForum Administrator, Xamarin Team Xamurai

    Hi all, as mentioned in the first post in the thread:

    Please direct any discussion about this release to the main release announcement in the General forum:

    Stable Release: Cycle 7 Feature Release

    That thread mentions the recommended approaches for various kinds of issues and requests. For example, please do:

    File a bug using the "Cycle 7" new bug form if you have found an issue that only happens on Cycle 7 (or if you have found an issue that you otherwise suspect is a bug).

    Thanks in advance!

  • BrendanZagaeskiBrendanZagaeski USForum Administrator, Xamarin Team Xamurai

    This thread has now been closed to direct all further updates onto the announcement for the first follow-up bugfix release for Cycle 7:

This discussion has been closed.