Resource.Designer.cs errors all of a sudden

patrickgoodepatrickgoode USMember ✭✭

Why am I getting these on a project that worked fine, then all of a sudden not?image

Best Answer

Answers

  • ThomasGoerlichThomasGoerlich DEMember ✭✭

    Did you try to clean the project, quit vs/xs, manually clear bin/obj folder and then rebuild the project again? This helps me in situations like this.

  • patrickgoodepatrickgoode USMember ✭✭

    @ThomasGoerlich Yes, didn't help

  • seanydaseanyda GBMember ✭✭✭✭✭

    They're really annoying. I find deleting each line with the error in resource.designer fixes it :S

  • C64GamerC64Gamer USMember ✭✭
    edited May 2016

    XLabs is not ready for the new Xamarin.Forms 2.2. You have to wait for a newer version of Xlabs or take this fix:

    1. Create a Resource.cs file in your root folder from your android project
    2. Copy the content from this link into that file: https://gist.github.com/rid00z/76906292010e080c7f5eadfb5ca7b107
    3. Rename the namespace to your project namespace
    4. Cleanup your project
    5. Rebuilt it

    Now everything should working again

    Regards
    C64Gamer

  • patrickgoodepatrickgoode USMember ✭✭

    Thanks everyone. The prerelease version fixed it

  • Thank You. It Works Fine.

Sign In or Register to comment.