Forum Xamarin.iOS
We are excited to announce that the Xamarin Forums are moving to the new Microsoft Q&A experience. Q&A is the home for technical questions and answers at across all products at Microsoft now including Xamarin!

We encourage you to head over to Microsoft Q&A for .NET for posting new questions and get involved today.

Remote Mac connected, but build fails because can't connect - WTF?

ClintStLaurentClintStLaurent USUniversity ✭✭✭✭✭

As seen in the attached, Visual Studio sees the remote Mac as connected.
Yet when I build, it fails because it can't connect.
Its frustrating when half the tools contradict the other half.

This Xamarin.Forms solution has an Android, iOS and UWP project. At the start of each Month I run them all to make sure they are all on-par and happy. So this is not a new solution, nor am I totally unfamiliar with connecting to a remote build Mac.

Neither PC has its firewalls even running.
All the basics like same usernames, ssh and so on have remain the same and untouched for months.
Of course I have already rebooted everything. I'm connecting to the Mac by IP address.
I've run through the troubleshooting page just to make sure I haven't overlooked something.

I really think this is something recent, perhaps in the lastest release. I do have both machines on the same release channel-but that is alpha so I wonder/worry. They are both up to date and report nothing new available.

Anyone else ever see this split behavior where it is connected but can't connect?


  • DaveHuntDaveHunt USMember ✭✭✭✭✭

    Oddly enough, the first picture shows "Clints-Mac.local", while the second shows an IP address. I would think if you were connecting by IP address, both pictures would show the IP address. Also, just to be sure, have you double-checked the IP address on the Mac? I know that's a bit noobish, but sometimes it's the one thing we're sure it isn't that is causing the problem.

  • ClintStLaurentClintStLaurent USUniversity ✭✭✭✭✭

    I agree: I would expect to see the IP address since that is how I connected. Yet its the machine name that appears in the tooltip of the toolbar item. Maybe that is meant to be helpful, showing that enough connectivity exists to obtain the name. Kind of like how it can either show (connected) or (limited) in the tooltip depending the nature of the connection.

    Whenever there is some kind of issue blocking a full/duplex/working connection the icon shows a yellow screen and (limited) instead of green and (connected). Its a subtle difference in the icon color I admit, but its there. This is usually an indication that the two machines aren't running the same version of Xamarin and need to be updated - at least that's been my experience.

    Since the Mac Agent connection dialog and the output window both show "" I want to believe they are using the same connection information. If I connect using the machine name of "Clints-Mac.local", the tooltip shows the same text, but the output window will say "Unable to connect to address='Clints-Mac.local' " - supporting this hope.

  • MichaelLattaMichaelLatta USUniversity

    I was experiencing the same issue today. One minute it worked fine, the next it would fail in the middle of the build because it couldn't connect (some MTouch error).

    I tried updating xamarin on my machine and the mac and now i get a different error...Unable to start build agent.

  • ClintStLaurentClintStLaurent USUniversity ✭✭✭✭✭

    1 - I notice the attached images are no longer visible. But then again I'm at work today and was at home when I posted the images. If it weren't for DaveHunt's comments showing he could see them I would wonder if I really attached them. So... Can anyone else still see the attached photos? (I'm trying to determine if the site dropped them or if my work is filtering them out)

    2 - Interesting that MichaelLatta had the same issue come up on the same day. Makes me wonder about an update that got pushed out and automatically applied (thanks Microsoft for that behavior in the OS). He was able to resolve eventually by re-updating both is PC and his Macintosh. That didn't work for me. Michael is on Stable channel and my home machine is on Alpha channel so there will always be some lingering questions about Alpha.

  • DaveHuntDaveHunt USMember ✭✭✭✭✭

    I can confirm the images are still there. I have to click on a "broken image" icon to open them in another tab/window, but they're there.

  • ClintStLaurentClintStLaurent USUniversity ✭✭✭✭✭

    Thanks for that. Clearly my employer is doing some level of filtering. Good to know.

  • BrendanZagaeskiBrendanZagaeski USForum Administrator, Xamarin Team Xamurai
    edited April 2017

    Unable to connect to Address='' with User='clint...

    If you're still hitting this same issue, I will mention that the build host connection troubleshooting guide lists 2 possible causes of this error along with steps to diagnose and resolve each possible cause. With a little luck, one of those 2 possibilities will solve the problem in your case too.

    Hopefully for most users the troubleshooting article should appear near the top of the Google results for this error: For me at least the troubleshooting article pops up as the 2nd result.

    I will tentatively close this thread to consolidate any further discussion onto one of the other forum threads about the same message:

    (As always, I'm also happy to reopen the thread upon request within the next month or two. Just send a quick email to [email protected] with a link to this thread. For follow-up after the next couple of months, if the remaining related open bug reports or forum threads do not cover the desired scenario, please follow the recommendations to file a new bug report or create a new forum thread. Thanks!)

This discussion has been closed.