Xamarin.Forms 2.2.0

12346

Posts

  • AdrianKnightAdrianKnight USMember ✭✭✭✭

    @RyanWatson We haven't seen any updates by Xamarin lately.

  • TonyDTonyD USMember ✭✭✭

    +1 CarouselView has been MIA for a month now.

  • GautamJainGautamJain INMember ✭✭✭

    I just downloaded ButtonXaml sample and built it. The app runs and after 5-8 seconds it exits automatically with some error that I don't understand. Attached is the debug log file that I saved from LogCat.

    Actually, my real app behaved this way. So I thought of trying a sample to see if the problem is really with my app or some configuration.

    I am using Visual Studio 2015 Community Edition. The ButtonXaml automatically downloads all the Nuget packages.

    The problem seems to be with some configuration. I am using the Android SDK that is shipped with Android Studio because the emulator is real fast. Building using API 23 SDK. Running on API 19 Emulator image.

    The app steps logging the below message:
    05-23 05:41:17.683: D/Mono(10398): [0xb9bfc5b0] worker finishing

    Please help.

  • BjornBBjornB USMember ✭✭✭

    after update all pages in navigationstack trigger OnApparing/OnDissapearing when I go out and back in to my app. Totally breaking everything in my app... @TheRealJasonSmith is XF 2.2 supposed to be like this?

  • DavidTavarezDavidTavarez DOMember ✭✭✭

    @JKay said:
    @TheRealJasonSmith Can you upload the slides to your "Optimising App Performance with Xamarin.Forms" I've had to take screenshots from the youtube video which isn't great. Be really useful if someone could post them somewhere

    There you go http://kent-boogaart.com/blog/jason-smith's-xamarin-forms-performance-tips

  • BjornBBjornB USMember ✭✭✭

    @BjornB said:
    after update all pages in navigationstack trigger OnApparing/OnDissapearing when I go out and back in to my app. Totally breaking everything in my app... @TheRealJasonSmith is XF 2.2 supposed to be like this?

    This bug only appears when using FormsAppCompatActivity, FormsActivity works just like its supposed to

  • FokkeVermeulenOldFokkeVermeulenOld USMember ✭✭
    edited May 2016

    @BryanHunterXam @TheRealJasonSmith
    Do you know any process on this failure?

    The signature-issue on google maps using the latest final xamarin.Forms and googleplayservices 29.0.0.1
    http://stackoverflow.com/questions/37333220/googlesignatureverifier-signature-not-valid-message-not-using-the-google-maps-a

    https://forums.xamarin.com/discussion/67177/xamarin-forms-maps-2-2-0-31-and-googleplayservices-signature-not-valid

    And I saw there is an update on the googleplayservices to 29.0.0.2 https://www.nuget.org/packages/Xamarin.GooglePlayServices.Maps/29.0.0.2
    The problem is I cannot update because here you set it directly to 29.0.0.1 https://www.nuget.org/packages/Xamarin.Forms.Maps/2.2.0.31

    I need definately it getting to work

  • HomeroBatistaKzamHomeroBatistaKzam BRMember ✭✭

    After upgrading to version 2.2 of Xamarin.Forms, I'm with the following problem:

    /Users/HomeroKzam/Projects/Components/grial-uikit-extended/samples/Grial/Droid: Error XA5209: Unzipping failed. Please download https://dl-ssl.google.com/android/repository/android_m2repository_r29.zip and extract it to the /Users/HomeroKzam/.local/share/Xamarin/Android.Support.v4/23.3.0.0/content directory. (XA5209) (Grial.Droid)
    /Users/HomeroKzam/Projects/Components/grial-uikit-extended/samples/Grial/Droid: Error XA5209: Reason: /Users/HomeroKzam/.local/share/Xamarin/zips/2A3A8A6D6826EF6CC653030E7D695C41.zip is not a valid zip file (XA5209) (Grial.Droid)

    ... (more 52 errors)

    I again compile the same code, without making any changes, these errors disappear, but displays the following error:
    /Users/HomeroKzam/Projects/Components/grial-uikit-extended/samples/Grial/Droid/Resources/values/Style.xml(0,0): Error APT0000: Error retrieving parent for item: No resource found that matches the given name 'Theme.AppCompat.Light.NoActionBar'. (APT0000) (Grial.Droid)
    /Users/HomeroKzam/Projects/Components/grial-uikit-extended/samples/Grial/Droid/Resources/values-v21/Style.xml(0,0): Error APT0000: Error retrieving parent for item: No resource found that matches the given name 'Theme.AppCompat.Light.NoActionBar'. (APT0000) (Grial.Droid)

    ... (more 25 errors)

    Thanks,
    Homero.

  • AndyBarajasAndyBarajas USMember ✭✭

    @AlessandroCaliaro Make sure your Target Android Version and your Target Framework both point to the same API

    Ref: http://forums.xamarin.com/discussion/comment/104444/#Comment_104444

  • GautamJainGautamJain INMember ✭✭✭

    @HomeroBatistaKzam

    The following steps worked for me:

    1. Manually delete the file /Users/HomeroKzam/.local/share/Xamarin/zips/2A3A8A6D6826EF6CC653030E7D695C41.zip
    2. Then rebuild all. This rebuild all will take a lot of time because in the background android_m2repository_r29.zip is being downloaded. Don't cancel the build. Let it complete. The build should succeed now. Or at least, you will not get any related errors.
  • seanydaseanyda GBMember ✭✭✭✭✭

    Any news on the carousel view?!

  • HomeroBatistaKzamHomeroBatistaKzam BRMember ✭✭
    edited May 2016

    @Gautam-Jain

    Thank you very much. Now it's working!

  • RyanWatsonRyanWatson USMember ✭✭✭

    @lpdavies said:
    Any news on the carousel view?!

    @lpdavies I got a message from support last night after sending them an email that said they are close to having a package ready.

    Crossing my fingers that it is out really soon.

  • seanydaseanyda GBMember ✭✭✭✭✭

    @RyanWatson said:

    @lpdavies said:
    Any news on the carousel view?!

    @lpdavies I got a message from support last night after sending them an email that said they are close to having a package ready.

    Crossing my fingers that it is out really soon.

    Thanks! Much appreciated @RyanWatson

  • SpaceMonkeySpaceMonkey GBMember ✭✭✭
    edited May 2016

    Bugzilla doesn't allow me to see:

    For:

    40844 - [Android] Forms Android app gets stuck with GC bridge calls when using current beta branch of Xamarin.Android/Mono Runtime

    Error:

    You are not authorized to access bug #40844.

  • DonMesserli.1843DonMesserli.1843 USMember ✭✭

    O just updated Xamarin.Forms to 2.2.0.43 and am getting this error when trying to build for iOS...

    Error MT2002: Failed to resolve "System.Void CoreGraphics.CGSize::.ctor(System.Single,System.Single)" reference from "Xamarin.iOS

  • TimBartonTimBarton USMember

    I am also getting this error ater upgrading.

    Error MT2002: Failed to resolve "System.Void CoreGraphics.CGSize::.ctor(System.Single,System.Single)" reference from "Xamarin.iOS

  • Juan.WahyudihardjoJuan.Wahyudihardjo USMember
    edited May 2016

    @DonMesserli.1843 said:
    O just updated Xamarin.Forms to 2.2.0.43 and am getting this error when trying to build for iOS...

    Error MT2002: Failed to resolve "System.Void CoreGraphics.CGSize::.ctor(System.Single,System.Single)" reference from "Xamarin.iOS

    @TimBarton said:
    I am also getting this error ater upgrading.

    Error MT2002: Failed to resolve "System.Void CoreGraphics.CGSize::.ctor(System.Single,System.Single)" reference from "Xamarin.iOS

    Yes, this is the common issue we're facing right now after upgrading to XF 2.2.0.43.. Any idea when will this be fixed?? Luckily, my project whose I am updating the XF version is just a demo project, imagine if the one updated is the live app source code, it will be such a pain (this is where source control or source code backup mechanism plays an important role I believe, so we can easily roll it back to the previous version if the build fails because of XF update)..

  • RaphaelSchindlerRaphaelSchindler USMember ✭✭✭

    @DonMesserli.1843 @TimBarton @JuanWahyudihardjo This is more likely a problem with the Linker. Try to set it to No Linking, this should fix it. At least that was a problem on my end.

  • Juan.WahyudihardjoJuan.Wahyudihardjo USMember
    edited May 2016

    @RaphaelSchindler said:
    @DonMesserli.1843 @TimBarton @JuanWahyudihardjo This is more likely a problem with the Linker. Try to set it to No Linking, this should fix it. At least that was a problem on my end.

    @RaphaelSchindler Sorry, just to make sure I do the correct step, how can I set it to No Linking??
    is it in my Xamarin.IOS project options -> iOS Build -> Linker Behavior -> then we select don't link??

    Thanks in advance

  • RaphaelSchindlerRaphaelSchindler USMember ✭✭✭

    @JuanWahyudihardjo Yes, it's in the options from you Xamarin.iOS options. Right click on solution -> Options -> iOS Build -> Linker behavior to Don't link.

    I get this error on all 3 channels at the moment. So the bug is in Stable/Beta/Alpha release. At least for me

  • Juan.WahyudihardjoJuan.Wahyudihardjo USMember
    edited May 2016

    @RaphaelSchindler said:
    @JuanWahyudihardjo Yes, it's in the options from you Xamarin.iOS options. Right click on solution -> Options -> iOS Build -> Linker behavior to Don't link.

    I get this error on all 3 channels at the moment. So the bug is in Stable/Beta/Alpha release. At least for me

    @RaphaelSchindler after setting it to don't link, it works, but i got many warnings, something like this : "Native Linking warning : object file..... was built for newer iOS version than being linked", is it ok?? Can u also help me to understand what this linking behavior stuff means?:smile:

    I saw there are 3 options : Don't link, Link with frameworks SDK and Link All.. and I've also checked the same way in my xamarin.android project, for the linker behavior, it's no link by default..

  • RogerSchmidlinRogerSchmidlin CHUniversity ✭✭✭

    I would like to see the linker to work properly. What's the use of it, if we can never be sure that our code is working. I have it turned on because otherwise I do get errors.

  • RaphaelSchindlerRaphaelSchindler USMember ✭✭✭

    @JuanWahyudihardjo Yeah the warnings are ignorable. Maybe you just don't have the newest XCode and iOS Version on your Mac or something like that, I'm not sure though :/

    So the linker basically strips out not needed API functions in the used SDK's. Which results in smaller builds for the stores and devices. That part is actually a pretty rad idea, but it must be extremly hard to get this to work properly. That's why I never used Link all. Your app could become unusable if the Linker decides that a used part of the SDK is not used and strips it out. So Linking the Framework SDK's only can work, but right now the linker is just broken^^

  • Juan.WahyudihardjoJuan.Wahyudihardjo USMember
    edited May 2016

    @RaphaelSchindler > @RaphaelSchindler said:

    @JuanWahyudihardjo Yeah the warnings are ignorable. Maybe you just don't have the newest XCode and iOS Version on your Mac or something like that, I'm not sure though :/

    So the linker basically strips out not needed API functions in the used SDK's. Which results in smaller builds for the stores and devices. That part is actually a pretty rad idea, but it must be extremly hard to get this to work properly. That's why I never used Link all. Your app could become unusable if the Linker decides that a used part of the SDK is not used and strips it out. So Linking the Framework SDK's only can work, but right now the linker is just broken^^

    I'm pretty sure that I got the latest version of OS X(10.11.5 El Capitan) and XCode (7.3.1).. but i'm just curious, by setting it to no linking, could it bring impact later in runtime when we run our apps?? I mean it could be some DLL missing or something resulting in error..

  • RaphaelSchindlerRaphaelSchindler USMember ✭✭✭
    edited May 2016

    @JuanWahyudihardjo Hmm ok then I don't know what his problem is^^ No, actually setting it to No Link means that everything is in your app. Even unneeded code, which blows up the app size. If you use Linking then it could be possible that some DLL's could be missing.

  • Juan.WahyudihardjoJuan.Wahyudihardjo USMember
    edited May 2016

    The case was solved in xamarin studio on my Mac, now the problem comes on my Visual Studio 2015 Community, I just made a new test project just to test to connect to my macbook as build host.

    When i update the xamarin forms package to version 2.2.0.43, I straight run my iOS "Welcome to xamarin forms" project on VS 2015 to my testing iphone device, It gives following exception on running base.FinishedLaunching(app, options)

    "Attempting to JIT compile method 'Xamarin.Forms.Platform.iOS.SizeExtensions"..

    Edit : it also happens while trying to run from Mac

    A very serious question , does xamarin really do a unit and regression testing prior to release of a new version or subversion??

    Walao,, if this is the case, then we should always make a backup first of our apps' source code before upgrading to the latest XF..

  • NMackayNMackay GBInsider, University ✭✭✭✭✭
    edited May 2016

    @Juan.Wahyudihardjo

    Seeing the exact same issue after upgrading to Forms 2.2.0.43 with iOS projects. Have to roll back to the previous version on two apps which is a PITA :neutral: Not using linking either as I don't usually for debugging.

  • TonyDTonyD USMember ✭✭✭

    @BryanHunterXam is there a bug tracking this issue with compiling the newly released XF2.2.0.43? Can we get an ETA on a fix for the hotfix?

  • NMackayNMackay GBInsider, University ✭✭✭✭✭

    @BryanHunterXam

    Thanks for the update.

  • CezaryGrabskiCezaryGrabski USMember
    edited May 2016

    Just if all at Xamarin missed some earlier post about TapGestureRecognizer...

    It is still broken on Android, even in 2.3.0-pre3.
    It is working well if used with Image, but not if used with ContentView, Grid (working in 2.1.x), Label or BoxView (I tested only).

    I am using it a lot in my custom controls, so now I must go back to 2.1 or my app will not respond on any tap.

  • CezaryGrabskiCezaryGrabski USMember

    And another problem with 2.2.0.45 on WP8.1

    I have ListView with custom controls as ViewCells, where I have some buttons with TapGestureRecognizer.
    I have disabled standard selection in list by set SelectedItem = null on "ItemSelected" handler and it always work in previous releases of XF in Android and WP8.1.

    But now in 2.2.0.45 on WP listview selects (and only selects, never deselects on second tap) items in backgraoud while tapping on buttons and change colors of my labels in items contentview.

    What interesting SelectedItem is always null, ItemSelected handler is not invoked, seems like only internally list change item visuality to selected state.

    To solving this wrong behaviour I had to add forced set SelectedItem to item was tapped and back to null;

  • NMackayNMackay GBInsider, University ✭✭✭✭✭

    iOS AOT startup issue seems to be resolved now in 2.2.0.45.

  • RyanWatsonRyanWatson USMember ✭✭✭

    @CezaryGrabski said:
    Just if all at Xamarin missed some earlier post about TapGestureRecognizer...

    It is still broken on Android, even in 2.3.0-pre3.
    It is working well if used with Image, but not if used with ContentView, Grid (working in 2.1.x), Label or BoxView (I tested only).

    I am using it a lot in my custom controls, so now I must go back to 2.1 or my app will not respond on any tap.

    @CezaryGrabski I have TapGestureRecognizer working with a Grid in 2.2.0 (upgrading to 2.30 this morning though). The one issue I had is that I had frames and labels with background colors set that were interfering. I have my TGR on the my frame that is in the grid.

  • EdebaliEdebali TRMember

    Hi,

    After updating XForms 2.2.0.45 I have iOS release issue too.

    MTOUCH: error MT2002: Failed to resolve "System.Void CoreGraphics.CGRect::.ctor(System.Single,System.Single,System.Single,System.Single)" reference from "Xamarin.iOS, Version=0.0.0.0, Culture=neutral, PublicKeyToken=84e04ff9cfb79065"
    Task "MTouch" execution -- FAILED

    I am getting this error in release mode. On some threads they said ACR.UserDialogs can cause this. So I updated it to 5.2.2 also.

    Any suggestion?
    Thanks Edebali.

  • DavidAllenDavidAllen USDeveloper Group Leader ✭✭✭

    This (and previous) stable releases do not match the open source repository. For example. InvalidationTrigger has an access modifier of Public in the open source repository, but is Internal in the NuGet package. Please could we get everything in sync? Better still, please could you remove all the Internal modifiers altogether. Whenever I try to extend XF and use the existing classes I'm continually coming across access issues due to classes, properties and methods being marked internal, and then have to use reflection to access them. Not exactly conducive to either fixing bugs or extending functionality!!

Sign In or Register to comment.