Couldn't connect to logcat, GetProcessId returned: 0

Hi.

Approximately 95% of the times I try to deploy/debug on a real device (not an emulator), I instantly get a "Unfortunately, has stopped." message, and no debugger error(s) (all exception options are ticked). Upon inspection of the Visual Studio output, I noticed that it says "Couldn't connect to logcat, GetProcessId returned: 0". ADB finds the device just fine. I've tried restarting the ADB server, and I've unticked "Use Fast Deployment" (like some other threads on this issue suggests) to absolutely zero avail. I've also tried reinstalling everything. I'm using Visual Studio 2015 with the Xamarin plugin (latest versions), but the same thing happens if I use Xamarin Studio. This is getting really frustrating.

Help/suggestions would be greatly appreciated.

Posts

  • i am searching everywhere, i can't solve this problem... :(

  • I'm having the same problem .. and even taking the recommended actions the error persists, try also:
    Android Manifest -->Required Permission -->Enable ACCESS_COARSE_LOCATION and INTERNET(tick)
    Android Options --> Supported Architecture -->Enable armeabi and armeabi-v7a

    and even then the error persists

Sign In or Register to comment.