iOS project : FileNotFoundException on Host invalid path

Hi all,

I develop a cross-platform app using Visual Studio 2015 and build iOS app using an host.
The build failed with this exception :
System.IO.FileNotFoundException: /Users/admin/Library/Caches/Xamarin/mtbs/builds/TeedlMobileiOS/44a299393b33183ffe81e6e2cebbc7ad/obj/iPhoneSimulator/Debug/Images/Calendar/datecell.png does not exist

When I check on my mac, I see that this image is called "Images\Calendar\datecell.png" and its path is "/Users/admin/Library/Caches/Xamarin/mtbs/builds/TeedlMobileiOS/44a299393b33183ffe81e6e2cebbc7ad/obj/iPhoneSimulator/Debug/Images\Calendar\datecell.png"

The path is not correctly set and it's the same issue for all images of Calendar, Checkbox and Radiobutton folders.
How can I fix it please ? Thanks in advance.

I use Xamarin.Forms v2.2.0.5-pre2 but not Toasts.Forms.Plugin (I saw during my search on google that the same issue can happen)

Answers

  • 15mgm1515mgm15 ✭✭✭✭ USMember ✭✭✭✭

    Have you tried to move the images to a parent folder?

  • KarineROBINOTKarineROBINOT USMember

    This image is a xamarin resource, not mine. I can't access it throw my project in the solution explorer.
    The build always delete and recreate the debug folder that contains the invalid path on the mac. So if I try to correct the path manually and run the app, it's no use :/

  • 15mgm1515mgm15 ✭✭✭✭ USMember ✭✭✭✭

    Mmmmhh, What about clean/rebuild the iOS project? Have you also tried to revert back to Xamarin.Forms 2.1.0.6529 stable release? also from which component "Images\Calendar\datecell.png" is?

  • KarineROBINOTKarineROBINOT USMember
    edited April 2016

    I try to :

    • rebuild
    • close solution and rebuilt
    • close the connection with the host, close solution, rebuilt
    • revert to the last stable Xamarin.Forms on the ios project (do I need to revert back on all project (PCL + each platform) ?

    Images comes from Xlabs.Forms.
    I will try to revert the last stable XLabs.Forms but they have a lot of things in beta mode so I risk a regression :/

  • 15mgm1515mgm15 ✭✭✭✭ USMember ✭✭✭✭

    Oohhh then (I suppose) the issue is with XLabs.Forms, I guess you are using Xlabs Calendar which is in beta... maybe contacting directly @MichaelRidland can help!

  • PeterOBrien.4416PeterOBrien.4416 USMember

    I just made a post about this issue... You do have to create the proper directories with the resource files manually. You have to add them to the /Debug directory in real-time as Visual Studio is rebuilding. See:

    https://forums.xamarin.com/discussion/67761/resource-path-bug-in-xamarin-visual-studio-when-building-datecell-png-error/p1?new=1

Sign In or Register to comment.