error MT2002: Failed to resolve assembly: Microsoft.Threading.Tasks

SwappyTimSwappyTim USMember ✭✭

I started getting the following error, but only for AppStore builds. Debug builds work fine. Any ideas? App store builds worked fine yesterday, and I don't know of anything that has changed.

    MTOUCH: error MT2002: Failed to resolve assembly: 'Microsoft.Threading.Tasks, Version=, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a'


  • @TimNichols did you solved your problem and when what did you do?

  • SwappyTimSwappyTim USMember ✭✭

    Yes, I solved the problem. It turned out that error was a red herring. The real error was that I removed PCLStorage (thinking we no longer needed it). I don't know why it complained about Microsoft.Threading.Tasks instead of complaining about PCLStorage. Anyway, once I put PCLStorage back it worked again.

  • HinoHino USMember

    I had this same issue just now. I switched from the Xamarin Alpha Channel and back to the Stable channel to force reinstall of Mono and that fixed the issue. I think for whatever reason my Mono installation got corrupted.

Sign In or Register to comment.