Forum Visual Studio

VS2015 Enterprise issue

YeyiYeyi PHMember

In VS2015 enterprise (Update 2), I tried creating an Android project by choosing "Build native Android apps in C#" project. It created a project with a GetXamarin.xambe file that contains a link to download Xamarin. After installing, when creating the same project, it still just creates a GetXamarin.xambe. I tried this on 2 other machines with the same result. Any help is appreciated. Thanks!

Best Answer


  • VictorGarciaAprea.9996VictorGarciaAprea.9996 USXamarin Team Xamurai

    Hi Yeyi,

    It looks like you don't have Xamarin installed. The "Build native Android apps in C#" template is actually a breadcrumb template (provided by VS core) which only contains instructions for you on how to download and install Xamarin.

    I would suggest that you run the VS 2015 Setup again (Control Panel->Program and Features->Visual Studio 2015->right click->Change->Modify, then look for entries under "Cross Platform Mobile Development" and it should shown "C#/.NET (Xamarin 4.0.3)", please make sure it's checked and proceed with install.

    Let me know if that works!

  • YeyiYeyi PHMember

    Hi Victor,

    Thanks for replying. I have tried that prior to posting and I find it strange that the installer will report "Success" but seems to not have done anything after launching VS2015. I have tried this again in another machine and a VM with the same results. The only thing similar with them is they used the same base installer for VS but I downloaded the xamarin setup for vs separately on each machine. I also tried both normal and running as admin to no avail. Any ideas?


Sign In or Register to comment.