Forum Workbooks & Inspector

Could not start xamarin inspector

v3yr0nv3yr0n USUniversity ✭✭
edited April 2016 in Workbooks & Inspector

I was just testing xamarin inspector but i'm not able to start it in any project. Tried ios, android, xamarin forms.
I've installed xamarin inspector and i've downloaded xamarin studio 6.0 from beta channel

Xamarin Studio Enterprise
Version 6.0 (build 4968)
Installation UUID: 1749d22d-523b-4d28-be8f-e77ad7b87418
Mono 4.4.0 (mono-4.4.0-branch/a3fabf1) (64-bit)
GTK+ 2.24.23 (Raleigh theme)

Location: /Applications/Xamarin Profiler

Version: (Xamarin Enterprise)

Version: (Xamarin Enterprise)

Basically when I click in the "target icon" nothing happens but in the console I have:
Xamarin Inspector Integration
Enabled for project: yes
Hash: 545e74c

Anyone with the same issue?


@SandyArmstrong can you help? :)

Best Answers


  • v3yr0nv3yr0n USUniversity ✭✭

    No problem @SandyArmstrong, just wanted to let you know :)

  • v3yr0nv3yr0n USUniversity ✭✭

    @abock said:
    This has been addressed in the just-released 0.7.2. Please give it a try! Thanks!

    Yep, this one works. Thanks!

  • pfedotovskypfedotovsky RUMember ✭✭
    edited April 2016

    I have the same issue. I'm using Visual Studio 2015 Update 2 with Alpha Xamarin version.
    I'm trying to inspect my Xamarin.Forms project. So I run the Android emulator, then click 'Inspect' - and nothing happens.
    How to resolve this issue?

    I have the following tools versions:

    Microsoft Visual Studio Enterprise 2015
    Version 14.0.25123.00 Update 2
    Microsoft .NET Framework
    Version 4.6.01038

    Xamarin (514438c)
    Visual Studio extension to enable development for Xamarin.iOS and Xamarin.Android.

    Xamarin Inspector Support (357da8b)
    Adds support for inspecting Xamarin and WPF apps.

    Xamarin.Android (b4be22e)
    Visual Studio extension to enable development for Xamarin.Android.

    Xamarin.iOS (977921b)
    Visual Studio extension to enable development for Xamarin.iOS.

  • SandyArmstrongSandyArmstrong USXamarin Team, Insider Xamurai

    @pfedotovsky Are you using Xamarin Inspector 0.7.2? Are you using either the Visual Studio Android Emulator, or Xamarin Android Player? Do you have Debug configuration selected?

    Please check out the Android requirements here, as well:

  • pfedotovskypfedotovsky RUMember ✭✭

    @SandyArmstrong I'm using Xamarin.Inspector 0.7.2 and Visual Studio Android Emulator, debug configuration is selected.
    I've read the requirements, the only thing I'm unsure is "Must have fastdev enabled", could you please elaborate on that?

  • SandyArmstrongSandyArmstrong USXamarin Team, Insider Xamurai

    Right click your startup project, go to Properties.

    Then go to Android Options -> Packaging and make sure Use Shared Runtime and Use Fast Deployment are both checked.

    Then switch to the Linker tab and make sure Linking is set to None.

  • SandyArmstrongSandyArmstrong USXamarin Team, Insider Xamurai
  • pfedotovskypfedotovsky RUMember ✭✭

    @SandyArmstrong I can't enable "Use Fast Deployment" as it is disabled:

    I don't know why this setting is disabled, could you please help?

  • SandyArmstrongSandyArmstrong USXamarin Team, Insider Xamurai

    @pfedotovsky The only time that option is disabled for me is if I switch to a Release configuration. Are you 100% sure you're in Debug mode?

    Doing some searching, I see another XF user complaining of something similar. I cannot reproduce myself with a new XF project from templates.

    If you are in Debug mode and still see this, you'll want to inquire with the Android and/or XF team.

    Live app inspection absolutely requires it.

  • batmacibatmaci DEMember ✭✭✭✭✭

    Live app inspection is available for enterprise customers.

    is it VS enterprise? I am running on VS professional and I entered xamarin account which is business. Am I supposed to get that working for me?

  • SandyArmstrongSandyArmstrong USXamarin Team, Insider Xamurai

    @batmaci the way the check works right now, iOS and Android inspection require a Xamarin Enterprise license, and VS Pro is OK as long as that license is Xamarin Enterprise. WPF inspection only works on VS Enterprise, though.

    We may change future versions to only install into VS Enterprise for the sake of consistency. My understanding is that a Xamarin Enterprise license grants access to VS Enterprise.

    If you have further questions about licensing, best to take it up with support. They know all the business vs enterprise stuff better than I do. :-)

  • batmacibatmaci DEMember ✭✭✭✭✭

    @SandyArmstrong I see xamarin licenses are renamed. on my account it show business license this should be equal to enterprise right? Business was the highest available license last year if i remember correctly

  • SandyArmstrongSandyArmstrong USXamarin Team, Insider Xamurai

    @batmaci I just checked with support, and the Xamarin Enterprise tier did exist last year, and is not equivalent to Xamarin Business.

    So, if you have VS Pro and Xamarin Business, the Inspector will not show up for you. Sorry for any confusion.

  • batmacibatmaci DEMember ✭✭✭✭✭

    @SandyArmstrong thanks for making it clear. Just wondering. Does this apply also for VS2017 RC enterprise? do we get there inspector?

  • SandyArmstrongSandyArmstrong USXamarin Team, Insider Xamurai

    @batmaci Inspector doesn't support VS2017 yet. Once it does, I expect it would work in the RC.

    VS2017 support is coming soon.

  • batmacibatmaci DEMember ✭✭✭✭✭

    After watching Keynotes day 1, I thought what @JamesMontemagno presented was VS2017 with previewer and inspector. on the other hand, I found unfair that regarding inspector you didnt indicate or document that it is only for enterprise. many people like me wasting their time to search why "inspector button is gray" and try to make it run.

  • SandyArmstrongSandyArmstrong USXamarin Team, Insider Xamurai

    @batmaci Most of James' demo was done with VS2017, yes. The segment where he showed the Inspector used VS2015.

    We try to make it very clear that Inspector is Enterprise-only. It is mentioned in several places:

    I should have mentioned it again in the 1.0 release notes, although I'm not very confident that it would have been noticed there either.

    What do you suggest we do differently to make it more obvious?

This discussion has been closed.