Upload error, Unexpected character encountered while parsing value

I have noticed in a few threads (here, [here(https://forums.xamarin.com/discussion/comment/143571)) that people were having troubles uploading an app to Xamarin Test Cloud. Those posts were old but none of the solutions worked.

Error I get is

Unexpected character encountered while parsing value: <. Path '', line 0, position 0.

I created a new project with the same bundle ID and the same Info.plist and I am able to upload to XTC with that. But clearly isn't the app I want to test (though I did try out text input and screenshots, this system is awesome).

There is nothing else on my end that I can think of causing the problems. I did notice my .ipa file was about 230mb but had not seen anything about a max filesize for XTC.

I tried to use the --debug option to get more info when I ran the same command to upload from terminal but it did not help. Any suggestions what to do or why XTC servers may be erroring on my files?

Posts

  • bradmbradm AUMember ✭✭✭

    Sorted it out. Issue was I had linker behavior set to "Don't link", changing it to "Link Framework SDKs Only".
    Hope this helps someone else if they have this issue.

Sign In or Register to comment.