Framework .NET 4.5.2 not installed

Dear xamarin developers,

I am checking out from a repository on TFS and the project was created on a windows machine that is a Web API 5 solution. I am trying to run this on Xamarin studio on a MAC and I have had no luck. All of the packages say that I do not have .NET 4.5.2 installed. I tried lowering to 4.5.1 as well as Mono/.NET 4.5 || Mono/.NET 4.0 etc all of them that I have.

Xamarin 5.9.7
Business License

When I do downgrade to .NET Framework 4.5.1 almost all my packages are compatible except System.Web.Entity
When I try and build my project I receive the error that my CSC file cannot be located and the debugging info cannot be written.

I don't know what else todo,
I tried downloading the latest version of Xamarin, switching channels from alpha to beta, downloading mono directly from the site and running the script through command line and still does not work.

Is this type of project incompatible with Xamarin? Is there an ad in that I can install ?

Let me know

Canadian Xamarin Developer - Eric :)

Posts

  • sethderricksethderrick USMember

    Looking forward to someone answering this as I'm stuck in the same situation.

  • Can anybody at Xamarin please answer this?

  • erichugheserichughes CAMember

    I gave up, installed windows 10 and visual studio 2015. Now we're both on windows and its just easier

  • SkovorodkaSkovorodka USMember ✭✭

    Same problem. Is there a way to install .net framework 4.5.2 or higher on Mac OS X?

  • JunleLiJunleLi USMember
    edited April 2016

    I get into the same problem. However, I am running Windows 10 and .Net 4.6.1 is installed (in folder C:\Program Files (x86)\Reference Assemblies\Microsoft\Framework\.NETFramework\v4.6.1).

    As a workaround, I make a symbolic link to 4.6.1 for 4.5.2 version:

    cd C:\Program Files (x86)\Reference Assemblies\Microsoft\Framework\.NETFramework
    mklink /J v4.5.2 v4.6.1
    

    Now, XS compile passes.

Sign In or Register to comment.