Forum Visual Studio

Announcement:

The Xamarin Forums have officially moved to the new Microsoft Q&A experience. Microsoft Q&A is the home for technical questions and answers at across all products at Microsoft now including Xamarin!

To create new threads and ask questions head over to Microsoft Q&A for .NET and get involved today.

Xamarin.VS 4.0.1.147 is broken

AndreiAlistarAndreiAlistar USMember
edited March 2016 in Visual Studio

Everything installs fine, but when I open VS I get a bunch of errors: http://imgur.com/a/VDUrN

I tried clean install, universal installer, the .msi installer and all have the same results.

Opening a Xamarin project marks it as unavailable and incompatible.

In the 'about' section of VS, the Xamarin version is not displayed.

In control panel > programs and features, everything looks fine.

I also tried repairing both Xamarin and VS installations but with no success.

Posts

  • AndreiAlistarAndreiAlistar USMember
    edited March 2016

    This is how an ActivityLog.xml entry looks like:

    327

    Error

    VisualStudio
    End package load [XamarinShellPackage]
    {2D510815-1C4E-4210-BD82-3D9D2C56C140}

    80004005 - E_FAIL
    Could not load file or assembly 'file:///C:\Program Files (x86)\Microsoft Visual Studio 12.0\Common7\IDE\Extensions\Xamarin\Xamarin\4.0.1.147\Xamarin.VisualStudio.Shell.dll' or one of its dependencies. The system cannot find the file specified.
  • AndreiAlistarAndreiAlistar USMember

    However, of course I have the file there: http://imgur.com/02c7t2T

  • JeremyKolbJeremyKolb USMember ✭✭✭

    Open an admin command prompt, go to where you have visual studio installed and run 'devenv.exe /setup'. It will take a while as it rebuilds your configuration (don't worry you won't lose anything) but it usually fixes this sort of issue for me.

Sign In or Register to comment.