Forum Xamarin.iOS

New app icon required of 167x167 when trying to upload IPA build to iTunes

GaryBeasleyGaryBeasley USMember ✭✭

Just started getting error about a missing required app icon file. It says it's for the iPad and needs to be 167 x 167. I use Visual Studio 2013 and I don't see a place on the Properties->iOS Application tab for an image of that size. How would I go about adding that image to the project manually?

Thanks in advance.


  • DaveHuntDaveHunt USMember ✭✭✭✭✭

    You should be using an Asset Catalog to manage your application icons.

    See also this topic for potiential issues/workarounds/fixes for the 167x167 image.

  • GaryBeasleyGaryBeasley USMember ✭✭

    Thanks, but when I add a new Asset Catalog in VS 2013, and I name it "Images", then I add all the images to their respective slots, it won't save. When I try to save, it gives the error that it can't find the "Images" file and it's not even looking in my project folders, it's saying it can't find the file in C:\Program Files (x86)\Microsoft Visual Studio 12.0\Common7\IDE\Images.

    So.. should I name the file with an extension?

  • DaveHuntDaveHunt USMember ✭✭✭✭✭

    Did you follow the instructions to migrate from Info.plist to asset catalogs? That should have created the asset catalog in the correct location and automatically placed your existing icons in it.

  • GaryBeasleyGaryBeasley USMember ✭✭

    Thanks Dave!!!
    Here's the problem. When I double click on the info.plist file in iOS app in VS, it doesn't give the designer, even if you right click and choose the designer over code. It just shows the code. From the documentation, it shows the same screen I get if I go to the Properties and edit there. This is where my images currently are showing up, minus the 167x167 of course. Anyway, the pulldown for Asset Catalogs doesn't have an option other than "Don't Use Asset Catalogs".

    If I right click back in solutions explorer on the Asset Catalog folder and add new, it gives me the option to add a new asset catalog, and the default name is "media" with no extension. I rename it to "Images" with no extension and it opens up just like you would expect, and allows you to add the images. The problem is when you go to save, it doesn't allow it and gives the aforementioned error message about not being able to find the file. Even though I can't save anything to that asset catalog, when you go back to the Properties area, you can then choose to Use the asset catalog just created.

    There apparently is a bug in VS implementation when trying to save a Asset Catalog after adding. Couldn't I just manually update Content.json file?

  • DaveHuntDaveHunt USMember ✭✭✭✭✭

    I would think that would work. Or you can stick with the Info.plist and use the manual workaround as it seems you're considering from your post in the other thread.

  • GaryBeasleyGaryBeasley USMember ✭✭

    Thanks. I did stick with the info.plist route and got the .ipa uploaded just now. Yeah! I wouldn't mind using the Asset Catalog option, but I can't save the file once created, even if I don't add any images to it. Weird VS / Xamarin issue.
    Thanks for your help!

Sign In or Register to comment.