How to install iOS SDK version less than 9.2?

ManishpManishp USMember ✭✭

Hi,

I am doing development for iPhone app using MS Visual Studio (using Xamarin Portable cross platform app). I have iOS SDK version 9.2 installed, but after creating .ipa, When I installed on iPhone then it is showing message "You need to upgrade Software". My iPhone has iOS 9.1 installed.

I don't want update iPhone iOS version to 9.2. How can I create .ipa for iOS 9.1 version? How to install backward iOS version for visual studio ( Please give me link of backward iOS versions, So I can install it. )

Thanks and Regards,
Manish

Posts

  • KatieJohnstoneKatieJohnstone GBMember ✭✭

    Same problem here, I have two devices connected to MAC on the latest version of X-Code. I can deploy to the device with iOS 9.2 but my old iPhone 4 at version 7.1 will not work. Also in Visual Studio the SDK version in the properties window for the project is a combo box with just version 9.2 selectable. For Xamarin to be viable for apps to the store I will need to be able to build for people running older phone SDK's.

  • KatieJohnstoneKatieJohnstone GBMember ✭✭

    Hi, I back. This was resolved by changing Properties -> iOSApplications -> Deployment Target and reducing it to 7.0 (for my old phone). The saving the project and restarting visual studio. If you don't restart Visual Studio is won't work. There is still no option for 7.0 in Properties -> iOSBuild -> SDK Version but that doesn't seem to matter. Hope this helps someone.

Sign In or Register to comment.