Is there a bug in WinPhone (WinRT) - SearchBar?

I have a SearchBar defined in Xaml:

In Android and Win Desktop the SearchText is correctly bound.

In WinPhone (WinRT) SearchText is an empty string.

Since the binding is working correctly in Android and Win Desktop, I suspect this is a bug in Xamarin forms. Can anyone confirm that/ has anyone successfully bound to a SearchBar in the new Windows Phone Xamarin.Forms?

Thanks,

Answers

  • PeterWyssPeterWyss CHMember

    Hy

    I've the same issue...Binding (in a Xamarin.Forms SearchBar) does not work in a Win RT WinPhone 8.1 Project.

    Also the TextChanged Event does not work.

    Can anyone from Xamarin confirm this is a Bug?

    Kind regards,
    Peter

  • Tiago_MartinsTiago_Martins PTMember

    I'm also having this problem. Defining the SearchBar like this:

    And when I test it on Android, the Text property is with the text that I inserted, on Windows Phone 8.1 it's an empty string.

    Does anyone knows how to solve this?

  • SubhaMuralidharanSubhaMuralidharan USMember ✭✭
    edited July 2015

    Recently started Windows Phone development and my environment is Windows Phone 8.1 (Runtime). Facing similar issue exactly as posted above. Shared Forms SearchBar code working for Android & iOS and showing blank space in Windows. Has anyone fixed this issue?

  • I'm also facing same issue, TextProperty is always giving empty string. Even binding the Text or getting searchBar.Text doesn't work. Any hotfix to resolve this issue?

  • aarthidlaarthidl USMember ✭✭

    Hi all,
    I am also having the same issue, The text value is still empty. Please anyone resolve this issue as soon!

  • rarenivarrarenivar USMember ✭✭

    I'm having the same issue, the binding is working as expected on Android and iOS but not on Windows Phone 8.1 (using Xamarin.Forms 2.0.1).
    Seems like this is a bug with Xamarin.Forms.

  • rarenivarrarenivar USMember ✭✭

    This bug has been fixed in the latest pre-release version (2.1.0-pre4). After upgrading to this version, my SearchBar element is working as expected. See version release notes here

Sign In or Register to comment.