Android 5.1 Build Error

I just installed the Stable releases of the Xamarin platform released today. I can no longer build the Android projects I was working on, and were running just fine prior to the update.

The error in the build log is:

Target _CompileToDalvik:
Tool /System/Library/Java/JavaVirtualMachines/1.6.0.jdk/Contents/Home/bin/java execution started with arguments: -jar /Developer/android-sdk-macosx/build-tools/18.0.1//lib/dx.jar --no-strict --dex --output=obj/Debug/android/bin obj/Debug/android/bin/classes /Library/Frameworks/Mono.framework/External/xbuild-frameworks/MonoAndroid/v4.4/mono.android.jar
unknown output extension: obj/Debug/android/bin
usage:
dx --dex [--debug] [--verbose] [--positions=] [--no-locals]
[--no-optimize] [--statistics] [--[no-]optimize-list=] [--no-strict]
[--keep-classes] [--output=] [--dump-to=] [--dump-width=]
[--dump-method=[*]] [--verbose-dump] [--no-files] [--core-library]
[--num-threads=] [--incremental] [--force-jumbo]
[.class | .{zip,jar,apk} | ] ...
Convert a set of classfiles into a dex file, optionally embedded in a
jar/zip. Output name must end with one of: .dex .jar .zip .apk. Positions
options: none, important, lines.
dx --annotool --annotation= [--element=]
[--print=]
dx --dump [--debug] [--strict] [--bytes] [--optimize]
[--basic-blocks | --rop-blocks | --ssa-blocks | --dot] [--ssa-step=]
[--width=] [.class | .txt] ...
Dump classfiles, or transformations thereof, in a human-oriented format.
dx --find-usages <file.dex>
Find references and declarations to a field or method.
declaring type: a class name in internal form, like Ljava/lang/Object;
member: a field or method name, like hashCode
dx -J ... <arguments, in one of the above forms>
Pass VM-specific options to the virtual machine that runs dx.
dx --version
Print the version of this tool (1.7).
dx --help
Print this message.

For the heck of it I created a fresh Android project and it built the first time but now gives the same error.

Any thoughts?

Posts

  • DavidCarawayDavidCaraway USBeta ✭✭

    OK, I fixed my problem. I had to reinstall Xamarin. Despite pulling down this update the installer indicated it needed to install Xamarin Android 5.1.0 and the Android SDK 22. Something must not have updated properly.

  • KithenKithen SEMember

    Just got the same error. Have anyone else had this problem and solved it on another way than reinstalling Xamarin?

  • Same problem here

Sign In or Register to comment.