Inspector Button Missing From XS IDE After Installing 0.5 Preview

AdamZucchiAdamZucchi USUniversity, Developer Group Leader ✭✭✭

After updating to Inspector 0.5 Preview, the Inspector button has vanished from my Xamarin Studio IDE. I am on a Mac running 10.11.2 running Xamarin Studio 5.10.1 (build 6). The only thing I can think of is if the Inspector has since been only made available to Business and up licenses (I am running an Indie account).

We were hoping to show off Inspector this evening at a Xamarin 4 party, thanks for the help in advance!

Posts

  • AdamZucchiAdamZucchi USUniversity, Developer Group Leader ✭✭✭

    One other thing to note, initially 0.5 seemed to work fine and be accessible in Xamarin Studio after installing 0.5, however the button disappeared after restarting my Mac and reopening the Xamarin Studio IDE.

  • SandyArmstrongSandyArmstrong USXamarin Team, Insider Xamurai
    edited January 2016

    We have not made any licensing changes in the Inspector.

    Do you see the Inspector add-in in Xamarin Studio's Add-in Manager? If so, can you attach XS's IDE log?

    What kind of project do you have open that you are trying to inspect?

    If all else fails, you could demo the new Standalone Mode.

  • AdamZucchiAdamZucchi USUniversity, Developer Group Leader ✭✭✭

    Xamarin Inspector within the Ad-In Manager is showing "This add-in can't be loaded due to missing dependencies."

    Here is a screenshot of that message:

    Any idea why those dependencies would be missing and how to fix?

    Thanks!

  • SandyArmstrongSandyArmstrong USXamarin Team, Insider Xamurai

    It looks like our Mac build machine was set to use the alpha channel instead of stable. We'll fix this for the next release.

    You could upgrade to the alpha channel if you want. The other option is to downgrade to 0.4.0, which I believe was built against an older Xamarin Studio.

    Standalone mode should work in 0.5.0 if neither of those options are desired.

    Sorry for the trouble.

  • AdamZucchiAdamZucchi USUniversity, Developer Group Leader ✭✭✭

    I tried to download 0.4 earlier today from the 0.4 release page, however that package that downloaded ended up being the 0.5 installer. Could you give me a link to the 0.4 installer package?

  • AdamZucchiAdamZucchi USUniversity, Developer Group Leader ✭✭✭

    Great, I'll try that when we get to the presentation site. Thanks!

  • SandyArmstrongSandyArmstrong USXamarin Team, Insider Xamurai

    FWIW, Xamarin Studio 5.10.2 has been promoted to the beta channel today.

  • Having the same issue today. It worked two nights ago and I came back yesterday and the button did not appear.
    I tried downloading and installing 0.4.0 but it is not installing the ide add-in

    I am doing a lightning talk tomorrow evening at a meetup and I need to get this working.

    Thanks,
    Jackson

  • SandyArmstrongSandyArmstrong USXamarin Team, Insider Xamurai

    @JacksonHayes.1947

    1) Can you post the output of About Xamarin Studio -> Show Details?
    2) Did you download 0.4.0 from the link I posted above?
    3) What kind of project are you trying to inspect?
    4) Did you make sure you have that project in debug configuration, and having linking totally disabled?

  • SandyArmstrongSandyArmstrong USXamarin Team, Insider Xamurai

    Xamarin Studio 10.5.2 is now in the stable channel. Please let us know if you have any further issues with Inspector 0.5.0 after upgrading XS.

This discussion has been closed.