Forum Xamarin.Android

The application could not be started error when debuging andorid project in Visual Sutido

I am tried the source code of Tasky, tried it within visual studio 2013 update2 version. The related android simulator is already started, when tried debuging it raised the error"The application could not be started error". Ensure the application has been installed to the target device and has a launchable activity (Mainlauncher=true).

does that mean I need to have the app built and installed on the android simulator firstly? I already tried the build, it succeed.


  • MoeenAleemMoeenAleem USMember

    Just in the activity code , Set vale like this
    [Activity (Label = "Your Project Name", MainLauncher = true, Icon = "@drawable/icon")]

    and in Configuration, Select Debug option and choose Platform (In Xamarin,platform is Any CPU)

    Hope this Helps

  • RustamGalljamovRustamGalljamov USMember ✭✭

    What also often helps - and helped me with the same issue - is to uninstall the app before deploying it again to the device.
    Best Luck!

  • veerooveeroo USMember ✭✭

    In this case, uninstalling Mono Shared Runtime and Xamarin.Android API-xx Support helped me

  • Victor.6438Victor.6438 USMember

    I met the same issue, it works fine after uninstalled Mono Shared Runtime and Android Api-xx Support.

  • johannes.jacobsjohannes.jacobs DEMember
    edited January 2016

    Connect your phone to pc and run adb uninstall com.example.yourapp.

    Then just start again.

  • I had the same error today, trying to run Xamarin Android-app on Xamarin Android Player. To fix it I needed to check the "x86" box at the "Supported architectures" section.

  • BalakrishnanSBalakrishnanS USMember ✭✭

    The app is not shown in the front end, but The App will be listed in application manager. if you Uninstall the application from Application Manager, then only you can able to install again.

  • RamaBhandaruRamaBhandaru USMember, University
    edited February 2016

    In instances when the app is not shown in the apps section, use the adb command prompt to manually uninstall it.
    adb uninstall package-name

  • JoseMirallesJoseMiralles USMember ✭✭

    I was having the same issue after installing my app from the play store. I decided to start debugging without first uninstalling my signed app, the debugger uninstalled the app and could then not install the debug version of the app.

    I went back to the store, installed and uninstalled my app, and now it works. I Hope this helps someone.

  • NurhakKayaNurhakKaya USMember ✭✭

    Uninstall the app from your mobile phone then you can debug.

  • I solved it going to Settings > Applications and uninstalling the app and the other components like the Mono Runtime and so on.

  • MikkelRostockMikkelRostock DKMember ✭✭

    Unstalling the app from Settings -> Applications as suggested by JavierEscobar.2080 solved the problem for me.


Sign In or Register to comment.