Unable to update a PCL to include Xamarin.Android without losing .Net Framework 4.6 (i.e. C#6)

I am unable to update a PCL to include Xamarin.Android without the .Net Framework being dropped down from 4.6 to 4.5.

I have attempted the following:

$(MSBuildProgramFiles32)\MSBuild\14.0\Bin

I need to use C#6 and I thought this was supported out of the box.
What am I doing wrong?

Tagged:

Answers

  • JamesMontemagnoJamesMontemagno USForum Administrator, Xamarin Team, Developer Group Leader Xamurai

    .net 4.5 is not required for C# 6 at all, only VS 2015 or Xamarin Studio. You can just leave the PCL set to .net 4.5 and you will be all set as that is what is supported with Xamarin apps

Sign In or Register to comment.