Time Profiler doesn't work

SvenSven ✭✭USInsider ✭✭

Hi,

I tried profiling an App. The Memory profiling works as expected, but I'm interested in the time profiling. It shows 0ms everywhere.
Device: iOS 8.1.1
Xcode: 6.2
Mac: OSX 10.9.5
Xamarin Studio: 5.8
Xamarin Profiler: 0.12-0 (1)

What am I doing wrong?

rgds Sven

Posts

  • SimonTaylor.2787SimonTaylor.2787 ✭✭ AUMember ✭✭
    edited May 2015

    I'm seeing this on Android with Xamarin Profiler 0.14, Galaxy Nexus running Android 4.3, Nexus 7 running Android 5.1. Heap profiling is working. I don't think the exception in the log file is relevant - it occurs well after the profile information is displayed.

    Same result on Xamarin Profiler 0.12 and 0.13, this has worked on previous versions.

    Edit - this is a known issue https://bugzilla.xamarin.com/show_bug.cgi?id=29729

  • RodrigoMoyaRodrigoMoya Xamurai ESXamarin Team Xamurai

    Yes, sampling, which is what we use now for timing, doesn't work yet on Android and iOS devices. The fix for Android is coming soon, in an update to the channels in the next few days/weeks. As for iOS, it might take some more time.

    Before it worked because we used method enter/leave information for timing, which wasn't accurate and also added a lot of overhead, as the amount of information the runtime profiler generates for method enter/leave is huge. So, we've decided to disable that and use the more accurate information sampling gives us.

  • voidvoid ✭✭✭ DKBeta ✭✭✭

    Nice to know.

  • pradeepArutlapradeepArutla ✭✭ USUniversity ✭✭

    Is this issue fixed by now? How do I get the information about the fix. I am still facing the same issue for android App.

  • JosephRedfernJosephRedfern ✭✭ GBMember ✭✭
    edited August 2015

    The fix landed last week - timing works under Android in 0.19 (using method entry/exit timings rather than sampling, but it's better than nothing).

  • AntHAntH ✭✭ GBMember ✭✭

    Is this still broken for iOS? I can see values under Running Time, but Self is still 0 for everything. Using Profiler 0.22-0(1)

    Also sort by running time doesn't work

  • NuninzNuninz ✭✭ USMember ✭✭

    yep iOS still broken

  • ThomasFlemmingThomasFlemming ✭✭ DEMember ✭✭

    How is time-profiling suppose to work?
    I marked a time-range of 4 sec, where I want to find out, what my app is doing there, but all I get is one entry object:runtime_invoke.... 39398ms 100%. But is happening in there?
    Using profiler 0.24 with an Xamarin.Forms.android project.

  • GeorgeCookGeorgeCook ✭✭✭ PEUniversity ✭✭✭

    Why is there an option there if it doesn't work? For your marketing pictures!??
    @RodrigoMoya what's the ETA on this? and where's the docs to say it doesn't work? I think it's disingenuous at best to not clarify this feature as not working in the UI and the documentation. All this time I thought this feature was there, and then when I need it I find out it's just marketing fluff. This is very disappointing.

  • GeorgeCookGeorgeCook ✭✭✭ PEUniversity ✭✭✭

    and @ThomasFlemming at least you get something.. this is all we get 0% or totally blank. @JosephRedfern how did you get it to work?

  • ThomasFlemmingThomasFlemming ✭✭ DEMember ✭✭

    My sample is a Android-app using Visual Studio 2015 on Windows. So its a different version of the Profiler. I didn't do anything special, just following the profiler docs.

  • I'm just trying the Profiler for the first time today. When I launch the profiler the only enabled option is for Allocations. Does anyone know why Time Profiler would be disabled?

    I am using Xamarin Studio 5.10.1 with Xamarin Profiler 0.30.0 on a Mac. I am attempting to use the profiler along with the Xamarin Android Player and I have tried a variety of Device types including Nexus 4, 5 & 7 so far with no success. Is it restricted to a hardware build only? Is it disabled for everyone?

  • RodrigoMoyaRodrigoMoya Xamurai ESXamarin Team Xamurai

    Yes, with the last version of the profiler, we have disabled the time instrument, as it uses sampling, which doesn't work on all devices/os versions combinations. We are looking at fixing it in Mono, but for the time being, we were getting so many crash reports about sampling that until we fix it, we decided to disable it.

    Hopefully we will have the runtime bits fixed very soon, so it will be re-enabled.

  • MiraHolanMiraHolan CZMember

    I have the same problem as JonathanParham.6364 - have downloaded Profiler v.30 with disabled option for time profiling. Is there a way for downloading some older version of profiler with some kind of time profiling activated? Anything better than nothing... (I have looked for some older release but found nothing) Thanks

  • i_NateCooki_NateCook ✭✭ USMember ✭✭

    @RodrigoMoya The Time Profiler was actually working fine for us. Very disappointed in the decision to disable it completely. Would it not have been better to just add a warning about its instability?

  • marlon.constantemarlon.constante ✭✭ BRMember ✭✭

    @RodrigoMoya It would be possible to provide the version 0.24 for download, where Time Profiler feature is available?

  • evgeny.loskutovevgeny.loskutov USMember

    @marlon.constante said:
    @RodrigoMoya It would be possible to provide the version 0.24 for download, where Time Profiler feature is available?

    I believe I had 0.24 installed when I tried using Time Profiler last time. It refused to profile our apps, forcing me to update to 0.30. Just for me to realize that time profiling is disabled in 0.30 all together. Which is a shame because Time Profiler was a great help in optimizing our apps and we never had any major problems with it. I'd love to see it re-enabled rather sooner than later.

  • BastiBrauningBastiBrauning USMember

    I never had problems with the time profiler, too.

    Would be really nice to have it back. Upgraded to .030 and now stuck because I can't omptimize our application anymore without the time profiler.

  • KentCHKentCH USUniversity

    This thread was opened March 2015. We are fast approaching March 2016, and the Time Profiler is still not enabled.

  • spaceMonsterspaceMonster ✭✭ USMember ✭✭

    Just to bump this thread back up... Please Xamarin give us the Time Profiler back!!! I don't care if it is buggy....

    I envy Android Studio 2 users :-(

  • BradChase.2654BradChase.2654 ✭✭✭ USMember ✭✭✭

    @spaceMonster Cant you just use an older copy? Thats what I use to time profile...

  • RodrigoMoyaRodrigoMoya Xamurai ESXamarin Team Xamurai

    in 0.33.0 the time profiler is enabled again, although there are still some problems in the runtime, so please, whenever you find any, report it (in Bugzilla so that we can fix them all :smile:

  • MatteoMonizzaMatteoMonizza ✭✭ ITBeta ✭✭

    In 0.33.1 Time Profiler returns always 0ms

  • DimaMovchanDimaMovchan ✭✭ USMember ✭✭

    In 0.38 still not working properly.
    How can happen that after almost 2 years Profiler still not usable???
    The only version that worked properly for time profiling was 0.24.
    Please make all versions of Profiler can be downloaded so we can work with something that really works!!!

  • RodrigoMoyaRodrigoMoya Xamurai ESXamarin Team Xamurai

    In 0.24 and previous versions, what we had was a "guess", as we were using method enter/leave for calculating it, which took only into account managed code, so the results were in most cases invalid (wait time, for instance, was computed as time spent on the method that was waiting, which was invalid).

    Now we use real sampling for knowing time information of the app, I guess that's why you think it doesn't work? That is, what is exactly not "working properly"?

    Also, we could make profiler 0.24 available for download, but unless you also use old XS/X.Android/X.iOS, it's not going to work, as there are a lot of changes in the full toolchain. So better give us details on what doesn't work for you, and we'll fix it.

  • DimaMovchanDimaMovchan ✭✭ USMember ✭✭

    Now we use real sampling for knowing time information of the app

    The information is not alway correct and updated. I posted a bug and hope it will be solved soon.

    P.S. 0.24 version of profiler was not perfect but it worked. In 0.38 time profiling is not usable. I can't rely on the data displayed there. How can happen that after almost 2 years Profiler still not usable???

Sign In or Register to comment.