Can't deploy to device

Hi everyone I'm new using Xamarin, I was working with xcode and android studio, but is time to give a try to xam. that cross platform feature sounds cool :)

Ok this is it
I've been trying to deploy a simple app to my physical device but Xamarin doesn't deploy, it always give a "Aborted" error.
This is the log:

2015-11-30 14:18:06.9] DEBUG: RunShellCommand: e4cad828 am broadcast -a "mono.android.intent.action.PACKAGE_VERSIONS" -e "packages" >"Mono.Android.DebugRuntime,Mono.Android.Platform.ApiLevel_21,com.jabg.dev_est4" >"Mono.Android.DebugRuntime/com.xamarin.mono.android.PackageVersions"
[2015-11-30 14:18:09.0] DEBUG: RunShellCommand: e4cad828 cat /data/system/packages.xml
[2015-11-30 14:18:09.1] DEBUG: RunShellCommand: e4cad828 cat /dbdata/system/packages.xml
[2015-11-30 14:18:09.1] DEBUG: RunShellCommand: e4cad828 pm uninstall "Mono.Android.DebugRuntime"
[2015-11-30 14:18:09.1] DEBUG: RunShellCommand: e4cad828 pm uninstall "Mono.Android.DebugRuntime"
[2015-11-30 14:18:16.3] DEBUG: RunShellCommand: e4cad828 pm install "/data/local/tmp/Mono.Android.DebugRuntime-armeabi-v7a.apk"
[2015-11-30 14:18:18.4] DEBUG: RunShellCommand: e4cad828 rm "/data/local/tmp/Mono.Android.DebugRuntime-armeabi-v7a.apk"
[2015-11-30 14:18:18.5] ERROR: Deployment failed
Mono.AndroidTools.InstallFailedException: Unexpected install output: Aborted

at Mono.AndroidTools.Internal.AdbOutputParsing.CheckInstallSuccess (System.String output, System.String packageName) [0x0015b] in >/Users/builder/data/lanes/2508/bee8b405/source/md->addins/MonoDevelop.MonoDroid/external/androidtools/Mono.AndroidTools/Internal/AdbOutputParsing.cs:323
at Mono.AndroidTools.AndroidDevice+c__AnonStoreyD.<>m__0 (System.Threading.Tasks.Task1 t) [0x00023] in >/Users/builder/data/lanes/2508/bee8b405/source/md->addins/MonoDevelop.MonoDroid/external/androidtools/Mono.AndroidTools/AndroidDevice.cs:686 at System.Threading.Tasks.ContinuationTaskFromResultTask1[TAntecedentResult].InnerInvoke () [0x00027] in /private/tmp/source-mono-mac-4.2.0->branch/bockbuild-mono-4.2.0-branch/profiles/mono-mac-xamarin/build-root/mono->4.2.1/external/referencesource/mscorlib/system/threading/Tasks/TaskContinuation.cs:159
at System.Threading.Tasks.Task.Execute () [0x00016] in /private/tmp/source-mono-mac-4.2.0-branch/bockbuild-mono-4.2.0-branch/profiles/mono>->mac-xamarin/build-root/mono-4.2.1/external/referencesource/mscorlib/system/threading/Tasks/Task.cs:2523

(I have attached the log file)

Emulator is working fine and I can export the generated .apk to the phone to install it without problems, but debugging directly to physical device is the best way for debugging,at least for me save me time.
I'm using MacOSX

Can anyone give a clue to solve this please.

Answers

  • JeffSiemensJeffSiemens USMember ✭✭
    edited November 2015

    Please delete this post. Replied to the wrong thread.

Sign In or Register to comment.