Any workaround for slow constantly failing android device deployments?

GeorgeCookGeorgeCook PEUniversity ✭✭✭

It's got incredible - I can only build develop builds with fastbuild enabled (or it simply get's hung on detecting installed packages).

Now I have to unplug/replug my device every 2nd or 3rd build, then clean and rebuild just to get it to build.
If it behaves moderately well, then it insists on installing the shared runtime every single time.

Build cycles take anywhere from 3-5 minutes now, due to not being sure if it will give up half way through for no reason whatsoever or removing shared runtime, reinstalling it.

I see this behaviour in 5.8, 5.9 and 10. I find that 10 is the worst and more often than not simply refuses to deploy.

Anyone else seen these weoful

Tagged:

Answers

  • I rolled back to 3.11.1585.0 because I couldn't deploy, it just hangs. I tried some of the workarounds but nothing fixed it.

  • GeorgeCookGeorgeCook PEUniversity ✭✭✭

    Ok, good and disappointing to know, if you know what I mean.

    I won't accept the answer just yet in case someone else has an improvement for us.

  • ashalvaashalva GEMember ✭✭✭

    Hi @GeorgeCook ,

    I think it depends on the device. I had the same problem on GT 19082. The same project built time on GT 19082 was 3-5 minutes, while on Nexus 5 it was huge difference, maximum 1 minute.

  • GeorgeCookGeorgeCook PEUniversity ✭✭✭

    Yes. But this happens for me on everything. All devices. All emulators and it never used to be like this, so i don't think that's the cause.

    Also @DerekBeattie.6675 had the same issue and resolved it by downgrading. I'm not saying devices don't exasperate the issue; but I'm not buying it's an inevitable consequence. It's certainly a bug somewhere and it needs addressing. I'm just hoping someone else has a workaround as xamarin will likely drag their heels to fix it, especially if it's not effecting not everyone.

  • ThomasUThomasU USMember ✭✭

    I've got the same Problem with a GT 9300 will try later with some other devices but it's a really annoying bug.

  • In my case the build never finished. When I cancel the build, output would say to see exception log, I couldn't track down the error with detailed logging on.

  • Initially removing the .vs folder fixed it, then it wouldn't build because of locked files, I added the workaround in the Xamarin target to warn and continue, after that, it goes to la la land when building.

  • GeorgeCookGeorgeCook PEUniversity ✭✭✭

    my issues are on Xamarin Studio; so not sure if that helps; but useful for others.

Sign In or Register to comment.