Forum Xamarin.Forms

Deployment failed. Architecture not supported.


I am getting the below error while deploying..

The package does not support the device architecture (x86). You can change the supported architectures in the Android Build section of the Project Options.

Deployment failed. Architecture not supported.

Best Answer


  • PaulDistonPaulDiston USUniversity ✭✭✭✭

    Have you changed the supported architecture as the error message suggests? If so, did this solve your deployment issue?

  • MayankBhuvneshMayankBhuvnesh USMember

    I have tried changing the traget Android Version. But no luck.

    If any thing else required please suggest

  • JeevaNadarajahJeevaNadarajah USMember

    Thank you. This was useful.

  • PhilPhanPhilPhan USUniversity

    Thank you this solved my issue!

  • MuraliRajuMuraliRaju USMember

    Many thanks

  • ShantimohanElchuriShantimohanElchuri USMember ✭✭✭✭✭

    It seems this issue keeps appearing infrequently after updating various modules. The update screenshot of @ClarkCole was helpful, though it is now a bit outdate with more checkboxes in it.

  • Oh my God! Thank you! It took me months to work it!

  • That's great, I too have the same problem.
    1. Just changed Android Build -> Advanced tab -> armeabi-v7a and x86.
    It working fine for me.

  • @FlorianZimmermann.7188 said:
    Just in Case anyone got the same problem.
    You've to open the Options of the Droid Project.
    Then go to Android Options -> Advanced and mark x86 while having 'Release' selected as Configuration.

    Very useful, thanks a lot!!!!

  • JamesMontemagnoJamesMontemagno USForum Administrator, Xamarin Team, Developer Group Leader Xamurai
  • WilliamRaifordWilliamRaiford USMember ✭✭

    Thanks @JayakumarVnayagam, that got me going with Visual Studio's Android Emulator.

    @JamesMontemagno Wow I remember reading that a year or two ago and just not getting it. Now it makes perfect sense and addresses this problem. Sweet.

  • RameshYadavRameshYadav USMember

    Guys i'm getting the same error in windows xamarin...........but in my xamarin 5 i dont have that android X86 options and all

  • NeseekNeseek INMember

    Thanks @ClarkCole....
    A salute with gratitude...

  • Thanks - VS2015 -> project properties for my app -> Android Options -> Config=Release -> and then ticked all options, including "X86".

    And somehow, it now deploys to my Samsung Galaxy 5, no issue.......

  • Aahhhhh - I was deploying it to GenyMotion - which makes sense now why I needed the X86 option ticked.....

    Actually when I deploy to my own Samsung device, I don't need X86......

  • Thank you Clarkcole. This was useful.

  • ChristopherDrososChristopherDrosos GRMember ✭✭
    edited December 2016

    it doesnt work for me,i have select all the arhitectures on both debhg and release but i canf deploy to genumotion
    in packaging on release everything is unchecked,i cant deploy either as debug ir release

  • stevenseungstevenseung USMember ✭✭

    thanks for the fix, had a heart attack after all my apps failed to deploy

  • AditkothariAditkothari USMember ✭✭

    @FlorianZimmermann.7188 said:
    Just in Case anyone got the same problem.
    You've to open the Options of the Droid Project.
    Then go to Android Options -> Advanced and mark x86 while having 'Release' selected as Configuration.

    Very Useful Thank you..

  • DavidChandiaDavidChandia USMember

    Muchas gracias!!

  • DebendraDebendra Member ✭✭

    This issue is because of wrong architecture selection in Android option.
    To select the corect archicture Please select the following options.
    1. Right Click on Your Android Project.
    2. Go to Properties
    3. Select Android Option
    4. Scroll down to see the Advance this Advance Option.
    5. A popup will open with the supported acchicture.
    6. Mostly X86 archicture will work,but you can try with other archicture also.

  • abdalrhmanabdalrhman Member ✭✭

    You Can look in the ToolBar items and Change the Realese To Debuge

  • MazzAnt0n10MazzAnt0n10 Member ✭✭

    thank you

  • akhilgeorge303akhilgeorge303 Member ✭✭

    Thank you.

  • rafi924rafi924 Member

    Just change your build option from debug to release , normally happens when u want to test with emulator

  • All I did is changing the "solution configuration" from "Release" to "Debug"
    TA-DA, it worked!!! - the project deployed successfully and reflected in the Emulator.

Sign In or Register to comment.