Forum Xamarin.Forms

Announcement:

The Xamarin Forums have officially moved to the new Microsoft Q&A experience. Microsoft Q&A is the home for technical questions and answers at across all products at Microsoft now including Xamarin!

To create new threads and ask questions head over to Microsoft Q&A for .NET and get involved today.

Missing Services : Exit with error code 1

Working with Google Cloud Messaging in Xamarin.Forms Android app with VS 2012 exits by return error code 1

     GoogleApiAvailability.Instance.IsGooglePlayServicesAvailable(this)

Codes work successfully and getting output when debug in device.

Any suggestions ?

Weather I miss anything ?

Best Answer

  • YkshLeoYkshLeo USMember ✭✭✭✭
    Accepted Answer

    Just make a try :smile:

    • Check your emulator for Google Play Services, If there is no Google Play Services in emulator install and update it.
    • Install Google Play Services in Android SDK Manager.
    • Check all NuGets are installed properly or not.

Answers

  • YkshLeoYkshLeo USMember ✭✭✭✭
    Accepted Answer

    Just make a try :smile:

    • Check your emulator for Google Play Services, If there is no Google Play Services in emulator install and update it.
    • Install Google Play Services in Android SDK Manager.
    • Check all NuGets are installed properly or not.
  • HitmanHitman INMember
    edited October 2015

    Thanks @Yksh.Leo, I have no Google Play Services in my Emulator. That make this error.

Sign In or Register to comment.