1456 Errors in Xamarin.Forms Android Project After updating nuget

KestonCrandallKestonCrandall ✭✭USMember ✭✭

image

My project was working beautifully before updating the Xamarin.Forms nugets both on iOS and Android. I've posted in another threat that seems to be having problems with iOS. I've tried the beta and alpha channels to see if they had some sort of fixes, but they didn't. I literally can't build for any platform. This sort of thing usually happens when things break from updating, but usually only take 30-60 minutes to fix. I literally can't figure out any of this. I also installed API 23 and set that as target but that didn't help either.

Posts

  • GuiWaltrickeGuiWaltricke ✭✭ BRMember ✭✭
    edited October 2015

    Thats simple to solve, Open your Android SDK Manager and update all tools and plugins to the latest release.

    Good luck

  • KestonCrandallKestonCrandall ✭✭ USMember ✭✭

    image

    I updated those when I installed API 23.

  • KestonCrandallKestonCrandall ✭✭ USMember ✭✭

    image
    I was able to reduce it to 4 errors by cleaning.

  • ChaseFlorellChaseFlorell mod CAInsider, University mod
    edited October 2015

    Try this... in your Manifest

    <uses-sdk android:minSdkVersion="15" />
    

    This will use API 15 as min, and 23 as compile target.

  • KestonCrandallKestonCrandall ✭✭ USMember ✭✭

    I've tried a bunch of variations in min and target versions. Min 15/target 22 && min 15/target 23 both gave the same 4 errors.

  • ChaseFlorellChaseFlorell mod CAInsider, University mod

    Strange... and you tried to clean the solution, delete the app from the device, and re-deploy fresh?

  • KestonCrandallKestonCrandall ✭✭ USMember ✭✭

    I've cleaned it. It doesn't even get to the point where it launches the android player. It won't even start to build, fails in like < 5 seconds.

  • BobbyGalliBobbyGalli USMember

    Keaton, I'm having a similar error. Were you able to get this issue resolved?

  • AdamPAdamP ✭✭✭✭✭ AUUniversity ✭✭✭✭✭

    @KestonCrandall - Good ol' Resource.Designer.cs issues.

    Delete everything in that file, its auto-generated anyway but not the file itself, just the code inside the file.

    Then rebuild and it should resolve your issue. If not try that again, then do an Update-Package -reinstall on the project, then rebuild and see how you go.

    This is a very common issue where that file is just not regenerated when the Android Support packages are updated.

Sign In or Register to comment.