Google Play Services 22, add packages

Hello,

I'm starting using Xamarin, and testing admob, but for now i can't do nothing.

Using windows 7, Xamarin Studio 5.7 free

I add in component manager, and give me this alert: "Some required packages era not referenced by the project", them suggest Add Packages, and them give me this result in package console:
"Adding Xamarin.GooglePlayServices...
Attempting to resolve dependency 'Xamarin.Android.Support.v4 (≥ 21.0.3.0)'.
Attempting to resolve dependency 'Xamarin.Android.Support.v7.MediaRouter (≥ 21.0.3.0)'.
Attempting to resolve dependency 'Xamarin.Android.Support.v7.AppCompat (≥ 21.0.3.0)'.
Adding 'Xamarin.GooglePlayServices 22.0.0.0' to PlimPlim.
Could not install package 'Xamarin.GooglePlayServices 22.0.0.0'. You are trying to install this package into a project that targets 'MonoAndroid,Version=v4.0.3', but the package does not contain any assembly references or content files that are compatible with that framework. For more information, contact the package author."

------ I find a possible solution, that is import dll into references throw .Net Assembly, but required me to use trial version or pay.

Thanks

Posts

  • IvoProjectsIvoProjects PTMember

    ----- SOLVED ----
    Change target framework for 4.1, and this package will be avaiable.

  • MichaelBrewsterMichaelBrewster USMember
    edited February 2015

    I have to sacrifice 15% of Android users to use Xamarin.GooglePlayServices 22?
    The entry in the components store states, "This component is only for Xamarin.Android applications that target Android 4.0 (API level 14) and higher."

    Raising the version support from 4.0+ to 4.1+ doubles the number of devices that are incompatible with your app.

    Are there any other solutions to this problem?

  • ToGo.7579ToGo.7579 USUniversity

    I am also having this issue, I need google play services to run on 4.0.1. The component does say its compatible. Does anybody have a good workaround for this?

    Thanks!

  • I'm hitting this problem too. Any solution found yet?

  • BenjaminPageBenjaminPage AUMember

    I have this problem as well. Anyone??

  • Same here! +1

    Would love to know why the last ICS version is 19.0.0

  • MarcusGabilheriMarcusGabilheri USMember

    +1... I need to add play services to my project but we need to support 4.0.1. If I bump the version to 4.1 we loose around 20% of our customers...

  • ErhanAlankusErhanAlankus TRMember

    I need this too.

Sign In or Register to comment.