Detecting Android Devices

MartHughMartHugh USMember ✭✭✭

I am running Xamarin trial on Windows 7.

I have an Android device (GT-I8190N, Galaxy 3Mini) plugged into the USB.
It appears to have a recognised and named device driver assigned in Windows Device Manager.
The device has "USB Debugging" enabled in the developer options.

However when I select, from the IDE, "Run/Upload To Device" I have a dialogue presented which contains only emulators.

How can I upload to a hardware device ?

Thanks.

Tagged:

Posts

  • CortezCortez USMember ✭✭✭

    Hello @MartHugh!

    Does your phone's API and the Xamarin Studio setted API level meet eatchother?

  • MartHughMartHugh USMember ✭✭✭
    edited April 2015

    Great question @Cortez

    My Phone/Device claims Android 4.1.2
    How do I check/set the IDE version ?

  • MartHughMartHugh USMember ✭✭✭
    edited April 2015

    OK found SDK info in Android SDK Manager. Only 5.11 is installed. I had hoped it would be backwards compatible. Do I need to install 4.1.2 packages in order to be compatible with 4.12 devices ?

  • CortezCortez USMember ✭✭✭

    I think so. I installed only my phone api level (4.3). Every time i start a new solution first i change the API level in the xamarin studio because it try to use the newest.

  • MartHughMartHugh USMember ✭✭✭

    I have installed 4.12 as well now. But no change. I cannot see a way to tell the IDE which version to target.

  • CortezCortez USMember ✭✭✭

    Right click on the project, Options, Builder / General, Target framework.

  • MartHughMartHugh USMember ✭✭✭

    Thanks a lot for that. That makes sense. No sign of my device anywhere though.

  • SantiagoCabreraSantiagoCabrera ARMember ✭✭

    You should update your usb drivers probably, I'm not sure if samsung gives their own drivers for debugging or with the ones provided by google should work.

    • Try first updating/downloading google usb drivers from the SDK Manager
    • If this won't work google usb drivers for s3 mini, they should appear.

    If the device does not appear it's drivers deal, windows often screw things up when you install debug drivers of different devices, so take that into account (try uninstalling old drivers and reinstalling the new one)

    Hope it helps a bit.

    Maqui.

  • MartHughMartHugh USMember ✭✭✭

    Thank you. I will try that. The driver with same name as the device appears in Windows Device Manager so it seems to have the right one, but I dont know. It also thinks it is a USB drive because when I plug it in to the USB Windows prompts me asking what I want to do with the files. I wondered if this was related to the device not appearing in the IDE problem.

  • MartHughMartHugh USMember ✭✭✭

    I think this was a driver issue. I didnt not manage to sort it out, but have just setup Xamarin Studio on a Mac and the Android Phone is detected and deployment works out of the box.

    However, I am not having the same luck with deploying from the Mac to an iPad. Is deploying to Apple devices from the Mac Xamarin Studio supported ?

    Thanks again.

  • RameshchRameshch USMember

    How to detect the android device location(country name,country code,state name,nearest address location)...................Please let me help

    Thank you............

  • CheesebaronCheesebaron DKInsider, University mod

    @Rameshch not related to this question. Create your own new question instead.

Sign In or Register to comment.