Forum Xamarin.Android

Android: XA5101: Platform library directory for target Arm and API Level 23 was not found

SoerntPoppeSoerntPoppe DEUniversity ✭✭

Hi there,

while compiling my app in release mode I get that error message:

Xamarin.Android.XamarinAndroidException: error XA5101: Platform library directory for target Arm and API Level 23 was not found. Expected path is "C:\Users\XXX\Documents\Android\ndk\android-ndk-r10d\platforms\android-23\arch-arm\usr\lib".

I am unsure what I need to install via the Android SDK-Manger?

These are the project properties within VS:

Application:
image

Android Options:
Packaging:
image

Linker:
image

Advanced:
image

Android SDK-Manager:
image
image

Content of the folder at my PC:
image

Can someone help me here please?

Posts

  • adamkempadamkemp USInsider, Developer Group Leader mod

    This is an Android question so I moved it to the Android forum.

  • VitorMotaVitorMota PTMember

    Same here...

    I can build in Release mode but can't publish (Visual Studio).

  • so, is there a solution to this?

  • hvaughanhvaughan USMember ✭✭✭

    Having the same problem. Tried downgrading the SDK Platform-tools to version 23.0.0 but it did not make a difference. Really hope this gets fixed soon.

  • hvaughanhvaughan USMember ✭✭✭
    edited September 2015

    @SoerntPoppe @VitorMota @NinoPadrutt.7544
    I created a bug report for this issue. Please comment on it if anyone has any more info about the issue:
    https://bugzilla.xamarin.com/show_bug.cgi?id=33860

    *Edit: Just realized that turning off the LLVM compiler allows me to archive my project successfully. Will go update the bug report now.

  • MatheusGuimaraesMatheusGuimaraes GBMember, University ✭✭

    Spot on hvaughan! Turning off the LLVM compiler does indeed allow you to publish it so that's where the bug is. life saving! thanks for the tip and reporting the bug!

  • JGoldbergerJGoldberger USMember, Forum Administrator, Xamarin Team, University Xamurai

    I was able to reproduce this issue with a template Android project on the Stable versions of Xamarin for Visual Studio and Xamarin.Android on the Mac. (Got different errors with the Alpha/Beta versions)

    However this bug seems to be partially resolved with the Preview version of Xamarin Android for Android M. It resolved the issue when using in Xamarin Studio on the Mac. I did however still get the issue on Xamarin Studio on Windows/Visual Studio.

    This preview version is not available in either the Stable, Beta, or Alpha channels at this time. See these release posts for info on how to install this preview:

    https://releases.xamarin.com/preview-android-m-support-3rd-preview/
    https://developer.xamarin.com/guides/android/platform_features/introduction-to-m/
    https://forums.xamarin.com/discussion/43928/xamarin-android-preview-for-android-5-1-and-android-m?new=1

    I added this info to the bug report as well.

  • hvaughanhvaughan USMember ✭✭✭
    edited September 2015

    @JonGoldberger.0771

    Thanks for the help on this. The bug was marked as a resolved duplicate but I am not able to view the bug that they cited as the original bug. Do you know what the status of this is? Is it actually fixed? I appreciate the help.

  • JGoldbergerJGoldberger USMember, Forum Administrator, Xamarin Team, University Xamurai

    @hvaughan,

    (Changed my username... JGoldberger is what it has been, but all of a sudden it had the .0771. I have no idea why. But I digress...)

    The original bug is marked as fixed. And it looks like we pushed Xamarin.Android 6.0.0 to the Alpha channel on Windows, so this issue should be fixed if you switch to the Alpha update channel for Xamarin in either Xamarin Studio (windows) or Visual Studio.

  • hvaughanhvaughan USMember ✭✭✭

    @JGoldberger
    Thanks for the update!

  • I'm running the latest stable on Mac which has Android 6, but I'm still running into this error. Any update on when this will hit stable?

    The workaround I've tried is to create a softlink for the missing android-ndk-r10e/platforms/android-23 that points to android-21. So far that seems to take care of the issue without having to turn off LLVM.

  • hvaughanhvaughan USMember ✭✭✭

    @DavidJohnson.9477
    What exactly were the symlink commands that you used? I tried doing the following but still got the same error message:

    • Created /android-23/
    • Ran in terminal: ln -s ./android-21/ ./android-23/
  • That's curious. I used the full path when creating the symlink; maybe that made a difference:

    ln -s /Users/davidj/Library/Developer/Xamarin/android-ndk/android-ndk-r10e/platforms/android-21 /Users/davidj/Library/Developer/Xamarin/android-ndk/android-ndk-r10e/platforms/android-23
    
  • hvaughanhvaughan USMember ✭✭✭

    @DavidJohnson.9477
    It worked! Thanks a lot. Very helpful.

  • batmacibatmaci DEMember ✭✭✭✭✭

    I am having this error when I use "bundle assemblies into native code". my error message is
    "System.InvalidOperationException: Platform header files for target Arm and API Level 4 was not found. Expected path is "C:\ProgramData\Microsoft\AndroidNDK64\android-ndk-r13b\platforms\android-4\arch-arm\usr\include""

    I dont get why it complains about API level 4. I support min Api Level 21 in my android project

    <uses-sdk android:minSdkVersion="21" />
    

    anyone has any idea please or should I report a bug?

  • batmacibatmaci DEMember ✭✭✭✭✭

    wow, I am so angry now. I spent 2 days of trying figure out this error and it turned out xamarin bug. how can such serious feature can be hardcoded? https://bugzilla.xamarin.com/show_bug.cgi?id=48678

    It is sold with high cost enterprise product VS/XS. This cant be serious.

Sign In or Register to comment.