iOS 9.0, Xamarin Studio, "waiting for debugger to connect..." Please help

Like others, with the iOS 9.0 update, my Xamarin Studio will no longer connect to the iOS simulator. The most successful advice I've found in other threads is to switch to the beta version of Studio and Xamarin.iOS. I've done this. Now running Studio 5.9.7 (build 12) and Xamarin.iOS 9.0.1.29, along with Xcode 7.0.1 (7A1001)... and I'm still experiencing the same issue. Switching to beta did enable me to deploy to my device, but Studio still doesn't find the simulator.

I need Studio to find the simulator. If there are other options I've missed while researching the solution for this, I would greatly appreciate anyone pointing me in the right direction.

Posts

  • hobeauhobeau USMember

    Hi ChuckHedley,

    Make sure that you have updated XCode and also make sure to open up XCode as it will ask you to accept an agreement (and Xamarin Studio won't work until you do this).

  • Hi @hobeau

    Thank you for the reply. I have Xcode 7.0.1. After updating to 7.0.1 a couple days ago, it didn't fix my issue. It was only yesterday that I opened Xcode, saw the prompt to accept the agreement and accepted it. Doing that, I was sure Xamarin Studio would then work for me. Unfortunately, it made no difference. For more clarification... in Xamarin Studio, with "Debug" and "iPhone 6 iOS 9.0" selected, I press play to start debugging. It launches the simulator, the simulator opens and initializes to its home screen. When it launches the simulator, Xamarin Studio says "Waiting for debugger to connect...", and then continues to say that beyond the simulator boot, and until it simply stops waiting and stops the debug session. After switching to the beta version of Studio and Xamarin.iOS, Xcode (and accepting the agreement), multiple reboots of Studio, and multiple reboots of my Mac later... all to no avail.

    I hate to be that guy, but is there anything else you know of that I can try? I'm desperate to get this world put back together as I'm falling behind on a pressing deadline. Any other help you can offer will be greatly appreciated.

    Thank you.

  • hobeauhobeau USMember

    No worries, I think we're all 'that guy' ;). I know that there is an update on the beta channel that was just released today. Go to Xamarin -> Check For Updates -> Beta Channel. For more details of the fixes check out this article. Looks like that might help. Also you might want to try going to Project Options -> iOS Application -> Deployment Target and select 8 just to see if that helps.

  • @hobeau, my beta channel is up to date. I tried changing my target to 8. Nothing is making any difference. You're being beyond helpful, and I thank you for that. This is beyond frustrating. It seems people were complaining about this, and then the complaints went away, presumably by switching to the beta channel. But that has made no difference for me. I wonder what else I'm missing that others aren't.

  • hobeauhobeau USMember

    Hmm, I think I might start getting more fundamental if I were you. Try creating a new iOS application from scratch and just see if that runs. If not uninstall-reinstall Xamarin Studio. As crappy as that would be, it might work?

  • @hobeau, I continue to increase my debt to you for helping so much. I followed your advice and I've made progress. The progress is that... I created a new iOS application and... it runs. Quickly, and without issue. So it seems I don't need a reinstall of Studio. But now I'm stuck not knowing... how I can identify the difference between my project that won't find the debugger, and the test project that finds it without issue? I can only guess that the difference is in some file I don't look at regularly, or have maybe never looked at... or buried deep in one of the project properties pages. But I'm really not sure where to begin.

  • ChuckHedleyChuckHedley USMember

    @hobeau, I'm calling off the hounds. It's working now. I wish I knew why. I followed my train of thought following your advice and started comparing the configurations of each project side-by-side. The only difference that I found between the two was that Project Options -> iOS Build -> Enable Profiling was checked on the working project, but not my non-working project. I don't think I made any other changes (and I don't really know what Enable Profiling means.) Still feeling like I made no difference, I randomly tried to run it at some point, and... voila... finally. Just to be sure, I then shut down both copies of Studio, shut down my Mac, fired it back up, launched one copy of Studio, loaded my project, ran the debugger, and... it worked again.

    So... I really have no idea how, but it seems the world is whole again. THANK YOU very much for all of your efforts to help me. I'm not sure I would've thought to try a new project without your advice. It was golden.

Sign In or Register to comment.