MT1211: The simulator version {*} does not support the simulator type {*}

Ever since we updated to the latest release in the stable channel (and updated to Xcode 7), we’re facing a problem on our CI server where a build script is executing the command:

mtouch —launchsim {path to the *.app file}

The error we are receiving is:

error MT1211: The simulator version '2.0' does not support the simulator type 'iPhone 4s'

Not sure where this error is coming from, as this exact command as part of the build script used to work prior to the update. Running the app manually via Xamarin Studio continues to work after the update.

Anybody have any ideas as to why this is happening now? We're running this on a Mac Pro with the following configuration:

Xamarin Studio 5.9.7
Xamarin.iOS 9.0.1.20
Xcode 7.0.1
Mac OS X 10.10.5

Tagged:

Posts

Sign In or Register to comment.