Remove Xamarin from Visual Studio 2013

Everytime I start up Visual Studio 2013, something is going for about 3 minutes before I am able to work with it.
This is due to Xamarin. When I un-install Xamarin, the delay is gone.

I am now searching for a way to remove Xamarin from VS2013 without un-install Xamarin Studio.

Xamarin is not registered as an add-in to VS2013, so I don't know how to remove it.

I am only working with Xamarin Studio, so having it in VS2013 is not important to me.

Thank you for the help!


  • VictorGarciaAprea.9996VictorGarciaAprea.9996 USXamarin Team Xamurai

    Mmm... is very weird that you are getting such a delay. Most of Xamarin doesn't load at VS startup but just when you open an iOS or Android project, so it is weird such a delay may be caused by Xamarin bits.

    If you want to uninstall Xamarin from VS2013, you can go to Windows "Programs and Features", select "Xamarin" and then "Change". The Xamarin setup will pop up and you should uncheck the "Xamarin for Visual Studio 2013" option, that will remove Xamarin from VS 2013.

    Please let me know if the delay goes away after removing Xamarin for VS 2013, so we make sure it was the one causing the delay.


  • HermieWeberHermieWeber NLMember
    edited May 2015

    Thanks. I did as you suggested, and now VS2013 loads quickly again.

  • HermieWeberHermieWeber NLMember
    edited May 2015

    After an update of Xamarin Studio, the problem occurs again, but I think this is only natural.

  • Hi,
    Thanks for your input. I deleted Xamarin from VS 2013.

  • BjarkeSogaardBjarkeSogaard USMember ✭✭

    As a fellow developer I'm sure we're all interested in knowing the specs of your (@HermieWeber & @N.Y.Gudlanur) PCs. At least that will help the Xamarin developers to determine the problem.

Sign In or Register to comment.