Forum Xamarin.Android

Deployment failed because of an internal error: Failure [INSTALL_FAILED_UPDATE_INCOMPATIBLE]

Has anyone any ideas on this - i can build but not debug - simply refuses to deplaoy with above error
I have tried to build totally new app then add bits of this app one by one
Even with all the support files and classes in and all references (but the Oncreate method is left to be just a simple button as per demo) this works So it does not seem to be a conflict with any reference
I mean what update is incompatible with what ? I am completely stumped



  • ChrisHardyChrisHardy GBForum Administrator, Xamarin Team Xamurai

    There's more information on this issue on our troubleshooting page here: hopefully this will give you some more information to resolve the problem.

  • GerryHighGerryHigh USBeta ✭✭✭

    FWIW I'm now getting this error on the alpha branch on OSX Mavericks. Same source/phone compiles/deploys fine from Xamarin Studio alpha on Windows 8.

  • GerryHighGerryHigh USBeta ✭✭✭

    I was able to get it to install (as explained here

  • DavidReynoldsDavidReynolds USMember

    I also got this same error but had a different reason. My package name was empty. According to Xamarin docs I should have gotten a different error but I got this one. To fix in Visual Studio 2012 (will be slightly different for other IDE's) right click on your Android project and select Properties. Select the Android Manifest tab and ensure you have a package name with a '.' in it. The dot is important or it will not work.

  • BenBishopBenBishop USBeta ✭✭

    To add to the knowledge base of this issue, I ran into a similar issue where I had a version installed from TestFlight. When I would do a build on my iMac from XS directly to the device, I'd get an error saying the install was incompatible. Reinstalling from TestFlight, and then uninstalling it, and then installing from XS worked.

    With that said, I also ran into an issue where I had a build on my device that was generated by my iMac. When I tried to install a new build from my Macbook Pro via XS, I got the same incompatible install issue. I had to go back to my iMac, reinstall the app, uninstall it, and then try installing from my MBP.

    Long story short, whenever switching machines or delivery mechanisms, always manually uninstall the previous version!

  • ZacharyCardozaZacharyCardoza USMember

    Same issue for me. I uninstalled app, but some "ghost" files remained. Solution was to build APK and install from SD/Memory and then uninstall.

  • ianmercerianmercer USMember ✭✭

    For me it appears that a missing Application Icon was the cause of this error message, or at least it went away when I added one.

  • SagarPanwalaSagarPanwala USMember ✭✭✭

    @EugeneBosikov‌ ,It's work.

  • ckranjckranj INMember ✭✭

    @EugeneBosikov thanks a lot. It is working

  • mr-incrediblemr-incredible USMember

    Burned yet another hour on this bug this morning. Thanks @VincentPoirier. that turned out to be my issue as well. Ugh.

  • davidbarrettdavidbarrett USUniversity ✭✭
    edited June 2015

    While an uninstall of an existing package seems to always work here, my issue is that the app was nowhere to be found, even in Settings | Apps. I had to do a manual ./adb uninstall "packagename".

    Thanks to @GerryHigh for the tip.

  • satya.7655satya.7655 USMember

    i did not understand why ti is coming ............i have tried some of your solution still error showing i want an effecting solution can any give me?

  • satya.7655satya.7655 USMember

    my error is like:
    C:\Program Files (x86)\MSBuild\Xamarin\Android\Xamarin.Android.Common.targets(3,3): Warning MSB3247: Found conflicts between different versions of the same dependent assembly. In Visual Studio, double-click this warning (or select it and press Enter) to fix the conflicts; otherwise, add the following binding redirects to the "runtime" node in the application configuration file: (MSB3247) (PasswordlessLogin.Droid)

  • AshayMoreyAshayMorey USMember
    look solution of tomopgernoth
    this might help you guys .

  • MateuszKierepkaMateuszKierepka PLDeveloper Group Leader

    I had this same problem - manual unsintall APK helped.

  • DevaPalanisamyDevaPalanisamy GBUniversity ✭✭

    command line uninstallation worked for me.

  • v3yr0nv3yr0n USUniversity ✭✭

    yeah @DevaPalanisamy, it works for me too.

    adb uninstall

  • AnthonyTerraAnthonyTerra USMember, University

    Yeah the issue I had was the same as Nkechi. I deployed an application via an APK it didn't work, then I tried to debug from Xamarin. EPIC FAIL. I reinstalled the APK Manually uninstalled the app, debugged again all is right with the world.

    Thanks all

  • MHLDMHLD BRBeta ✭✭

    @bosikov said:
    You have a the same application installed from Google store or from package that was prepared for deploy. Go to Settings->Apps select your application and uninstall. It will fix all your problems.
    After that you will able to run and debug your application from IDE.

    Thank you!!!

  • PietroGaioPietroGaio USMember
  • BhaurajBiradarBhaurajBiradar USUniversity ✭✭

    OOPS I received this issue again. this time no luck from above posts. I am trying to instal app through Xamarin studio to Android Tab from my Mac ProBook. I received below error

    Deployment failed because of an internal error: Failure [INSTALL_FAILED_UPDATE_INCOMPATIBLE],

  • BhaurajBiradarBhaurajBiradar USUniversity ✭✭

    Below is the error
    Detecting installed packages

    Waiting for packaging to complete

    Installing application on device

    Deployment failed because of an internal error: Failure [INSTALL_FAILED_UPDATE_INCOMPATIBLE]

    Deployment failed. Internal error.

  • KorayemKorayem EGMember ✭✭

    I am alternating dev between two PCs. The problem occured because I installed the apk from one machine and attempted to deploy from another without uninstalling it.

    So before you switch machines, make sure you uninstall the app first.

  • Dayakumar.3395Dayakumar.3395 INMember ✭✭

    I have same issue because one file was available with same name with 0 kb size.
    First search APK name in your device and remove properly. it should work properly.

  • CuckooshkaCuckooshka USMember ✭✭

    Settings -> Apps, uninstall Mono Shared Runtime (it will be installed automatically with the next deploy).
    Helped in my case.

  • shanshanshanshan SEMember

    @BenBishop 's answer saved me!!! thanks!!! :)

  • Great!!! Worked for me!!!! Thank you!

    @JakubHolovsky said:
    Happened to me today and left me confused. The thing is that I:

    1) Installed APK of my App from different source.

    2) Then I wanted to install it from Xamarin Studio.

    3) Previous App got uninstalled but new build did not get installed and left me with error:

    Deployment failed because of an internal error: Failure [INSTALL_FAILED_UPDATE_INCOMPATIBLE]


    1) Install on your device the previous APK again.

    2) Properly uninstall it from your device.

    3) Try to install the new build through Xamarin Studio.

    It should work now :)

  • if anyone is still having this problem, i suggest uninstalling the app on the device and also uninstalling mono shared runtime then build app and it should work perfect.

  • DFoulkDFoulk USMember ✭✭✭

    I had this same error... Just had to add a 'Version number' and 'Version name' in my Android Manifest (MyProject.Android > Properties > Android Manifest)

  • 1xo21xo2 NZMember ✭✭✭

    thank you @EugeneBosikov‌

Sign In or Register to comment.