XamarinStudio-4.0 won't load

I installed XamarinStudio, everything was working well. Now tried to load it today and it just fails silently. I looked in "Local\XamarinStudio-4.0\Logs"

FATAL ERROR [2013-05-20 08:55:20Z]: Xamarin Studio failed to start. Some of the assemblies required to run Xamarin Studio (for example gtk-sharp)may not be properly installed in the GAC.
System.DllNotFoundException: Unable to load DLL 'libgtk-win32-2.0-0.dll': The specified procedure could not be found. (Exception from HRESULT: 0x8007007F)
at Gtk.Rc.gtk_rc_get_module_dir()
at Gtk.Rc.get_ModuleDir()
at MonoDevelop.Ide.IdeStartup.SetupTheme()
at MonoDevelop.Ide.IdeStartup.Run(MonoDevelopOptions options)
at MonoDevelop.Ide.IdeStartup.Main(String[] args)

Another post suggested "C:\Program Files (x86)\GtkSharp\2.12\bin" may not be on the path and to test this by running gtk-query-immodules-2.0.exe. It seems that "C:\Program Files (x86)\GtkSharp\2.12\bin" is on the path as it launches, but then crashes with the error "The procedure entry point cairo_show_text_glyphs couldn not be loaded in the dynamic link library C:\Program Files (x86)\GtkSharp\2.12\bin\libpangocairo-1.0-0.dll".

I'm running Windows 8 x64.

After I installed XamarinStudio I also installed pinta. This also doesn't work. Could pinta have broken my GtkSharp install? I was thinking or uninstalling both then re-installing, but would like to avoid this if possible.

Thanks,
Rob

Posts

  • mhutchmhutch USMember, Xamarin Team Xamurai

    Please try uninstalling all GTK# versions you have installed, and reinstalling GTK# 2.12.21.

  • RobertPickeringRobertPickering USMember

    I ended up uninstalled everything and re-installing and that fixed it.

Sign In or Register to comment.