Forum Xamarin.iOS

Announcement:

The Xamarin Forums have officially moved to the new Microsoft Q&A experience. Microsoft Q&A is the home for technical questions and answers at across all products at Microsoft now including Xamarin!

To create new threads and ask questions head over to Microsoft Q&A for .NET and get involved today.

Could not load the image referenced from a nib in the bundle with

LeighBowersLeighBowers GBMember
edited December 2012 in Xamarin.iOS

When testing in the simulator, my app performs perfectly. On the device, however, none of my images are loading. Looking at the console, I can see:

Could not load the "resource/images/branchfinder.png" image referenced from a nib in the bundle with identifier

All images have their build action set to "Content".

Any idea what's going on here? Why would a release build on the simulator contain the images, yet a release to the device doesn't?

Posts

  • LeighBowersLeighBowers GBMember

    The image files are definitely in the ipa, so it must bust be something like filename case sensitivity. Hmmm...

  • TheBearF8TheBearF8 USMember ✭✭

    How did you go about getting it to work in the simulator ?
    I'm getting the same error but in the simulator
    Thanks

  • Rushi.8941Rushi.8941 USMember
    edited July 2015

    Did you guys find a solution to this? I am getting this on simulator and I tried both ways, i.e. setting the image directly from Xcode and syncing changes in Xamarin studio and directly by setting the image programmatically from c#.

Sign In or Register to comment.