AOT/LLVM not available in custom csproj configurations

I have asked this question in the main forum, but haven't got an answer so I'm hoping reposting it here will bring me better luck.

I'm currently using 3 different release build configurations to target 3 different environments (beta/alpha/appstore) for my app. I'm looking at reducing the size of the app using AOT/LLVM/Proguard. However, when I go to the project properties these options are greyed out. I noticed they weren't greyed out on the default "Release"configuration, so I tried copying the csproj settings from "Release" to my custom configurations to see if I had any incompatible options that were disabling them, but it seems that only the default "Release" configuration can have these optimizations enabled.

Am I mistaken? Is there anyway to enable these optimizations on my custom release configs?

Thanks in advance

Posts

  • Adrian.StevensAdrian.Stevens USXamarin Team, University, XamUProfessors, Developer Group Leader Xamurai

    Hi Jeremy,

    Check the project under Build -> Android Build

    Do you have "Enable developer instrumentation" checked? (if so - uncheck it)

    I just tried I and I am able to create multiple configurations with ProGuard, OAT and LLVM enabled.

  • JeremyEllis.9126JeremyEllis.9126 USUniversity ✭✭

    Hi Adrian, thanks for getting back.

    I don't have Enable developer instrumentation checked.

    Interesting it works for you; what DevEnv are you using? I'm using VS2013, could it be a bug with that?

  • Adrian.StevensAdrian.Stevens USXamarin Team, University, XamUProfessors, Developer Group Leader Xamurai

    Hi Jeremy,

    Ah yes - I tried it originally in Xamarin Studio on a Mac. I just tried it in VS2015 and I'm not able to use ProGuard / AOT / LVVM on anything other than "Release".

    It looks like a bug or limitation in Visual Studio unfortunately.

  • JeremyEllis.9126JeremyEllis.9126 USUniversity ✭✭

    Hi Adrian, thanks for checking. Much appreciated.

    It looks like putting the AOT/LLVM/Proguard tags manually in the csproj works, but it doesn't show up in the UI; which was throwing me off.

    Just wondering if I should file a bug report.

    Thanks again.

Sign In or Register to comment.