Submit to Appstore - Invalid sdks value, LC_VERSION_MIN_IPHONEOS is greater than max allowed value

SubhaMuralidharanSubhaMuralidharan USMember ✭✭
edited July 2015 in Xamarin.iOS

Hi,

After upgrading Xamarin.iOS to 8.10.3 in my Xamarin.Forms project, I am unable to submit the app to Appstore. I am getting below error message when I try to submit the app.

Invalid sdk value. The value provided for the sdk portion of LC_VERSION_MIN_IPHONEOS in com_conceptworld_notezilla.app/com_conceptworld_notezilla is 9.0 which is greater than the maximum allowed value of 8.4

Environment Info:

=== Xamarin Studio ===

Version 5.9.4 (build 5)
Installation UUID: 79f8023d-fe65-4cee-9313-2d8dc8312106
Runtime:
    Mono 4.0.2 ((detached/c99aa0c)
    GTK+ 2.24.23 (Raleigh theme)

    Package version: 400020005

=== Apple Developer Tools ===

Xcode 6.0.1 (6528)
Build 6A317

=== Xamarin.iOS ===

Version: 8.10.3.2 (Indie Edition)
Hash: 8b265d6
Branch: master
Build date: 2015-06-30 15:19:13-0400

=== Xamarin.Android ===

Version: 4.18.0.34
Android SDK: Not found

=== Xamarin Android Player ===

Not Installed

=== Xamarin.Mac ===

Not Installed

=== Build Information ===

Release ID: 509040005
Git revision: 8010a90f6e246b32364e3fb46ef2c9d1be9c9a2b
Build date: 2015-06-08 16:52:06-04
Xamarin addins: 7e93e9c3503f28770f23ce1b7eafd829919f18e8

=== Operating System ===

Mac OS X 10.10.4
Darwin User-Mac-mini.local 14.4.0 Darwin Kernel Version 14.4.0
    Thu May 28 11:35:04 PDT 2015
    root:xnu-2782.30.5~1/RELEASE_X86_64 x86_64

I published using Xcode 6.0.1 and followed instructions given in this thread.

Please someone help me to fix this.

Tagged:

Answers

  • adamkempadamkemp USInsider, Developer Group Leader mod

    Make sure you don't have a minimum OS version set to 9.0. Something in your app, probably your Info.plist, seems to refer to 9.0.

  • SubhaMuralidharanSubhaMuralidharan USMember ✭✭
    edited July 2015

    Successfully submitted to Appstore. My minimum OS version in info.plist was set to 6.1 only, but SDK Options under iOS build in project options was set to Default. That was causing the problem. I changed it to 8.0, then uploaded to Appstore and everything went well :)

Sign In or Register to comment.