Unfortunately, *App Name* has stopped.

RWilliamsRWilliams USMember
edited October 2014 in Xamarin.Android

I need some help here, I can't deploy to an actual phone and have it load to save my life. I've built a simple Android App, as a matter of fact I dumbed it down to just a label with text, deploy to an .APK and tried to install on 3 different phones and versions of Android and it crashes every time. Build something similar in Android/eclipse works perfectly, had Xamarin for a couple of weeks now and haven't been able to deploy anything. All my hello world apps work perfectly in all the emulators just not a deployed .apk version, so not sure of I'm missing something or not but I'm frustrated now and need some help. I have VS 2012 11.61030 Update 4. Using Xamarin 3.6.253 with Xamarin Android 4.16.17, your response will be greatly appreciated. Thanks.

«1

Answers

  • ghutchisonghutchison USMember

    I am fairly new myself so prob not much help, but it could be the fast deployment option. Right-click on your project, not solution, and select properties. Select "Android Options" on the left and you should see the attached image. Try unchecking the "Use Fast Deployment (debug mode only)" option. It seems some phones don't like that at all. My test Nexus is ok, but the Samsung Galaxy S4 does not.

  • RWilliamsRWilliams USMember

    Thank you, however, that didn't work either.

  • markcarewmarkcarew AUMember

    Same here. After my android debugging went spastic. I decided to load up vs2015 ctp6 and can now see the VS Emulator Lollipop Phone in vs2013 but get the message "Unfortunately, ... .Droid has stopped. I seem to spend half my life at the moment coping with google nonsense like chrome never shutting down. I have unchecked Use Fast Deployment to no avail. Has anybody got the VS Emulator (from VS2015) working with VS2013 and can point me to an easy to follow instruction guide.

  • MaxSokolovMaxSokolov USMember

    Bump!

  • SplatoSplato USUniversity

    Android Player worked fine on my Win 7 Machine. Got a new Win 8.1 computer, re-installed everything as before and now can't deploy android apps. Get the same "Unfortunately, [app name] has stopped." message.

    VERY FRUSTRATING!

  • AriJohannessonAriJohannesson USUniversity ✭✭

    Same here - blank app project (Xamarin.Forms shared). Deploys to Xamarin Android Player but crashes immediately with message "Unfortunately, App Name has stopped.". Runs fine on both iOS and Win8 emulators.

  • AriJohannessonAriJohannesson USUniversity ✭✭

    Update: It works for Release builds but not for Debug. I have disabled Fast Deployment. Anybody solved this?

  • Jean-DanielGasserJean-DanielGasser CHMember ✭✭

    Hello
    Thanks to Ari Johannesson, the "Shared Runtime" uncheck did work for me.

  • bobwardwellbobwardwell USMember

    Ditto - And big thanks to Ari Johannesson. Disabling the shared runtime fixed me up too.

  • StevenReedStevenReed USMember ✭✭

    Yes, it works by unchecking the "Shared Runtime", but the file it created was 32MB whereas the other was around 4MB!

    So I had to get WinZip for my Android to get it emailed to me.

    Sure wish Xamarin would fix this!

  • VishnuPSVishnuPS USMember ✭✭

    Hi friends,
    I have developed an android application using xamarin form in xamarin studio and it was working fine in debugging mode with a physical device but when i tried to publish the app in ad-hoc it got published with out any error but the problem came when i tried to install the .apk file to the device which i was used test the application while debugging is not working it show the same error Unfortunately, App Name has stopped. i tried the solutions that you guys mentioned above like unchecking the Shared Shared Runtime but no change please help me to get out of this issue...

    Thanks in Advance..........

  • DhirajSharmaDhirajSharma USMember

    Same here -error Unfortunately, App Name has stopped.

  • VishnuPSVishnuPS USMember ✭✭

    Giving internet permission solved my problem.

  • eddyizmeddyizm USMember ✭✭

    VishnuPS suggestion about allowing internet permission finally worked! Very frustrating! Thanks!

  • same problem here , tried all written solutions but still not working

  • Yes, it works by unchecking the "Shared Runtime", but the file it created was 32MB whereas the other was around 4MB!

    So I had to get WinZip for my Android to get it emailed to me.

    Sure wish Xamarin would fix this!

    Same here

  • SunilBRajSunilBRaj USMember

    Hi , Thanks to Ari Johannesson i unchecked Shared Runtime and its running like charm.

  • PetertherPeterther USMember

    Hi,

    I had the same problem when I used the "WebView App (Android)" solution in VS2015, but when using the "Blank App (Android)" and added a WebView to this, all my code from my first App worked!.

  • I have a same problem... but i have soleved problem after unchecked Shared Runtime.

    But Before this my app size approx 9 MB

    After Unchecked shared Runtime app size : 60 MB.

    How to compress my android apps size ?

  • YeboGogoYeboGogo USMember

    I installed my app from the emulator, redeployed and it worked. With "Shared Runtime" and without the Java Heap setting. https://www.androidpit.com/how-to-fix-unfortunately-app-has-stopped

  • leninmathileninmathi USMember ✭✭

    I too have same problem... i'm running a default sample application in android, whenever i'm deploying it i am getting the error as "unfortunately app has stopped." I've tried by

    1) changing the VM heap value.
    2) checking & unchecking the shared runtime, but still same error.

  • TchelidzeTchelidze GEMember

    I am using Visual studio android emulator and had the same problem.
    I tried all of the suggested solution, but none of them worked for me.
    Eventually, i've found one, go to Settings->Apps->(appName) and pressed Clear cache and clear data, after that App run happily ^^

  • Ramesh.9983Ramesh.9983 USMember
    edited January 2016

    Hi Guys..
    Finally i found the issue regarding Unfortunately "App Name" has stopped in android mobile..
    When we run the application in our mobile, we should have to keep the xamarin supporting file on your mobile..
    It should work..

  • KhurramShaikhKhurramShaikh USMember
    edited March 2016

    Ari Johannesson, IT WORK FOR ME... Thanks

  • ArvindrajaArvindraja INMember ✭✭✭

    @AriJohannesson said:
    SOLVED: Disabled "Shared Shared Runtime" in Android build options.

    Nice..it's work for me.

  • AbhayShiravantheAbhayShiravanthe INMember ✭✭

    Hi Guys,

    I was having the same problem and the below solution worked for me:

    Go to the project name in solution explorer and right click -> Properties.
    In the properties, go to Android Options -> uncheck shared runtime.

    Then go to Application tab and select Compile using Android version: Use Latest Platform
    Minimum Android Target -> This must be the Android version of the device you are deploying on
    Target Android version -> This must be the Android version of the device you are deploying on

    I selected Android 4.2( API Level 17 - Jelly Bean) as this was my target device for development.
    You can change this according to the device you are developing for.

    Hope it works for you all!

    Thanks and regards!

  • kuttkutt INMember

    @AriJohannesson said:
    SOLVED: Disabled "Shared Shared Runtime" in Android build options.

    Worked !

  • kuttkutt INMember

    @kutt said:

    @AriJohannesson said:
    SOLVED: Disabled "Shared Shared Runtime" in Android build options.

    Worked ! Thanks !!

  • I was having the same issue when I tried to build project in Release configuration in Visual Studio and run it on symulator. I found solution to fix it. Go to properties of Android project, then go to Android Options-> Advanced tab-> Supported architectures; and check all architectures' checkboxes.

  • lukasrein97lukasrein97 USMember ✭✭✭

    @TymurTkachenko said:
    I was having the same issue when I tried to build project in Release configuration in Visual Studio and run it on symulator. I found solution to fix it. Go to properties of Android project, then go to Android Options-> Advanced tab-> Supported architectures; and check all architectures' checkboxes.

    Thank you so much it worked. I only checked ARM Processor. Now i checked all and it works on all real devices now!

  • akbercakberc PKMember

    For me, it was x86_64 emulator and that not being in Build Options -> Advanced -> supported architectures. Most of the answers in this thread have to do with build properties.

  • DiegoSalvatoreDiegoSalvatore USMember
    edited December 2016

    OK, Solved..
    When I tried to used what @AriJohannesson said, i did not work for me. So, keep checked "Shared Runtime" (if Uncheked it, it gives a arquitecture error).
    My Solution: Go to Android build-->Advanced and Unchecked "armeabi" option

  • JulieMissonJulieMisson USMember

    Thank-you just unchecking "armeabi" and leaving the "shared runtime" checked worked for me also.

  • caroLimacaroLima USMember

    @TymurTkachenko said:
    I was having the same issue when I tried to build project in Release configuration in Visual Studio and run it on symulator. I found solution to fix it. Go to properties of Android project, then go to Android Options-> Advanced tab-> Supported architectures; and check all architectures' checkboxes.

    Thankssssssssssssssss!!!!!!!!!!!!!!

  • RamaBoseRamaBose USMember ✭✭

    Hai how to get .apk file in xamarin cross plate from.
    Please help me

  • danmbuendanmbuen USMember ✭✭

    @AriJohannesson said:
    SOLVED: Disabled "Shared Shared Runtime" in Android build options.

    Got this error in actual device. Worked for me! Thanks @AriJohannesson!

  • thanathana USMember
    1. Uncheck the "Shared Run time"
    2. Please check the version compatibility of the android build and your deceive / emulator
Sign In or Register to comment.