XS won't let me select the iOS Simulator (It's disabled)

GiusepeGiusepe BRMember ✭✭

Hello,

While I'm not really sure, I think that after the last Xamarin.iOS update, my XS studio won't let me select which simulator I want to run.
I have made a few research and tried everything I found, so far no success at all.

I have tested with my Xamarin.Forms project (with the iOS app as startup project), I have made a new XF project and even tried a simple iOS project.
I have completely remove Xcode and Xamarin, reinstalled it all and the problem persists.

Ah, I have the simulators installed and running perfectly with Xcode.

Posts

  • JeffreyStedfastJeffreyStedfast USXamarin Team Xamurai

    The problem is with your build configurations. This often happens if you create a Library project first and then add an iOS Application project because the Library project does not have the iPhoneSimulator Platform value.

  • GiusepeGiusepe BRMember ✭✭

    Hello @jstedfast.

    I'll take a look in the build configurations. Do you have a sample as it should be?
    Anyway, this is happening even when I create a iPhone project from scratch.

    Thanks for the reply :)

  • JeffreyStedfastJeffreyStedfast USXamarin Team Xamurai

    Try creating a new iOS SingleView Project. That works for me.

    I'm not sure how to explain how to fix the configurations or I would try to explain it better.

    We're working toward dropping the whole iPhone vs iPhoneSimulator Platform and instead using Any CPU the same as other .NET projects to avoid this type of confusion in the future.

  • GiusepeGiusepe BRMember ✭✭

    Just tried creating another iOs project, SingleView Project, and it's not working either.

    I'm thinking about removing it all over again, try to clean everything and start a fresh.

  • mattwardmattward GBMember Xamurai

    The only time I have had a similar problem was when the project was targeting a version of iOS that I did not have simulators installed for. By default a new project currently targets iOS 8.3. So you could try choosing an older iOS version either when you create a new project or by opening the Info.plist and changing the Deployment Target to an older version, say 8.0.

  • GiusepeGiusepe BRMember ✭✭

    Ok guys, after a few days I figured out what was happening:

    Seems that an update that I did on Xcode messed up with the simulators. Even when the simulators were working perfectly with Xcode, some kinda of link or reference was corrupted.
    I found a link on Stackoverflow (which I missed, sorry) where a guys suggested to remove all simulators from Xcode and re-add then one by one.
    Once I removed them all and restarted Xcode, they were magically back... So I removed all of them once more and restarted Xcode one more time. This time they vanished as it should be.

    I added all simulators that I need and launched XS... and it worked! All simulators up and running.

    Thanks for you support and attention, and sorry for this, after all, seems that was all an Xcode problem and not Xamarin :)

Sign In or Register to comment.