Forum Xamarin.Android

Announcement:

The Xamarin Forums have officially moved to the new Microsoft Q&A experience. Microsoft Q&A is the home for technical questions and answers at across all products at Microsoft now including Xamarin!

To create new threads and ask questions head over to Microsoft Q&A for .NET and get involved today.

Trouble with Motorola MC3200 Device

AxelStallknechtAxelStallknecht DEUniversity ✭✭

Hi folks,

I try to publish my app on a Motorola MC32 Barcode Scanner (Android 4.1.1). But I do not see the device in "Physical devices" in Xamarin Studio on my Mac. I have also a Samsung Galaxy 4 on this Mac which works great. I have checked everything, but can't find an error. The developer options are the same on both devices (i.e. USB Debug). On both devices I get the messages "USB debugging connected" and "Connected as a media device". If I open Tools->Android Devices, I see just the Galaxy. In "Physical devices" on main windows I also just see the Galaxy, but not the Motorola. I try to....reboot, use different USB ports, different USB cables, disconnect the galaxy so that just the Motorola is connected......
I ran out of ideas what else I can check. Does anyone have an additional idea ?

BR Axel

Posts

  • Do you see the device when you execute the following in the terminal?

    adb devices

    I do most of my development on Windows, and I've had to install specific drivers for different manufacturers. I've never had to install anything on the Mac. Checking the Zebra support site for the MC32[00], I don't see anything. I found this when googling: https://developer.motorolasolutions.com/docs/DOC-1880
    It has directions for Windows and Linux, but not Mac. The Google USB driver is not needed on MacOS, so that's a dead end.

    I've had issues with bad USB cables and ports before. Sounds like you've tried that avenue.

  • AxelStallknechtAxelStallknecht DEUniversity ✭✭

    Thanks for your answer, Jason. I haven't checked "adb devices"....good hint. ;-) Sometimes after testing.....and testing.....and testing.....you become blind for such simple thinks. ;) I will try it tomorrow...because it's about 8 pm in Germany and I'm at home. ;-)

    I prefer a Mac as main development machine for Xamarin projects. All my other Android projects works on Mac on different Android devices without any problems, without installing drivers or special software. On the Mac, there is VMWare Fusion Win8.1 installation. Fusion sees the MC32000 and ask, if this device should connected to Mac or Win. If I say Win, Win8.1 sees the device and I can browse files. But in Visual Studio I can't see this device anyway. No idea why !!!! Other Androids I see and can use these devices. Strange !!!

    My main native windows development machine is a Win7. But there ist just VS2008 (because of CE development) and VS2010 (for other .NET and mainly ASP.NET stuff) installed. But I can try this tomorrow too, if the MC3200 is recognized on real, non-virtual USB port.

Sign In or Register to comment.