Xamarin.VisualStudio.Shell package did not load correctly

WilliamReesWilliamRees USMember, University
edited October 2014 in Visual Studio

Hello Xamarin Community,

I am new to Xamarin and am trying to install Xamarin for Windows on my development box which is not connected to the internet for security purposes.

On my dev box I am running Visual Studio 2010 Ultimate Version 10.0.40219.1 SP1Rel.

I installed the following components in this exact order:

  1. JDK 1.6: http://download.xamarin.com/Installer/MonoForAndroid/jdk-6u39-windows-i586.exe
  2. Android SDK: http://dl.google.com/android/installer_r23.0.2-windows.exe
  3. GTK#: http://download.xamarin.com/GTKforWindows/Windows/gtk-sharp-2.12.26.msi
  4. Xamarin Studio: http://download.xamarin.com/studio/Windows/XamarinStudio-5.5.0.227-0.msi
  5. Xamarin for Windows (includes Xamarin.iOS for Visual Studio and Xamarin.Android): http://download.xamarin.com/XamarinforVisualStudio/Windows/Xamarin.VisualStudio_Setup-3.7.203.msi

Xamarin Studio fires up with no issues for me, however Visual Studio throws the following error when it tries to load up.

_"The 'Xamarin.VisualStudio.Shell.ShellPackage, Xamarin.VisualStudio.Shell, Version=1.0.0.0, Culture-neural, PublicKeyToken=0738eb9f132ed756' package did not load correctly.

The problem may have been caused by a configuration change or by the installation of another extension. You can get more information by running the application together with the /log parameter on the command line, and then examining the file 'C:\Users\userName\AppData\Roaming\Microsoft\VisualStudio\10.0\ActivityLog.xml'."_

When I view the ActivityLog.xml, I find these two entries regarding Xamarin.

  <entry>
    <record>316</record>
    <time>2014/10/29 17:58:22.968</time>
    <type>Error</type>
    <source>VisualStudio</source>
    <description>SetSite failed for package [Xamarin.VisualStudio.Shell.ShellPackage, Xamarin.VisualStudio.Shell, Version=1.0.0.0, Culture=neutral, PublicKeyToken=0738eb9f132ed756]</description>
    <guid>{2D510815-1C4E-4210-BD82-3D9D2C56C140}</guid>
    <hr>80131500</hr>
    <errorinfo>The composition produced a single composition error. The root cause is provided below. Review the CompositionException.Errors property for more detailed information.

1) Requested registry access is not allowed.

Resulting in: An exception occurred while trying to create an instance of type 'Xamarin.VisualStudio.Shell.Commands.StartXamarinDeviceManager'.

Resulting in: Cannot activate part 'Xamarin.VisualStudio.Shell.Commands.StartXamarinDeviceManager'.
Element: Xamarin.VisualStudio.Shell.Commands.StartXamarinDeviceManager -->  Xamarin.VisualStudio.Shell.Commands.StartXamarinDeviceManager -->  ComponentCatalog (Types='Clide.ClideSettings, Clide.ErrorsManager, ...').

Resulting in: Cannot get export 'Xamarin.VisualStudio.Shell.Commands.StartXamarinDeviceManager (ContractName="Clide.Commands.ICommandExtension")' from part 'Xamarin.VisualStudio.Shell.Commands.StartXamarinDeviceManager'.
Element: Xamarin.VisualStudio.Shell.Commands.StartXamarinDeviceManager (ContractName="Clide.Commands.ICommandExtension") -->  Xamarin.VisualStudio.Shell.Commands.StartXamarinDeviceManager -->  ComponentCatalog (Types='Clide.ClideSettings, Clide.ErrorsManager, ...').
</errorinfo>
  </entry>
  <entry>
    <record>317</record>
    <time>2014/10/29 17:58:23.000</time>
    <type>Error</type>
    <source>VisualStudio</source>
    <description>End package load [Xamarin.VisualStudio.Shell.ShellPackage, Xamarin.VisualStudio.Shell, Version=1.0.0.0, Culture=neutral, PublicKeyToken=0738eb9f132ed756]</description>
    <guid>{2D510815-1C4E-4210-BD82-3D9D2C56C140}</guid>
    <hr>80131500</hr>
    <errorinfo>The composition produced a single composition error. The root cause is provided below. Review the CompositionException.Errors property for more detailed information.

1) Requested registry access is not allowed.

Resulting in: An exception occurred while trying to create an instance of type 'Xamarin.VisualStudio.Shell.Commands.StartXamarinDeviceManager'.

Resulting in: Cannot activate part 'Xamarin.VisualStudio.Shell.Commands.StartXamarinDeviceManager'.
Element: Xamarin.VisualStudio.Shell.Commands.StartXamarinDeviceManager -->  Xamarin.VisualStudio.Shell.Commands.StartXamarinDeviceManager -->  ComponentCatalog (Types='Clide.ClideSettings, Clide.ErrorsManager, ...').

Resulting in: Cannot get export 'Xamarin.VisualStudio.Shell.Commands.StartXamarinDeviceManager (ContractName="Clide.Commands.ICommandExtension")' from part 'Xamarin.VisualStudio.Shell.Commands.StartXamarinDeviceManager'.
Element: Xamarin.VisualStudio.Shell.Commands.StartXamarinDeviceManager (ContractName="Clide.Commands.ICommandExtension") -->  Xamarin.VisualStudio.Shell.Commands.StartXamarinDeviceManager -->  ComponentCatalog (Types='Clide.ClideSettings, Clide.ErrorsManager, ...').
</errorinfo>
  </entry>

Is this a result of my "Starter" Xamarin package?

Any help regarding this issue would be appreciated.

Thanks,

Will

Posts

  • BayborodovSergeyBayborodovSergey USMember

    Same problem. Do you have solution ?

  • Sergei.0367Sergei.0367 USMember

    Hello. Has anyone solution for that?

  • zebra-brzebra-br ✭✭ USUniversity ✭✭

    Any updates?

    Similar error with VS2015RC on Windows 10 Preview. Entry in Visual Studio ActivityLog.xml is:


    257

    Error

    VisualStudio
    SetSite failed for package [XamarinShellPackage]
    {2D510815-1C4E-4210-BD82-3D9D2C56C140}

    80131509
    The service provider type 'Xamarin.VisualStudio.Shell.XamarinShellPackage' specified a provided assembly for components registration 'Xamarin.VisualStudio.dll' that was not found at 'C:\WINDOWS\Microsoft.Net\assembly\GAC_MSIL\Xamarin.VisualStudio.Shell\v4.0_3.11.0.0__0738eb9f132ed756\Xamarin.VisualStudio.dll'.

    However, when I search for the file that the message says is missing - the file is there with read & execute privileges for everyone and for "ALLAPPS".

  • zebra-brzebra-br ✭✭ USUniversity ✭✭

    Any updates?

    Similar error with VS2015RC on Windows 10 Preview. Entry in Visual Studio ActivityLog.xml is:


    257

    Error

    VisualStudio
    SetSite failed for package [XamarinShellPackage]
    {2D510815-1C4E-4210-BD82-3D9D2C56C140}

    80131509
    The service provider type 'Xamarin.VisualStudio.Shell.XamarinShellPackage' specified a provided assembly for components registration 'Xamarin.VisualStudio.dll' that was not found at 'C:\WINDOWS\Microsoft.Net\assembly\GAC_MSIL\Xamarin.VisualStudio.Shell\v4.0_3.11.0.0__0738eb9f132ed756\Xamarin.VisualStudio.dll'.

    However, when I search for the file that the message says is missing - the file is there with read & execute privileges for everyone and for "ALLAPPS".

Sign In or Register to comment.