Packaging Add-ins

RobertZmudzinskiRobertZmudzinski USUniversity ✭✭

I'm working on creating and add-in I can share among team members and have worked my way through this tutorial - http://developer.xamarin.com/guides/cross-platform/getting_started/extending_xamarin_studio_with_addins/ I then package the add-in with the mdtool like so

mdtool.exe setup pack DateInserter.dll

When I then install the generated mpack with the add-in manager I get the error

The installation failed!

Could not read add-in description.

The add-in however is successfully installed but I would like to address the error.

In AddinInfo.cs I specify the add-in description as follows...

[assembly:AddinDescription ("DateInserter")]

I've attached the full source for the project.
I'm hoping to avoid building Xamarin Studio from the source to debug - if someone could point me in the right direction I'd be very appreciative.

Thanks!

Best Answers

Answers

  • RobertZmudzinskiRobertZmudzinski USUniversity ✭✭

    Oops. Forgot to specify Xamarin Studio build - 5.8.3 (build 1)

  • GeorgeCookGeorgeCook PEUniversity ✭✭✭
    edited May 2015

    seems there's very little support for xamarin addin related issues here. I need an answer to this too.

    @RobZ did you solve this?

    Any ideas where else to go for help?

  • RobertZmudzinskiRobertZmudzinski USUniversity ✭✭

    I just did a fresh install last night of Xamarin Studio on a machine with only Visual Studio 2013 installed on it - nothing else. It doesn't show the error on the new machine. Both machines are running version 5.9 build 431. Yeah, you really have to hunt and guess when working on the addins. There is the DateInserter and a couple of other examples and that's it. Documentation is sparse. I have yet to get a build of MonoDevelop from source going - I think that's essential to addin development.

  • RobertZmudzinskiRobertZmudzinski USUniversity ✭✭

    You know it did not occur to me to look for the source for the Addin Maker till your post. I got it from your git repo yesterday - it's like ten tutorials in one. Most of my questions centered around wiring up the extension points and using related objects such as DotNetProject, DotNetProjectConfiguration, etc. I'm focused on creating project templates with the addin. I still need to work out how to add components into the template's csproj. I've got the sample code and I've got MonoDevelop building from source (finally) so 'm sure I'l get there. Thanks!

  • mattdnamattdna AUMember

    I'm getting the same error when I try and install my own custom add-in (installing from file using the .mpack file generated using mdtool). However, when I restart Xamarin Studio, the add-in appears to have installed successfully. If anyone has any ideas of things to try, this would be greatly appreciated as this would be a terrible first impression for users of the add-in.

    My Xamarin Studio is Version 5.9.1 (build 3).

  • mattdnamattdna AUMember

    I have also tried with the DateInserter sample from the Xamarin developer guide documentation http://developer.xamarin.com/guides/cross-platform/getting_started/extending_xamarin_studio_with_addins/
    I first had to upgrade the add-in project it to the newest version of Add-In maker using the instructions here: https://mhut.ch/addinmaker/1.2
    After building and using mdtool to generate the mpack file, installing into Xamarin Studio produced the same "Could not read add-in description" error.
    Therefore it appears the process is either broken, or the documentation in the developer guide is out of date. Or perhaps there is an issue with my installation of xamarin-studio.

    I'm considering bypassing the Add-in maker, and following the instructions for creating a Monodevelop add-in, as per here http://www.monodevelop.com/developers/articles/publishing-an-addin/.
    @mhutch can you comment on whether this is a feasible approach?

  • mhutchmhutch USMember, Xamarin Team Xamurai

    @mattdna for the installation errors, I'd suggest you file a bug on bugzilla.xamarin.com for @LluisSanchez to look at. Those are coming from the addin engine in XS itself. Addin Maker is a personal side project for me (I haven't worked on XS directly for about a year).

    The guide you linked is for building addins on the build server so they're published in the gallery. To do that, they still need to be buildable from a sln file and IMO Addin Maker the easiest way to do so.

  • mhutchmhutch USMember, Xamarin Team Xamurai
    edited May 2015

    (I've also requested that the Xamarin docs team update the "Extending Xamarin Studio with Add-Ins" doc to the latest version of my addin, but it's fairly low on their priorities list)

  • RobertZmudzinskiRobertZmudzinski USUniversity ✭✭

    @mattdna did you try pulling down https://github.com/mhutch/MonoDevelop.AddinMaker building, running it through the mdtool, and installing? I found with the original addin I was building I saw the registration error on one 5.9.1 (v 431) box but not on the other. When registering the addin maker addin I did not see the error on either box. I would be very interested to know if you see the registration error building and registering addin maker from source.

  • RobertZmudzinskiRobertZmudzinski USUniversity ✭✭

    @mattdna @LluisSanchez @mhutch This bug only appears when the Addin Maker addin is installed. If I uninstall it and then install my addin I do not get the error message. The same error message also happens on an uninstall of my addin. Some kind of conflict? This is reproducible every time for me across installs/machines. I don't think the casual user will have addin maker installed so I'll just distribute with the caveat uninstall Addin Maker, install my addin, reinstall addin Maker. I have not specifically tested the case of running Addin Maker from source and installing my adding but I think that case may work.

  • RobertZmudzinskiRobertZmudzinski USUniversity ✭✭

    Simply disabling Addin Maker while the other addin is installed and then re-enabling is sufficient to eliminate the "install failed" error message.

  • mattdnamattdna AUMember

    @RobZ - thanks so much, my plugin installs and uninstalls without any issues at all when the Addin Maker is disabled. @mhutch, thanks for your help so far. Do you have any ideas why having the Addin maker installed (and enabled) could be causing this conflict?

  • mhutchmhutch USMember, Xamarin Team Xamurai

    I don't know, sorry. It sounds like a bug in the addin engine and only Lluis is familiar with its internals.

  • RobertZmudzinskiRobertZmudzinski USUniversity ✭✭

    Agree.

    The exception seems to come from

    monodevelop/main/external/mono-addins/Mono.Addins/Mono.Addins/Addin.cs:

    throw new InvalidOperationException ("Could not read add-in description");

  • RobertZmudzinskiRobertZmudzinski USUniversity ✭✭

    @LluisSanchez Thanks! Very much appreciated!

Sign In or Register to comment.