Xamarin.Droid app crash on checked “Shared runtime option”

Hello, my Xamarin experience was pretty cool, until this one issue.
I'm trying to debug my Xamarin Forms app on android device, but my app crashes on start after deployment, if I check "Use shared runtime" option, to be able to use breakpoints. if I uncheck "Use shared runtime", then app runs without any issues, but I'm unable to use breakpoints

I develop with Visual Studio 2015 CTP6 and using Genymotion 5.1.0 as emulator, I tried all of develop forks (stable, beta, alpha), but I'm still unable to debug my app.

I have also tried to debug on real device Samsung SM-G850F (Galaxy Alpha, Android 4.4) and still no result. :c
By the way, if I debug iOS project with Mac Build Host it works fine, so it depends on Android project, I guess.

Answers

  • greagdeaygreagdeay USMember
    edited April 2015

    well, I have found a pretty useful comment by Jonathan ( http://forums.xamarin.com/discussion/comment/50436/#Comment_50436 )

    even if I didn't use Galaxy S4 for debuggin, I tried to manually create a directory for AOT modules, but it didn't help.
    may be, I did it wrong?

    adb shell "mkdir /data/app/panicbutton.com-1/lib/x86/

    here is my adb log:
    http://pastebin.com/vgn2jiqh

    anyway, I tried to debug Xamarin Samples and they are fine, so the problem is in my project and settings.
    If anybody can help me with that issue, please, I will be very glad, because that problem is starting to freaking me out :confounded:

  • IgorLimankyIgorLimanky RUMember

    I got same problem, did you resolve it?

  • FrancMoralesFrancMorales JPMember ✭✭

    Checking "Use Share Runtime" still crashes app (debugging or not) in both debug and release versions.

    Have VS2012 and Xamarin Studio with latest updates as of the date of this post.

  • Any solutions?

Sign In or Register to comment.