MainStoryboard.storyboard -- There was a problem rendering this document

NateFullerNateFuller USMember

Hey guys. I'm super new to Xamarin. I was just trying to follow the tutorial for getting started here:

http://developer.xamarin.com/guides/ios/getting_started/hello,_iOS/hello,iOS_quickstart/

I hit a snag at step 5 when it tells me to open up the storyboard. Not sure why this happening? The load spinner appears for a while and then this error just pops up saying that there was a problem rendering this document, and asks if I'd like to open the storyboard with Xcode, which I would not like to do. I just did a fresh reinstall of Xcode 5 and Xamarin. I'll attach a photo so you can see the error I'm encountering. Has anyone else ran into this issue?

Posts

  • NateFullerNateFuller USMember

    Solved. Logging in on the home screen got it to work.. Derp

  • JajaHarrisJajaHarris USBeta, University ✭✭

    waddup dude, got the same issue as well as a few others; this whole storyboard feature doesn't seem to be fully baked

  • NateFullerNateFuller USMember

    Did you make sure you were logged into your
    account and were connected to the Internet when you tried to access the storyboard?

  • JajaHarrisJajaHarris USBeta, University ✭✭

    yep I'm logged in, just created a new single-view project, dragged a button and a label onto the storyboard, gave them names; double-clicked the button and put in one line of code to change the labels text to "hello world". At first I was getting an error stating that I was missing a partial declaration for the button's touchUpInside event handler.

    However when I look in the designer file the partial method is there. So did another build and on the second time around it built fine (no changes - go figure). But the app doesn't display in the simulator. Tried to open up the storyboard again and got the error that you mentioned. Closed out the storyboard file and re-opened it.

    Controls were out of order and not in original positions. Closed down Xamarin Studio and created a new single-view project - - added a button and a label - double-clicked to create event handler - add one line of code - hit build - app won't display. I'm running on the alpha channel with 8.0 as the target sdk.

  • JajaHarrisJajaHarris USBeta, University ✭✭

    I guess something wacky is going on between Xam Studio and the simulator. The apps are being deployed but they are not being launched by default. I have to click on the icon in the simulator to launch the app. Normally they just launch on their own. Oh well...it is alpha.

  • AlanMcGovernAlanMcGovern USXamarin Team Xamurai

    Logging into your Xamarin account is not a requirement for the designer. It has no effect on the designer. There is a known issue where sometimes the design surface cannot be started reliably. We have been unable to diagnose or replicate the issue on any of our machines though, so if you are experiencing this please send us your log files. We've been adding additional logging to newer builds to help us narrow down exactly what is going wrong.

    As for iOS8 support - this is still alpha and is not fully supported. There are known bugs in apples tooling as well as our own. For example launching applications was broken in apples first preview, but was working again in their second preview.

    For production work we recommend you target iOS7.1 and use Xcode 5.0 -> 5.1.1. This is the stable and supported configuration. We will bring a fully stable iOS8/Xcode6 support across our entire toolchain as soon as possible, but we are relying on apple to stabilise their stuff too.

  • NateFullerNateFuller USMember

    Where should we send the logs? Should they be posted here? If so, I've run into another error trying to access the story board.

  • ChrisLamontChrisLamont USMember, University

    I am also having trouble with my story board. I have been working on it today and all of a sudden it has stopped working. I have opened other projects and they are all working well.

    I was having trouble editing static cells that were outside the range of the view controller so I changed the Storyboard Simulated Metrics to Freeform. I ran it and it worked well, then I got an error message saying there was a problem and would I like to undo my changes. It had worked well so I said I didn't want to undo the changes. now it does not work and I get the following message...

    System.AggregateException: One or more errors occurred. ---> System.Exception: EnsureSession counter too high. Server may be repeatedly crashing. ---> MonoTouch.Design.Client.InvalidSessionException: Session invalid
    at MonoTouch.Design.Client.ServerProcessConnection.SendRequest(CommandRequest req, Boolean throwIfNotRunning)
    at MonoTouch.Design.Client.ServerProcessConnection.SendRequest[TResponse](CommandRequest req, Boolean throwIfNotRunning)
    at MonoTouch.Design.Client.ServerProcessConnection.PostXml(DesignSession session, String xml, String[] viewsToHide)
    at MonoTouch.Design.Client.ServerProcessConnection.PostXml(DesignSession session, XElement[] xml)
    at MonoTouch.Design.Client.IPhoneDesignerSession.<>c__DisplayClasse.b__d(ServerProcessConnection c)
    at MonoTouch.Design.Client.IPhoneDesignerSession.<>c__DisplayClass761.<EnsureSession>b__74() --- End of inner exception stack trace --- at MonoTouch.Design.Client.IPhoneDesignerSession.<>c__DisplayClass761.b__74()
    at System.Threading.Tasks.Task1.InnerInvoke() at System.Threading.Tasks.Task.Execute() --- End of inner exception stack trace --- ---> (Inner Exception #0) System.Exception: EnsureSession counter too high. Server may be repeatedly crashing. ---> MonoTouch.Design.Client.InvalidSessionException: Session invalid at MonoTouch.Design.Client.ServerProcessConnection.SendRequest(CommandRequest req, Boolean throwIfNotRunning) at MonoTouch.Design.Client.ServerProcessConnection.SendRequest[TResponse](CommandRequest req, Boolean throwIfNotRunning) at MonoTouch.Design.Client.ServerProcessConnection.PostXml(DesignSession session, String xml, String[] viewsToHide) at MonoTouch.Design.Client.ServerProcessConnection.PostXml(DesignSession session, XElement[] xml) at MonoTouch.Design.Client.IPhoneDesignerSession.<>c__DisplayClasse.<ReloadItems>b__d(ServerProcessConnection c) at MonoTouch.Design.Client.IPhoneDesignerSession.<>c__DisplayClass761.b__74()
    --- End of inner exception stack trace ---
    at MonoTouch.Design.Client.IPhoneDesignerSession.<>c__DisplayClass761.<EnsureSession>b__74() at System.Threading.Tasks.Task1.InnerInvoke()
    at System.Threading.Tasks.Task.Execute()<---

    Contents of C:\Users\Chris\AppData\Local\Xamarin\Log\11.0\iOSDesigner.2014-07-21__16-28-23.log:
    [2014-07-21 16:28:33.0] INFO: Starting full reload...
    [2014-07-21 16:28:33.0] INFO: Reloading: Serialization took 1ms
    [2014-07-21 16:28:41.9] INFO: Reloading: Deserialization took 273ms
    [2014-07-21 16:28:41.9] INFO: Reloading: Server rendering completed in 8902ms with 711001 bytes
    [2014-07-21 16:28:42.2] INFO: Fetched iOS SDK data in C:\Users\Chris\AppData\Local\Temp\xd-support-files-4447996e
    [2014-07-21 16:28:42.2] INFO: Added image resource: organizer.png
    [2014-07-21 16:28:42.2] INFO: Added image resource: logo.gif
    [2014-07-21 16:28:42.2] INFO: Added image resource: invitations-not-sent.png
    [2014-07-21 16:28:42.2] INFO: Added image resource: delete.png
    [2014-07-21 16:28:42.2] INFO: Added image resource: completed.png
    [2014-07-21 16:28:42.3] INFO: Added image resource: all-responded.png
    [2014-07-21 16:28:42.3] INFO: Added image resource: add.png
    [2014-07-21 16:28:42.3] INFO: Reloading: Serialization took 0ms
    [2014-07-21 16:28:42.3] INFO: Reloading: Deserialization took 0ms
    [2014-07-21 16:28:42.3] INFO: Reloading: Server rendering completed in 25ms with 214 bytes
    [2014-07-21 16:28:42.4] INFO: Reloading: Serialization took 1ms
    [2014-07-21 16:28:44.0] INFO: Reloading: Deserialization took 273ms
    [2014-07-21 16:28:44.0] INFO: Reloading: Server rendering completed in 1589ms with 356448 bytes
    [2014-07-21 16:28:44.3] INFO: Reloading: Serialization took 0ms
    [2014-07-21 16:28:47.2] INFO: Reloading: Deserialization took 0ms
    [2014-07-21 16:28:47.2] INFO: Reloading: Server rendering completed in 2978ms with 214 bytes
    [2014-07-21 16:28:47.2] ERROR: EnsureSession (counter 0): MonoTouch.Design.Client.InvalidSessionException: Session invalid
    at MonoTouch.Design.Client.ServerProcessConnection.SendRequest(CommandRequest req, Boolean throwIfNotRunning)
    at MonoTouch.Design.Client.ServerProcessConnection.SendRequest[TResponse](CommandRequest req, Boolean throwIfNotRunning)
    at MonoTouch.Design.Client.ServerProcessConnection.PostXml(DesignSession session, String xml, String[] viewsToHide)
    at MonoTouch.Design.Client.ServerProcessConnection.PostXml(DesignSession session, XElement[] xml)
    at MonoTouch.Design.Client.IPhoneDesignerSession.<>c__DisplayClasse.b__d(ServerProcessConnection c)
    at MonoTouch.Design.Client.IPhoneDesignerSession.<>c__DisplayClass761.<EnsureSession>b__74() [2014-07-21 16:28:47.2] INFO: Reloading: Serialization took 0ms [2014-07-21 16:28:47.8] INFO: Reloading: Deserialization took 286ms [2014-07-21 16:28:47.8] INFO: Reloading: Server rendering completed in 563ms with 711001 bytes [2014-07-21 16:28:48.0] INFO: Fetched iOS SDK data in C:\Users\Chris\AppData\Local\Temp\xd-support-files-4447996e [2014-07-21 16:28:48.0] INFO: Added image resource: organizer.png [2014-07-21 16:28:48.3] INFO: Added image resource: logo.gif [2014-07-21 16:28:48.3] INFO: Added image resource: invitations-not-sent.png [2014-07-21 16:28:48.3] INFO: Added image resource: delete.png [2014-07-21 16:28:48.3] INFO: Added image resource: completed.png [2014-07-21 16:28:48.3] INFO: Added image resource: all-responded.png [2014-07-21 16:28:48.3] INFO: Added image resource: add.png [2014-07-21 16:28:48.3] INFO: Reloading: Serialization took 0ms [2014-07-21 16:28:48.3] INFO: Reloading: Deserialization took 0ms [2014-07-21 16:28:48.3] INFO: Reloading: Server rendering completed in 23ms with 214 bytes [2014-07-21 16:28:48.4] INFO: Reloading: Serialization took 0ms [2014-07-21 16:28:49.7] INFO: Reloading: Deserialization took 152ms [2014-07-21 16:28:49.7] INFO: Reloading: Server rendering completed in 1331ms with 356448 bytes [2014-07-21 16:28:50.2] INFO: Reloading: Serialization took 0ms [2014-07-21 16:28:52.9] INFO: Reloading: Deserialization took 0ms [2014-07-21 16:28:52.9] INFO: Reloading: Server rendering completed in 2644ms with 214 bytes [2014-07-21 16:28:52.9] ERROR: EnsureSession (counter 1): MonoTouch.Design.Client.InvalidSessionException: Session invalid at MonoTouch.Design.Client.ServerProcessConnection.SendRequest(CommandRequest req, Boolean throwIfNotRunning) at MonoTouch.Design.Client.ServerProcessConnection.SendRequest[TResponse](CommandRequest req, Boolean throwIfNotRunning) at MonoTouch.Design.Client.ServerProcessConnection.PostXml(DesignSession session, String xml, String[] viewsToHide) at MonoTouch.Design.Client.ServerProcessConnection.PostXml(DesignSession session, XElement[] xml) at MonoTouch.Design.Client.IPhoneDesignerSession.<>c__DisplayClasse.<ReloadItems>b__d(ServerProcessConnection c) at MonoTouch.Design.Client.IPhoneDesignerSession.<>c__DisplayClass761.b__74()
    [2014-07-21 16:28:52.9] INFO: Invalidating current connection
    [2014-07-21 16:28:52.9] INFO: Reloading: Serialization took 0ms
    [2014-07-21 16:28:54.9] INFO: Reloading: Deserialization took 290ms
    [2014-07-21 16:28:54.9] INFO: Reloading: Server rendering completed in 1990ms with 711001 bytes
    [2014-07-21 16:28:55.0] INFO: Fetched iOS SDK data in C:\Users\Chris\AppData\Local\Temp\xd-support-files-4447996e
    [2014-07-21 16:28:55.0] INFO: Added image resource: organizer.png
    [2014-07-21 16:28:55.1] INFO: Added image resource: logo.gif
    [2014-07-21 16:28:55.1] INFO: Added image resource: invitations-not-sent.png
    [2014-07-21 16:28:55.1] INFO: Added image resource: delete.png
    [2014-07-21 16:28:55.1] INFO: Added image resource: completed.png
    [2014-07-21 16:28:55.1] INFO: Added image resource: all-responded.png
    [2014-07-21 16:28:55.1] INFO: Added image resource: add.png
    [2014-07-21 16:28:55.2] INFO: Reloading: Serialization took 0ms
    [2014-07-21 16:28:55.2] INFO: Reloading: Deserialization took 0ms
    [2014-07-21 16:28:55.2] INFO: Reloading: Server rendering completed in 19ms with 214 bytes
    [2014-07-21 16:28:55.2] INFO: Reloading: Serialization took 0ms
    [2014-07-21 16:28:56.5] INFO: Reloading: Deserialization took 160ms
    [2014-07-21 16:28:56.5] INFO: Reloading: Server rendering completed in 1308ms with 356448 bytes
    [2014-07-21 16:28:57.2] INFO: Reloading: Serialization took 0ms
    [2014-07-21 16:29:00.3] INFO: Reloading: Deserialization took 0ms
    [2014-07-21 16:29:00.3] INFO: Reloading: Server rendering completed in 3091ms with 214 bytes
    [2014-07-21 16:29:00.3] ERROR: EnsureSession (counter 2): MonoTouch.Design.Client.InvalidSessionException: Session invalid
    at MonoTouch.Design.Client.ServerProcessConnection.SendRequest(CommandRequest req, Boolean throwIfNotRunning)
    at MonoTouch.Design.Client.ServerProcessConnection.SendRequest[TResponse](CommandRequest req, Boolean throwIfNotRunning)
    at MonoTouch.Design.Client.ServerProcessConnection.PostXml(DesignSession session, String xml, String[] viewsToHide)
    at MonoTouch.Design.Client.ServerProcessConnection.PostXml(DesignSession session, XElement[] xml)
    at MonoTouch.Design.Client.IPhoneDesignerSession.<>c__DisplayClasse.b__d(ServerProcessConnection c)
    at MonoTouch.Design.Client.IPhoneDesignerSession.<>c__DisplayClass761.<EnsureSession>b__74() [2014-07-21 16:29:00.3] ERROR: Unexpected exception while reloading XML for MonoTouch.Design.Client.IPhoneDesignerItem[] System.AggregateException: One or more errors occurred. ---> System.Exception: EnsureSession counter too high. Server may be repeatedly crashing. ---> MonoTouch.Design.Client.InvalidSessionException: Session invalid at MonoTouch.Design.Client.ServerProcessConnection.SendRequest(CommandRequest req, Boolean throwIfNotRunning) at MonoTouch.Design.Client.ServerProcessConnection.SendRequest[TResponse](CommandRequest req, Boolean throwIfNotRunning) at MonoTouch.Design.Client.ServerProcessConnection.PostXml(DesignSession session, String xml, String[] viewsToHide) at MonoTouch.Design.Client.ServerProcessConnection.PostXml(DesignSession session, XElement[] xml) at MonoTouch.Design.Client.IPhoneDesignerSession.<>c__DisplayClasse.<ReloadItems>b__d(ServerProcessConnection c) at MonoTouch.Design.Client.IPhoneDesignerSession.<>c__DisplayClass761.b__74()
    --- End of inner exception stack trace ---
    at MonoTouch.Design.Client.IPhoneDesignerSession.<>c__DisplayClass761.<EnsureSession>b__74() at System.Threading.Tasks.Task1.InnerInvoke()
    at System.Threading.Tasks.Task.Execute()
    --- End of inner exception stack trace ---
    ---> (Inner Exception #0) System.Exception: EnsureSession counter too high. Server may be repeatedly crashing. ---> MonoTouch.Design.Client.InvalidSessionException: Session invalid
    at MonoTouch.Design.Client.ServerProcessConnection.SendRequest(CommandRequest req, Boolean throwIfNotRunning)
    at MonoTouch.Design.Client.ServerProcessConnection.SendRequest[TResponse](CommandRequest req, Boolean throwIfNotRunning)
    at MonoTouch.Design.Client.ServerProcessConnection.PostXml(DesignSession session, String xml, String[] viewsToHide)
    at MonoTouch.Design.Client.ServerProcessConnection.PostXml(DesignSession session, XElement[] xml)
    at MonoTouch.Design.Client.IPhoneDesignerSession.<>c__DisplayClasse.b__d(ServerProcessConnection c)
    at MonoTouch.Design.Client.IPhoneDesignerSession.<>c__DisplayClass761.<EnsureSession>b__74() --- End of inner exception stack trace --- at MonoTouch.Design.Client.IPhoneDesignerSession.<>c__DisplayClass761.b__74()
    at System.Threading.Tasks.Task`1.InnerInvoke()
    at System.Threading.Tasks.Task.Execute()<---

  • Hi,

    @JajaHarris I am also facing similar issue. How to fix it?

  • Same here

  • DanieleDaviDanieleDavi USMember

    Hi, I have the same issue (Xamarin 3.9, SDK 8.0)

  • MahenderReddyMahenderReddy USMember
    edited February 2015

    Hi, Recently I installed Xamarin studio version:5.7. After that I downloaded a sample project it's working fine without storyboard.Then I created a new project in that story board is not opening.
    Error : There was a problem rendering this document.
    in more details:
    System.AggregateException: One or more errors occurred ---> System.SystemException: RegisterServicePort(com.xamarin.MTHosting.ca55294, com.apple.PowerManagement.control): Kernel returned: -308 (-308): (ipc/mig) server died
    at MonoTouch.Hosting.CheckReturnExtensions.Check (kern_return_t result, System.String message) [0x0003c] in /Users/builder/data/lanes/monodevelop-lion-monodevelop-5.7-branch/b70bab61/source/md-addins/Xamarin.Designer.iOS/MonoTouch.Hosting/MachPort.cs:434 ...................

  • same here, but in visual studio 2013 with business edition ... very bad!

    supportus

  • KatherineGreenKatherineGreen RUMember

    Same trouble, Xamarin Studio, Indie edition

    System.AggregateException: One or more errors occurred ---> System.Exception: EnsureSession counter too high. Server may be repeatedly crashing. ---> System.AggregateException: One or more errors occurred ---> MonoTouch.Design.Client.InvalidSessionException: Session invalid ---> Foundation.ObjCException: NSObjectInaccessibleException: NSDistantObject (0x25e3c360) is invalid (no connection)
    at ObjCRuntime.Runtime.ThrowNSException (IntPtr ns_exception) [0x00000] in :0

  • AmroOsamaAmroOsama SAMember

    Did anyone find a solution for this, it also happens with me.
    I'm logged in my Indie account and I do have internet access.

  • AlanMcGovernAlanMcGovern USXamarin Team Xamurai

    For anyone experiencing problems, can you pleas attach the full exception information and also the Ide.log and the iOSDesigner.log file from the session where you experienced the problem.

    The latest 5.7 release has several fixes for startup issues in comparison to previous releases. I believe we have one more ready to ship with the next service release.

    If you are seeing an error with 'RegisterServiceReport' in it, then you could have this malware installed: https://kb.xamarin.com/customer/portal/articles/1684218-ios-designer-error-with-"registerserviceport"

    Thanks!

  • JonWorthingtonJonWorthington USUniversity

    I am getting the same error. I am brand new to Xamarin - just downloaded it last night and am working on the Phoneword_IOS tutorial. When I open my MainStoryboard it says "There was a problem rendering this document".

    Error is attachedFu

  • AnanyaDixitAnanyaDixit GBMember ✭✭

    Hi, I am also receiving the same error when attempting to open StoryBoard.

    I've attached the error log that I am getting. Help! I need to do my assignment but can't even start it properly by the looks of it!

    TIA!

  • chandu234uchandu234u USMember, University

    It worked for me once I moved the solution path to C:\. looks like designer doesn't work good if the solution path is having multiple folders. FYI I am using visual studio 2013 update 4.

  • derFranzderFranz DEMember

    same problem here :( using:

    Microsoft Visual Studio Ultimate 2013
    Version 12.0.31101.00 Update 4
    Microsoft .NET Framework
    Version 4.5.51650

    Installed Version: Ultimate

    ...

    Xamarin 3.11.445.0 (5061f92)
    Visual Studio extension to enable development for Xamarin.iOS and Xamarin.Android.

    Xamarin.Android 5.1.0.115 (d23da369e436488f38c8ab8fe8a9ae7d9ea5256b)
    Visual Studio plugin to enable development for Xamarin.Android.

    Xamarin.Forms Intellisense 1.0
    Provides intellisense for Xamarin.Forms in the XML editor.

    Xamarin.iOS 8.10.0.0 (7741cc495ab0baf04ff0405d0604bc27f0ecae2e)
    Visual Studio extension to enable development for Xamarin.iOS.

    Xamarin.iOS Unified Migration 1.0
    Automated migration for Xamarin iOS Classic projects to Unified

    Xamarin.TestCloud.Integration 1.0
    Early preview of Xamarin Test Cloud integration

    XamlHelpmeet 1.0
    Derivative version of XAML Power Toys by Karl Shifflett originally designed and compiled for VS 2008 and 2010. This version has been rewritten in C# and is designed for installation in VS 2012.

  • UsamaKaleemUsamaKaleem USMember

    I have just download Xamarin Studio and i am trying to run the first tutorial Hello IOS. but there is issue in the designer of Iphone. the Ipad storyboard opens fine. The error details are attached. I want to use xamarin but if the tutorials dont work how can one do anything.
    The error log is attached

  • AlanMcGovernAlanMcGovern USXamarin Team Xamurai

    @derFranz You've installed an extension in Visual Studio which is breaking assembly loading/resolving.

    The relevant part of the stacktrace is:

    [2015-05-02 23:46:11.0] ERROR: Unexpected error while trying to render custom controls
    System.AggregateException: One or more errors occurred. ---> System.NullReferenceException: Object reference not set to an instance of an object.
       at Costura.AssemblyLoader.ReadExistingAssembly(AssemblyName name)
       at Costura.AssemblyLoader.ResolveAssembly(Object sender, ResolveEventArgs args)
       at System.AppDomain.OnAssemblyResolveEvent(RuntimeAssembly assembly, String assemblyFullName)
       at System.RuntimeTypeHandle.GetTypeByName(String name, Boolean throwOnError, Boolean ignoreCase, Boolean reflectionOnly, StackCrawlMarkHandle stackMark, IntPtr pPrivHostBinder, Boolean loadTypeFromPartialName, ObjectHandleOnStack type)
       at System.RuntimeTypeHandle.GetTypeByName(String name, Boolean throwOnError, Boolean ignoreCase, Boolean reflectionOnly, StackCrawlMark& stackMark, IntPtr pPrivHostBinder, Boolean loadTypeFromPartialName)
       at System.RuntimeType.GetType(String typeName, Boolean throwOnError, Boolean ignoreCase, Boolean reflectionOnly, StackCrawlMark& stackMark)
       at System.Type.GetType(String typeName)
       at MonoTouch.Design.Client.SystemDrawingTypeBinder.BindToType(String assemblyName, String typeName)
       at System.Runtime.Serialization.Formatters.Binary.ObjectReader.Bind(String assemblyString, String typeString)
       at System.Runtime.Serialization.Formatters.Binary.ObjectReader.GetType(BinaryAssemblyInfo assemblyInfo, String name)
       at System.Runtime.Serialization.Formatters.Binary.ObjectMap..ctor(String objectName, String[] memberNames, BinaryTypeEnum[] binaryTypeEnumA, Object[] typeInformationA, Int32[] memberAssemIds, ObjectReader objectReader, Int32 objectId, BinaryAssemblyInfo assemblyInfo, SizedArray assemIdToAssemblyTable)
       at System.Runtime.Serialization.Formatters.Binary.__BinaryParser.ReadObjectWithMapTyped(BinaryObjectWithMapTyped record)
    

    Costura.AssemblyLoader is intercepting standard assembly resolution and is throwing a null reference exception, thus breaking assembly resolution/loading for (potentially) everything in Visual Studio. Your best bet is to remove whichever extension it is which is using this class, or upgrade to a newer version which does not break assembly loading.

  • AlanMcGovernAlanMcGovern USXamarin Team Xamurai

    @UsamaKaleem I just read through your log file. Your logs indicate you're hitting a known issue we've attempted to address in our internal builds. The root of the issue is that Xamarin Studio launches multiple renderers, get's confused, then times out because it's waiting for the wrong renderer.

    The first build to ship with the full fix for this will be Xamarin Studio 5.10 or higher. In the meantime, there's one workaround which should help:

    After launching Xamarin Studio and opening your project, open Activity Monitor and kill any process called csproxy. If it automatically restarts, kill it again. Keep killing it until it stays dead [0]. Once that's done, open your storyboard and wait to see if it loads. Note: This will start 'csproxy' automatically, so don't kill it this time!

    If the storyboard doesn't load after this, just close the storyboard file and reopen it. This seems to bypass the issue for most people.

  • UsamaKaleemUsamaKaleem USMember

    Thanks for the reply. Cool waiting for the update but the (5.10 or more) more seems suspecious here and i dont know how frequent you guys release the new versions. And yep it worked. Opening it the second time did it. Cheers

  • AlanMcGovernAlanMcGovern USXamarin Team Xamurai

    I'm going to close this thread as the original issue reported has been dealt with and the other issues in the most recent comments have fixes/workarounds.

    If there are problems with newer versions of Xamarin Studio, then please create new topics in the forums or file new bugs in bugzilla so we can track the issue. Thanks!

This discussion has been closed.