No valid iOS code signing keys found in keychain

NealCulinerNealCuliner USBeta ✭✭✭

And now with the 5.9 and stables I cannot build AdHoc. Xcode is refreshed, wasn't a problem yesterday. Why is this not working in XS 5.9?

"No valid iOS code signing keys found in keychain"

Posts

  • AbelGarciaSaizAbelGarciaSaiz USMember ✭✭

    I'm facing the same problem. I can't compile iOS projects. No solutions proposed in other threads in the forum solved the problem. Last week i finally solved it by clearing keychain and installing Xcode but it's not working again after the update I made yesterday. It's really annoying. What's the reason of that? How do we solve that?

  • NealCulinerNealCuliner USBeta ✭✭✭

    @jstedfast fixed it yesterday per my bugzilla with him, maybe he can shed some light here. From what I gather someone changed how the provisioning profiles are parsed in Xamarin Studio. We're going to need a new build out ASAP

  • JeffreyStedfastJeffreyStedfast USXamarin Team Xamurai

    No, the problem with the Publishing Workflow was that it searched the Keychain for the signing certificate by trying to (wrongly) match each certificate's Thumbprint with a string that was actually meant to be the certificate's Common Name.

    In other words, given the string "iPhone Developer: Jeffrey Stedfast (YZ56349GH7)", it was trying to locate the certificate in the keychain by assuming it was the Thumbprint (which it is obviously not).

    This string is the value gotten from the Info.plist in the .xcarchive directory located in ~/Library/Developer/Xcode/Archives/${ProjectName}${DateTime}.xcarchive

    The second bug I fixed yesterday was in the MSBuild IBTool task which aborted due to an exception being thrown by the logging system when the ibtool command spewed error messages to stderr. This only happens, though, if ibtool fails to compile the xib or storyboard.

  • 15mgm1515mgm15 USMember ✭✭✭✭

    Is there a beta release for the fix?

  • JeffreyStedfastJeffreyStedfast USXamarin Team Xamurai

    Which fix?

  • CaptainXamtasticCaptainXamtastic GBUniversity ✭✭✭
    edited May 2015

    I've got this same problem on fresh installs on my new iMac and MacBook Pro (with new developers arriving this week who will have to do the same setup), what's the recommended work around so that we can hit the ground running?

    EDIT:

    On my MacBook Pro, the following worked for me (however on the iMac I get the following error instead: Pairing with server [ip address]. Reason: No UUID has been set).

    (copied from http://forums.xamarin.com/discussion/39674/iphonesimulator-build-results-in-no-valid-ios-code-signing-keys-found-in-keychain : )

    The resolution for me was to unload the ios project. Open the csproj file, find this element

    BEFORE

    <PropertyGroup Condition=" '$(Configuration)|$(Platform)' == 'Debug|iPhoneSimulator' ">
        <CodesignEntitlements>Entitlements.plist</CodesignEntitlements>
    </PropertyGroup>
    

    AFTER

    <PropertyGroup Condition=" '$(Configuration)|$(Platform)' == 'Debug|iPhoneSimulator' ">
        <CodesignEntitlements></CodesignEntitlements>
    </PropertyGroup>
    

    Removing Entitlements.plist from the CodesignEntitlements element.

  • CaptainXamtasticCaptainXamtastic GBUniversity ✭✭✭

    From my previous post: The iMac error was simply because I had not accepted the Terms and Conditions of the XCode installation ... so the above fix was good for both iMac and MacBook Pro with Visual Studio 2013 installed in Parallels on Yosemite.

  • MichaelKnappMichaelKnapp USMember
    edited June 2015

    Having the same problem in AppStore build mode - so I can't release a new version
    Nm- my cert actually had expired, just assumed it was the same problem as dev cert.

Sign In or Register to comment.