'XamarinShellPackage' package did not load correctly

gfkeoghgfkeogh AUMember ✭✭

I have just installed Visual Studio 2015 Pro RC (release candidate) on a fresh Window 8.1 OS. The installation seems to complete without problems. When I launch Visual Studio I get the error information below, taken from the modal dialog and the ActivityLog.xml file. The same error occurs if I try to create any project dependent upon Xamarin. I am keen to begin work on an iPad demo app, so any advice would be most welcome. Thanks, Greg.

The 'XamarinShellPackage' package did not load correctly.
SetSite failed for package [XamarinShellPackage]
80004003 - E_POINTER
Object reference not set to an instance of an object.


  • gfkeoghgfkeogh AUMember ✭✭

    My apologies, I forgot to search the forums for the word "XamarinShellpackage", and I can see there has been some discussion of this problem already. I'm now examining the threads.

  • VictorGarciaAprea.9996VictorGarciaAprea.9996 USXamarin Team Xamurai

    Hi Greg,

    Let's us know if you were able to fix this.


  • gfkeoghgfkeogh AUMember ✭✭

    By following the advice in another thread, I downloaded and installed Xamarin.VisualStudio_3.11.524.msi . A quick sanity check shows I can now create and build an empty portable project without errors. I know that VS2015 is in RC status, but when I installed it and found Xamarin integration broken I was quite shocked and disappointed. Many web searches produced no useful hints and I was very close to completely giving-up on Xamarin in despair, but luckily someone suggested I ask in this forum and there I found the answer buried deep inside a post among the discussion. This isn't good advertising for Xamarin!

    FYI ... attempts to debug-run the empty Android project give "Invalid pointer" and "larger than 131072 and requires a Business Licence" errors. The Windows Phone gives "unable to verify the virtual machine is running" errors. The iOS app requires me to setup pairing with my iMac, which will take some time and effort. These all seem to be environmental, licencing or config problems for me to deal with, but once again it's an appalling experience and I can see at least another whole day being burned up just to get the "hello worlds" to run.

  • VictorGarciaAprea.9996VictorGarciaAprea.9996 USXamarin Team Xamurai

    I'm sorry to hear you didn't have a great first time experience. We've been working hard with Microsoft to be VS 2015 compatible since almost a year now, supporting previous CTPs releases, RC and RTM soon.

    Did you have previous VS+Xamarin bits installed in the box where you installed VS 2015 RC? When installing VS 2015 RC did you check the Xamarin checkbox for installing it or did you install it separately? Knowing this may help understand what may have gone wrong with your installation.

    What we are doing for VS 2015 post-RC (bits not public yet) is forcing from VS 2015 Setup the installation of specific Xamarin bits version even if your box may have a previous Xamarin installation (one not compatible with VS 2015), this way we can make sure that you are getting bits that will actually work in VS 2015.

    On your other questions:

    1) Android: the errors you are getting are because (I'm assuming) you are using a Xamarin Starter license which has a limitation of 128kb in size for the generated app. Of course the "larger than 131072 and requires a Business Licence" wording is not exactly very friendly... I'll send feedback internally about this.

    2) Windows Phone: this one is most probably not related to Xamarin as we don't include any simulators or VMs for running Windows Phone bits. At first looks like something from the VS 2015 may be missed. What happens if you just try to develop a Windows Phone project (File->New->Project->Windows Phone), where no Xamarin is involved at all? You should get the same error.

    3) iOS: Yes, iOS is a bit more complicated than anything else because of the requirement of having a Mac to pair to in order to build and test your apps, even the simplest ones. I do know what machine(s) setup you are using but you do mention you have an iMac. What we use here all the time is a machine running OS X where we install the Xamarin Build Host and we run Visual Studio in the same machine using Parallels. It may take some time to get the setup properly working, but once this is done, it should work almost seamlessly.

  • GeorgeHahnGeorgeHahn USMember
    edited June 2015

    For others' reference, the 3.11.524 build is linked in this thread (unavailable via dashboard).

    Edit: Worth noting that it didn't solve this issue for me.

  • GeorgeHahnGeorgeHahn USMember

    Uninstalling Xamarin, repairing VS2015, and reinstalling Xamarin solved this issue for me.

  • ChrisChanChrisChan MYMember

    damm lousy product

Sign In or Register to comment.